Acer liquid z2 (z120) single sim root help


Last Updated: 2013-12-12 22:37:32
  1. channELcee

    channELcee Member

    Ok not been on here a while!!!!!!
    Ive rooted a few phones and tablets in the past and i found them all easy as hell, now however im stuck using an ACER LIQUID Z2 (single sim) and cant find how to root it for love nor money. One click soloutions do not work and the extremely rare occasion ive found a thread somewere on tinternet ive been far to cautious to use due to to many brickings by users!!!!!!!!

    As im only using this phone as a temporary phone i wasnt bothered about rooting but ive actually come to like it, so much so im keeping it for the time being (if it works well cheaply, stuff the upgrade)
    The only problem ive come across is NO-ONE seems to have a root guide/any knowledge of how to root this phone.

    This phone is a budget smartphone and i dont see a huge demand for it so devs may simply not bother with it, but to be fair its a decent tidy phone that does what i need, im sick to death of google services updates ripping the hell out my precious storage space. So all though i have no interest in flashing a new rom i simply want root access to move the ever more and more rubbish over to sd card/delete unneeded to free up space for my beloved apps.

    If anyone knows of any other way i can move pre installed apps/services to sd without the need to root (considering this is a jelly bean 4.1.1 os) i would love to be enlightened. Im no expert or android pro but im an ace with google and i cant find anything helpful :(

    thanks to all that have taken their time to read this id appreciate any help

    Advertisement
  2. Rukbat

    Rukbat Well-Known Member

    Have you looked into how to root a phone using adb, as opposed to running some script that some developer may have gotten right (or wrong)?
  3. channELcee

    channELcee Member

    ive seen some info regarding adb and sdk rooting. Seemed more complicated than some of the other ways ive done it. And the one click root is definitely a no go. think ive tried them all now. Ive downloaded official sdk but it wont open. so think I need to figure out why first before I can even manually root anyway. Ive found the guides for manually rooting slightly confusing also. I check for some IDIOTS GUIDES :)
  4. Wussman

    Wussman New Member

    Hi ! Try with Kingo Android . I own an acer z120 single sim too and I successfully rooted it ! :)
    Success ! ;)
  5. Wussman

    Wussman New Member

    Hi ! Try with Kingo Android . I own an acer z120 single sim too and I successfully rooted it ! :)
    Success ! ;)
  6. channELcee

    channELcee Member

    I meant to update this...ooops. I managed to root it using droid tools and another program. not at my laptop so cant remember what the other one was. Im gonna put up a tutorial over the weekend. never tried kingo...may have been simplier. ill have a look tomoz. thanks for your message. took me ages to work out how. lol

Share This Page