[ACS]Root for Transform Ultra


Last Updated:

  1. interdpth

    interdpth Well-Known Member

    Oneclick for all OSs!(Windows, Mac, Linux)

    Download the One Click Root!!! Run the .bat file if on Windows, or the SH file if on mac/linux

    If it doesn't work for some reason. Reboot and you'll have root.

    Samsung drivers if needed -->Drivers for Windows!

    Thanks to the creators of zergRush

    Enjoy your rooted Transform Ultra!
    I don't mind donations and neither does my bud ShabbyPenguin.

    >>

    APK for phone, and an How to video soon!

    Link for root! run.sh for linux/mac and .bat for windows!

    Owning Boost phones since '11
    If first link isn't working properly, use me.
    [​IMG]

    Advertisement
  2. Rally 517

    Rally 517 Well-Known Member

    Beat. Shabby huh??lol
  3. Shabbypenguin

    Shabbypenguin Well-Known Member Developer

    yes and no, i tried the zergrush at first before interdpth got his phone. but i used a version that i compiled myself, which failed so i figured it didnt work. luckily for us interdpth went back and tested a generic version :p
    CellBlock420, Dhamali and latinmaxima like this.
  4. tphillips78

    tphillips78 New Member

    Look at you fancy kids. Congrats.
  5. titan979

    titan979 New Member

    Thank you very much!
  6. MacKHAroni

    MacKHAroni Well-Known Member

    wow thanks a million guys
  7. imfm

    imfm Well-Known Member

    "Rush did it!" I love it. Donation for you for rooting my phone and entertaining me in the process.
  8. LoveMyTardis

    LoveMyTardis Member

    I have a couple of questions about rooting my phone: 1.-Can the phone be un-rooted if needed? If so, is there anyway Samsung would be able to tell it was ever rooted? Just wondering in case of possible warranty service in future. 2.-Is there anyway Boost Mobile could tell if the phone is rooted? If they found out, could they cancel my service? I remember reading something about modified phones in their TOS. I am most anxious to root so that I can access a broader range of software for my phone, I just wanted to weigh the above concerns before rooting it. Thank you very much for your help, LoveMyTardis
  9. interdpth

    interdpth Well-Known Member

    Remove the file su from /system/bin/ and you'll be unrooted!
    DMajor239 likes this.
  10. Hitohax

    Hitohax Member

    Alright I did this just like the tutorial said and its stuck at cleaning up files its been that way for like 5 minutes now what is going on.

    Edit: 3:05pm I am still stuck at cleaning up files and my phone hasn't turned back on
    [​IMG]

    Alright so apparently my phone froze while doing it the first time but I did it a second time and it did it flawlessly and I have a Superuser App :D.
  11. zbban1

    zbban1 Well-Known Member

    Exactly how do I find this file and unroot the phone? Thanks!
  12. zbban1

    zbban1 Well-Known Member

    Well, I guess I got it...deleted files and re-rooted it...power button works again for shutting off phone...we'll see if it stays that way...lol.
  13. badassz24

    badassz24 Member

    i tried this, all i get is this screen

    Attached Files:

    • cmd.jpg
      cmd.jpg
      File size:
      40.3 KB
      Views:
      95
  14. smith058

    smith058 Guides Guide

    make sure you have debugging enabled then try powering off your phone, then turn it back on and right when you see the samsung logo run the one click root
  15. zbban1

    zbban1 Well-Known Member

    Would someone please tell me, in layman's terms, how to properly unroot this phone? The power button and camera button work when they want to and I'm getting tired of doing battery pulls...feels as if I'm back to having a Blackberry. :mad: Thank you very much in advance! :)
  16. smith058

    smith058 Guides Guide

    I don't think having root has any thing to do with that... imo
  17. Shabbypenguin

    Shabbypenguin Well-Known Member Developer

    perhaps he wants to return it to the store ;)

    but wouldnt surprise me, every time there is people that claim root broke 3g/wifi/pron/webbrowsing/app/market/camera/their life etc etc
  18. zbban1

    zbban1 Well-Known Member

    SHE (yes, us girls like techno-toys, too! :D) doesn't want to return it to the store, she just wants the problem solved. I love the phone, 99% of it. Our store said that Boost wouldn't let them return it if it had more than 30 minutes on it anyway. Never heard of that before...

    I never claimed that root broke it, I was simply asking what could have made the buttons not work. I did unroot it and reroot it and it works, on and off. Not a problem...if it was a huge issue then I'd chuck the phone (or see if Samsung would fix the issues under warranty) and buy another one...or wait to see what the Warp is all about...lol.
  19. zbban1

    zbban1 Well-Known Member

    Please tell me how to find this file...
  20. smith058

    smith058 Guides Guide

    download / install "Root Explorer"
    once installed go to your app drawer
    tap the "Root Explorer" icon
    scrole down untill you see "system"
    tap on the word "system"
    scrole down untill you see "bin"
    tap on the word "bin"
    on the top right corner of your screen tap "Mount R/W" icon (it may only show "Mount R"
    scrole way down untill you see "su"
    tap and hold on the word "su"
    a menu should pop up after 2 seconds... choose "Delete"
    DMajor239 and zbban1 like this.
  21. zbban1

    zbban1 Well-Known Member

    Thank you VERY much for your help, but for some reason it's not working. I followed your directions exactly...I checked with root checker and the super user app is still on the phone. I have done it a dozen or more times and still it shows it's rooted. I deleted the file "su", and everytime I've rechecked for that file, it IS gone, but yet it's still rooted. I can't even seem to be able to delete the super user app. I've tried wiping it, etc., etc., etc....I'm done with this phone. Everything I try just doesn't seem to work and it's gone way beyond frustrating. I'm ready to give this phone a toss because with it still being rooted, I won't be able to get warranty work done on it to try and fix the power button and camera button issues. What a waste of $230 and $3.99 for the root explorer app. I guess that's what I get for trying something new (rooting). Ah well, it is what it is...thanks again for your help.
  22. Jon_H

    Jon_H Member

    Sounds to me like a hardware problem more than a software/root problem.
  23. zbban1

    zbban1 Well-Known Member

    I'll agree that it's more than likely a hardware problem, but it doesn't negate the fact that if I can't get it UNrooted I probably won't be able to get it serviced through the warranty. :(

    I'm going to try unrooting it again this afternoon...I don't like to give up on anything without giving it my best...I believe I DID have it unrooted the other day because I managed to get rid of the super user app, but then I rerooted it. I should have left it alone at that point and taken it in, but I didn't.
  24. smith058

    smith058 Guides Guide

    After you delete su, try a "factory data reset"
    Goto settings -- privacy -- factory data reset
    That sould wipe all user data. Hopfully including the supper user app.

    Don't throw the phone away... send it to me.
    Or just wait for somone to get odin to work on this phone... I beleve they are working on it.
  25. zbban1

    zbban1 Well-Known Member

    Oh trust me, I've done a number of factory wipes...lol. That's ONE thing I KNOW where to find/how to do on the phone. :D Right now the phone is just sitting on my desk while i retry unrooting it and such...I went out and bought a flashed HTC Evo 4G (to Boost, of course) so I'm getting it set up the way I want it, installing apps, etc...sweet phone! Missed the big screen of my old Droid X and yes, I do miss the physical keyboard, but overall I love it!

    I would consider sending it to you, but it wouldn't be free of charge. Nowhere near the full price, maybe half or less...I know that it'd be an easy fix for someone who can get it unrooted with a few clicks of the mouse...but I will keep you in mind if the thing gets on my last bad nerve and I feel it's time for it to go...;)

Share This Page