Activate Stock G1 over WiFi


  1. Swizz

    Swizz Well-Known Member

    The original thread, and all of my posts, were deleted in a freak electrical storm that gave me super human strength. Luckily Google Cache managed to save this page long enough for me to hit copy/paste.

    ----

    I've seen a few guides around the internet in regards to activating a G1 over wifi without a data package, and decided to test it myself. Since it worked, I'm compiling the information that I've gathered into one easy-to-read thread. This guide assumes that you have a semi-working knowledge of the command prompt or terminal.

    Standard disclaimer:
    Bricked phones, not my fault.

    The Setup
    1x Stock G1 running cupcake, this phone has no root modifications on it.
    1x USB cable
    1x SD card, at least 128MB
    The image file to downgrade to version RC29 of Android, download here
    ADB for your computer:
    Linux Download
    Mac Download
    Windows Download
    Windows Only:
    AdbWinApi.dll, place in same folder as ADB.exe
    Windows Drivers for Android (Tested on XP/Win7 only) If anyone can confirm these drivers work on other Windows OSs, please post.

    --End Setup--

    1. Ensure that your SD card is formated FAT32, and place the DREAIMG.nbh, that came out of the DREAIMG-RC29.zip file, in the root directory of the SD card. (No, DREAIMG is not a typo.)
    2. With the phone off, insert the SD card into your G1.
    3. While holding down the camera button, turn on the phone.
    3a. You should see a rainbow screen, followed almost immediately by a gray screen. (mileage and colors may vary)
    3b. One of the lines on the phone should read: "Press power button to start update image".
    3c. Press the power button
    3d. Wait for the entire process to complete, do not interrupt! It will tell you it is done updating.
    4. Reboot phone.

    Download the appropriate ADB file for your system, if you're on a Windurrs machine you'll need to download and install the Android drivers as well.

    Ok, we're done rolling back to RC29; and we have access to the 'sploit which gives us terminal access without seeing the terminal.

    Until I tell you to later on, do not touch the screen for any reason. During the rollback process the screen has turned into hot lava and will burn your hand if you touch it. If you can't resist, and touch the screen not only will you be sans one digit but you get to reboot your phone and start over.

    You should now be at this screen:

    [​IMG]

    5. Hit <enter>, type "reboot"(no quotes), and hit enter again.
    5a. If all went well your phone just rebooted, yay good thing!
    6. We're back to the last screen.
    7. Plug your phone into your computer using your USB cable.
    8. If you mistype this step or it doesn't work(because you mistyped), you'll need to reboot your phone and try, try again.
    9. Hit <enter>, type "setprop persist.service.adb.enable 1"(no quotes), hit <enter>
    9b. If all went well you should get an error message saying something like "cannot dial 7387767 7377478.7378423.232.362253 1, it's not an emergency number. This is a good thing, we hope.
    10. Set your phone down.
    11. Open a terminal on your computer, and navigate to the folder containing the adb file you downloaded earlier.
    12. If all is well, you should be able to type "adb" and get a big screen of options.
    13. Type "adb devices".
    13a. You should see the following:
    [​IMG]
    13b. If all you see is "list of devices attached", and nothing below it, reboot your phone and move back to step 8.
    13c. type "adb shell" (no quotes)
    14. Copy and paste "am start -a android.intent.action.MAIN -n com.android.settings/.Settings" into your terminal.(no quotes)
    15. If your copy+paste-fu is strong, you'll see this screen:
    [​IMG]
    16. Hit "Wireless Controls" (The screen is no longer hot lava)
    17. Now you're at:
    [​IMG]
    18. Hit Wi-Fi settingsm you're now at:
    [​IMG]
    19. Turn on your wifi, and configure your network as necessary.
    20. Hit the back button until you are back to this screen:
    [​IMG]
    21. Run the standard setup instructions.

    If all went well, you should now see:
    [​IMG]

    Congratulations, you just stuck it to the man and activated your G1 without the data package.

    Thanks to Noonehereyet for running Get Your Droid On, where you download the DREAIMG.nbh, and where you can find all sorts of G1 builds, rooted or not.

    And thanks to Balazer for catching the missing step 13c.

    Advertisement
  2. justjimjpc

    justjimjpc Premium Member VIP Member

  3. Jayziac

    Jayziac Well-Known Member

    thanks for the info. Hopefully the new myTouch 3G won't have to go through this, or someone needs to come up with a guide for it again. I cringe to think about all the android devices coming out that NEED data plans to activate.
  4. Z06

    Z06 Member

    Hey Swizz its me again, im apparently the reason u made this thread. I was going nuts that i couldn't find it. I still need ur help man. I just cannot get the G1 drivers to install. Ive tried a diff pc with XP and it still doesn't work. Windows just installs its default drivers always. please help me out. I have a paper weight!
  5. justjimjpc

    justjimjpc Premium Member VIP Member


    connect your phone to the pc
    Go into your device drivers screen and you should find either a Yellow ! that indicates a problem or ...
    You might find a Device named ADB Interface ...
    delete them disconnect the phone and shutdown PC and restart ...
    Recheck that you device drivers are all ok and clear of any problems ...
    if not, Delete those as well and shutdown and restart PC ...

    Now you can try to install the proper windows drivers again ...
  6. Z06

    Z06 Member

    tried all that and no go, im on Vista 32 bit SP2
  7. Andorous

    Andorous New Member

    hi!!! i'm sorry guys, this will sound ********, doing all the above effectively means my phone is rooted right?
  8. oOMassacreOo

    oOMassacreOo Member

    Nice guide.
  9. juls1488

    juls1488 New Member

    i am having a little trouble with the image part. after loading the DREAIMG.nbh to the sd card, and the holding camera while the phone powers on, it goes to the rainbow screen, then very briefly flashes the gray screen. it does say loading on the gray screen, but then it says "no image file" and returns to the rainbow screen. I have tried using two different sd cards, and the DREAIMG.nbh from multiple sources just to be sure.
    any input?
  10. MRag

    MRag New Member

    Hi,

    "The original thread, and all of my posts, were deleted in a freak electrical storm that gave me super human strength. Luckily Google Cache managed to save this page long enough for me to hit copy/paste.

    ----

    I've seen a few guides around----------"

    Thanks this is a really detailed and useful post. I'm fairly novice at this stuff but am learning. Project 1 is to activate a stock G1 over wi-fi. I was able follow the instructions and get the phone to reboot when <enter> reboot <enter> is typed in. I'm having trouble getting adb.exe to work. Error message I get says "..failed to start because AdbWinApi.dll was not found". I did download the drivers (Windows) in the above directions and have them in a folder in program files. They do not have the above file but do have another dll file.

    Perhaps there is a thread I can search/follow. Any help would be appreciated. Running Vista.
    Thanks, MRag
  11. oOMassacreOo

    oOMassacreOo Member

    I've seen a few different guides and tutorials for rooting android, but by far this one seemed the easiest to follow for me.

    How To: Root the MyTouch 3G or G1 in One Click! | The Unlockr

    When you downloaded the DREAIMG.nbh was the file in .zip format? When I rooted my phone, that file was in .zip format and it wouldn't show up to flash until I unzipped the file. Try that.
  12. Swizz

    Swizz Well-Known Member

    You need Vista drivers. The ones I provided are XP only.

    No. More or less, if you have a rooted phone you wouldn't even need this tutorial. The purpose is to allow stock G1s to activate over wifi, so they can run without a data package.

    However, flashing the DREAIMG.nbh is the first step towards rooting a G1.
  13. chipfiasco

    chipfiasco New Member

    for steps 12 through 14, where exactly am I typing?
    I'm a newb at this..
    lol
  14. chipfiasco

    chipfiasco New Member

    and another thing..
    I'm getting the gray screen but it says "No Image File!" as it redirects me back to the rainbow screen..

    I've tried this now with the RC29 file zipped and unzipped, and I don't know what the problem could be..
  15. Wesley_minnie

    Wesley_minnie New Member

    Here is the deal. I bought a G1 from a friend. He did a master rest on the phone.( normamly not a problem). Except My t-mobil plan does not include data. My problem is i cannot get past the registration screen without a data plan. Now i did some research and there is a way to do it with wifi. See link http://androidforums.com/support/6564-activate-stock-g1-over-wifi.html probem is, I dont know what the heck they are talking about!!! Can anybody just simplify this for me or know of a different way to go about this? (besides the obvious: get a data plan with t-mobil which i am not in the position to do. Thanks to my credit standings with the company. Gotta love ex-girlfriends)
    you can e-mail me or call wes Please help. ITS CHRISTMAS!!!!!
  16. EVILEMPIRE

    EVILEMPIRE New Member

    sorry to post this message but would this work with windows 7 x86 if not i need bust out my old pc with xp thinking of getting a g1 through a friend
  17. watsupdoc67

    watsupdoc67 New Member

    i followed all of this and it worked great but does this root the phone ?
  18. Swizz

    Swizz Well-Known Member

    no! :)
  19. abonto

    abonto New Member

    Hi guys,

    Is there a similar procedure that can activate MyTouch, Magic, HTC G2 via wireless? If you noticed the G1 has a keyboard to typed the commands:

    Hit <enter>, type "setprop persist.service.adb.enable 1"(no quotes), hit <enter>

    but the phone mentioned aboved are touchscreen without keyboards.

    Please help, I got out the iphone band wagon and selected android, but I need your help to get started. Thank you in advance.
  20. Swizz

    Swizz Well-Known Member

    Oi. This is a tricky one as the files required have only been tested on the G1. By the time the mytouch came out, this particular sploit had been long patched.

    Here is why it probably wont work: The .nbh file to drop it down to RC30(pre cupcake) does not have an on-screen keyboard, thus rendering this tutorial useless for an all touchscreen phone.

    Best of luck
  21. abonto

    abonto New Member

    Thank you swizz for your reply...wow that's a bummer, makes me think that google is worst than apple in terms of marketing their product, forcing all android owners to have a data plan.:-( I'll continue searching for more answers, else I won't have any choice, but to find a different phone.

    I'm sincerely hoping that somebody out here, still has an answer. Thank you guys.
  22. Swizz

    Swizz Well-Known Member

    Well, a choice like that isn't really Google's. The carrier requests these features be put on the phones to ensure maximum profit; hey it's just business. All of the phones that come from Google, the ADP1 and the Ion to be specific, can bypass the initial sign in process. So, not really fair to pin that on Google.

    Second, you may want to root your phone using the goldcard method. A tutorial of which can be found here.

    Best of luck, once more.
  23. vljt221

    vljt221 Member

    I have gone all the way to ADB Devices but it shows offline.. can anyone help me and tell me what I am doing wrong?
  24. Swizz

    Swizz Well-Known Member

    trying running 'adb kill-server'
  25. vljt221

    vljt221 Member

    When I put in adb kill-server it said *server not running*. Then I put "adb devices* and it still daemon starting and still shows offline. What am I doing wrong?

Share This Page