ActiveSync warnings on exchange server caused by Droid users onlySupport


Last Updated:

  1. ahahum

    ahahum New Member This Topic's Starter

    Joined:
    Nov 23, 2009
    Messages:
    4
    Likes Received:
    0
    We have users setup on our coprorate email server connecting using activesync. Most users are windows mobile and iPhones. We currently have 2 droids for testing (one is mine!).

    I get warnings in my exchange server application logs like this. It only began when we started testing the droids.

    Event Type: Warning
    Event Source: Server ActiveSync
    Event Category: None
    Event ID: 3033
    Date: 12/2/2009
    Time: 3:32:30 PM
    User: username
    Computer: EXCHANGE
    Description:
    The average of the most recent [200] heartbeat intervals used by clients is less than or equal to [540]. Make sure that your firewall configuration is set to work correctly with Exchange ActiveSync and direct push technology. Specifically, make sure that your firewall is configured so that requests to Exchange ActiveSync do not expire before they have the opportunity to be processed. For more information about how to configure firewall settings when using Exchange ActiveSync, see Microsoft Knowledge Base article 905013, "Enterprise Firewall Configuration for Exchange ActiveSync Direct Push Technology" (Enterprise firewall configuration for Exchange ActiveSync Direct Push Technology).


    I have modified my firewall here to meet MS's recommendations for timeout values - mine are at 900 seconds. It seems that the droid's activesync is doing something a little different than the standard activesync session with the server.

    Does anyone else manage an exchange server and have access to these logs? Please look to see if you're getting the same warning. It's logged about 1 time per hour. The only thing that I haven't tried is restarting the server after the changes on our firewall. I don't expect this to be an issue.

    Thanks!

    Adam
     

    Advertisement
  2. ahahum

    ahahum New Member This Topic's Starter

    Joined:
    Nov 23, 2009
    Messages:
    4
    Likes Received:
    0
    No one?
     
  3. colnago

    colnago Well-Known Member

    Joined:
    Nov 17, 2009
    Messages:
    3,091
    Likes Received:
    218
    I think there was already a thread(s) on this. Search the main Droid forum...or do a google search.
     
  4. ahahum

    ahahum New Member This Topic's Starter

    Joined:
    Nov 23, 2009
    Messages:
    4
    Likes Received:
    0
    Thank you for the suggestion, colnago, but I have not found any postings on google or this site regarding this particular situation. I searched quite thoroughly before posting.

    If you were able to find something on this topic, I would be very appreciative if you pointed me in that direction rather than just suggesting I search.
     
  5. colnago

    colnago Well-Known Member

    Joined:
    Nov 17, 2009
    Messages:
    3,091
    Likes Received:
    218
    Which Exchange client are you using? You may want to start there and work backwards, esp. if its a 3rd party app.
     
  6. ahahum

    ahahum New Member This Topic's Starter

    Joined:
    Nov 23, 2009
    Messages:
    4
    Likes Received:
    0
    I am using the exchange client built into the OS on the Droid. I am not using any 3rd party software for email.
     
  7. colnago

    colnago Well-Known Member

    Joined:
    Nov 17, 2009
    Messages:
    3,091
    Likes Received:
    218
    Hit up Motorola...I'd help but I no longer have my Droid, so I can't test against our servers. Or try using a 3rd party app to see if you can recreate error.

    Try contacting the people that make Touchdown...their solution seems pretty stable based on comments.

    Or just start a case with Google engineers. They seem to be involved/responsive to the user base.
     
  8. anniedroyd

    anniedroyd New Member

    Joined:
    Nov 6, 2009
    Messages:
    1
    Likes Received:
    0
    Have you tried changing this setting on the server...?

    Heartbeat Interval

    The device specifies the heartbeat interval as part of the PING command. This dictates how long the server must keep the connection alive. The device will dynamically converge to the highest possible heartbeat interval for a given network, based on the mobile operator timeouts, firewall timeouts etc. The higher the heartbeat interval, the better it is for battery life. So the heartbeat is optimized for a given network.

    You can change the minimum and maximum heartbeat interval settings on the server through the registry.

    The settings are MinHeartbeatInterval and MaxHeartbeatInterval under
    HKLM\SYSTEM\CurrentControlSet\Services\MasSync\Parameters

    The defaults are 1 and 45 minutes respectively. Note that the maximum is hard coded to 59 minutes since the maximum possible DAV subscription lifetime is 60 minutes.

    You can also specify a heartbeat alert threshold. The server maintains a sliding window of the last 200 heartbeat intervals supplied by clients. If the average from this sample is less than or equal to the alert threshold, there will be a warning in the event log

    "The average of the most recent heartbeat intervals used by clients is less than or equal to x. Please check your firewall settings to ensure that they permit requests to Exchange ActiveSync to live for at least 15 minutes."

    The alert threshold and sample size can be configured through the registry. The settings are HBiSampleSize and HbiAlertThreshold under
    HKLM\SYSTEM\CurrentControlSet\Services\MasSync\Parameters
     

Share This Page

Loading...