Root ADB not working??

Discussion in 'Android Devices' started by mdonova33, Jul 15, 2010.

  1. mdonova33

    mdonova33 Well-Known Member
    56

    May 23, 2010
    292
    6
    56
    When i go to push files to my phone, i type adb, and it says it is not a command!!
    HELP ME!! IM LOSING MY MIND!!
     

    Advertisement

  2. drdoom

    drdoom Well-Known Member
    93

    Apr 8, 2010
    959
    183
    93
    College Student
    North Carolina
    Did you navigate to the tools folder in the sdk?
     
  3. Jonamerica

    Jonamerica Well-Known Member
    88

    Apr 30, 2010
    158
    193
    88
    Manager of Information Services; Sys Admin
    Boston, MA
    Did you install the sdk? Did you go to the sdk/tools directory?

    Check out The Complete Guide: Root & Everything Else for a walk through (read the Downloads and Getting Ready sections).
     
  4. mdonova33

    mdonova33 Well-Known Member
    56

    May 23, 2010
    292
    6
    56
    woo...got it. wasnt going to sdk..
     
  5. civicsisedan

    civicsisedan Well-Known Member
    93

    Apr 26, 2010
    840
    178
    93
    Army
    Maryland
    when i go into cmd prompt and goto my tools folder and type adb shell

    i get new line with
    ~ #

    and it doesnt let me do anything else after that
     
  6. TheWhiteBandito

    TheWhiteBandito Well-Known Member
    63

    May 2, 2010
    295
    48
    63
    Student / Software Developer / Web Developer
    That is the correct thing to be getting. You can't type anything from there?
     
  7. civicsisedan

    civicsisedan Well-Known Member
    93

    Apr 26, 2010
    840
    178
    93
    Army
    Maryland
    i copy and past the lines to remove apps.. tried from 3 different sites (all have different lines for some reason)

    and always says no such file or directory or whatever...

    i actually got city id off somehow but none of the others like teeter and footprints...

    gave up and moved on...
     
  8. TheWhiteBandito

    TheWhiteBandito Well-Known Member
    63

    May 2, 2010
    295
    48
    63
    Student / Software Developer / Web Developer
    Some sites might be different because some delete the app off the phone using the rm command while others will move the app using the mv command to to move it to a folder that the phone won't look for installed apps.

    Make sure that in ClockWorkMod /system is mounted. If it isn't mounted, your computer won't see it and will give you the error.
     
  9. fishinrick

    fishinrick New Member
    5

    Jul 27, 2010
    1
    0
    5
    I keep getting this message when I run adb shell "adb is not recognized as an internal or external command operable program or batch file" can someone please tell me what i did wrong or what I need to do to get into adb shell
     

Share This Page

Loading...