1. Hot New Devices! HTC One M9 | Samsung Galaxy S6 | LG G4

ADB on the Venture


  1. b_randon14

    b_randon14 Well-Known Member Developer

    Has anyone been able to get ADB to pick up the Virgin Mobile Venture? I can't find any driver downloads for this phone and I can'tget Linux or windows to pick it up using ADB!

    Advertisement
  2. AlexJGonzalez

    AlexJGonzalez Member

    Unfortunately not. :l anyway I can help?. Ima noob but willing to help.lol.
  3. markzombie82

    markzombie82 Well-Known Member

    Wow is there nothing for this phone i had thought about trading in the wfs for this one i have thirty days would that be advised havent really researched it much is it easily rootable?
  4. GreyCelt

    GreyCelt Well-Known Member

    Nothing that I've tried works. I can't get adb to pick it up and none of the commands in Terminal Emulator work for anything. I'm at a loss with this one. The problem is that it's a Chinese off brand so who knows what they used to lock it down.
  5. edthebear

    edthebear Member

    Yes, but not on Windows. I tried drivers from Allcatel's site, Quallcom, the generic Android drivers that come with the SDK and none of them worked. I had to do it through a Linux box running Ubuntu 11.10

    Since I'm a new user here I can't post links or images, but I figured it out from a thread here on androidforums

    If you put this after the slash on androidforumsDOTcom/

    esteem-all-things-root/528294-adb-ubuntu-11-10-a

    and then put a DOThtml on the end, you'll get the link.

    Post number 2, where PlayfulGod talks about /etc/udev/rules.d was especially helpful. I ended up creating two rules files, just to be on the safe side. One is named 51-android.rules and contains this line.

    SUBSYSTEM=="usb", ATTR{idVendor}=="19D2", MODE="0666"

    The other is named 70-android.rules and contains the same line. I don't know which one it uses, and as long as it works, I can live with having an extra one line text file on my Linux box. :) Supposedly a Mac machine doesn't need a driver or a rules file, but I don't have a way to test that.

    After I got ADB working, I worked off of this thread (prepend the androidforums url and add DOThtml to the end)

    virgin-mobile-venture/517720-anybody-out-there

    And tried rooting it with Zergrush. It failed, and there was wailing and crying throughout the land. :( I've tried several of the one-click Root exploits but they all seem to be patched.

    I reallyreallyreallyREALLY wish I'd taken this thing back to BestBuy and got the Optimus V instead before their 30 day return policy expired.

    (If someone who can post links could fix those URLS for me it might be helpful for others... :) )
    divinebovine likes this.
  6. b_randon14

    b_randon14 Well-Known Member Developer

    Yeah : had the same luck. I finally git adb working using linux but no root method has worked so far :-(
  7. edthebear

    edthebear Member

    I got tired of all the phone's problems and got an Optimus Elite. I might try rooting it later just for fun, since I don't care if I brick the thing or not.
  8. Kin Kira

    Kin Kira Member

    I got adb working just fine on my laptop but I've got no idea how to root it from there I can send my phone commands and all I'm just no developer though.
  9. th3gam3

    th3gam3 New Member

    i hope someone can figure this out for me im tired of the ads on the phone and would like more power from this pos. im not really working right now so its the only phone i have till i get this interview im trying hard for.
  10. divinebovine

    divinebovine Well-Known Member Contributor

    Where did you find the USB driver? Got instructions for getting as far as you got?

    I probably won't be able to root it, but there is a non-root hack I want to try for moving unmovable apps to the SD card.
  11. divinebovine

    divinebovine Well-Known Member Contributor

    Ah, figured it out. All I had to do was post about it, and suddenly my brain put it all together, I guess. Installed PdaNet based on half of a clue found buried in some other post about another phone and PdaNet installer provided the driver.

    Once I did that, the app move hack worked perfectly. No more low memory! Additionally I've discovered PdaNet, which apparently will let me USB tether, a function I was hoping to have. :cool:

    Therefore, ADB driver success! OP, install PdaNet and you'll be good to go.
  12. Kin Kira

    Kin Kira Member

    I just gotta thank Windows for some odd reason. I plugged it in with and had no problem. Whats this trick you've got cause I'm tired of low space -.- I've got NO space at all with almost no apps on it.
  13. divinebovine

    divinebovine Well-Known Member Contributor

    As a new user I can't post links, but if you google these terms:
    android move unmovable apps to sd
    you should come up with a site whose domain name is bongizmo dot com, with a blog entry titled "How to move almost all Android apps to SD card (no root required)" By Sergey Povzner Published September 24, 2010. My summary of it:
    1. Install the Android SDK
    2. Maybe install the generic USB driver that comes with the SDK
    3. Connect the phone using USB cable and do not enable USB storage mode. Go to Settings -> Applications -> Development and enable USB debugging.
    4. Start terminal window on your computer (on Windows: click Start, type
  14. slutyman

    slutyman Well-Known Member

    can someone pull the stock recovery and pastebin?
  15. divinebovine

    divinebovine Well-Known Member Contributor

    Got a link to instructions for doing that?
  16. slutyman

    slutyman Well-Known Member

    adb shell ls -l /dev/block

    and pastebin that please
  17. Shabbypenguin

    Shabbypenguin Well-Known Member Developer

    that isnt going to pull recovery, just would have let me know what commands to tell you on how to get recovery.. i was under the impression you had the device since you pm'd me about it :p
  18. slutyman

    slutyman Well-Known Member

    i do have the device adb wont read it
  19. Shabbypenguin

    Shabbypenguin Well-Known Member Developer

    you can always use terminal emulator

    ls -l /dev/block > /sdcard/dev-block.txt

    and then upload it :p
  20. divinebovine

    divinebovine Well-Known Member Contributor

    You need to install PDANet, which magically installs drivers that work with the Venture.

    FWIW, here's the output:
    Code (Text):
    1. # ls -l /dev/block
    2. ls -l /dev/block
    3. drwxr-xr-x root     root              2012-09-11 07:45 vold
    4. brw------- root     root     179,   1 2012-09-11 07:45 mmcblk0p1
    5. drwxr-xr-x root     root              2012-09-11 07:45 platform
    6. brw------- root     root     179,   0 2012-09-11 07:45 mmcblk0
    7. brw------- root     root      31,   7 2012-09-11 07:45 mtdblock7
    8. brw------- root     root      31,   6 2012-09-11 07:45 mtdblock6
    9. brw------- root     root      31,   5 2012-09-11 07:45 mtdblock5
    10. brw------- root     root      31,   4 2012-09-11 07:45 mtdblock4
    11. brw------- root     root      31,   3 2012-09-11 07:45 mtdblock3
    12. brw------- root     root      31,   2 2012-09-11 07:45 mtdblock2
    13. brw------- root     root      31,   1 2012-09-11 07:45 mtdblock1
    14. brw------- root     root      31,   0 2012-09-11 07:45 mtdblock0
    15. brw------- root     root       7,   7 2012-09-11 07:45 loop7
    16. brw------- root     root       7,   6 2012-09-11 07:45 loop6
    17. brw------- root     root       7,   5 2012-09-11 07:45 loop5
    18. brw------- root     root       7,   4 2012-09-11 07:45 loop4
    19. brw------- root     root       7,   3 2012-09-11 07:45 loop3
    20. brw------- root     root       7,   2 2012-09-11 07:45 loop2
    21. brw------- root     root       7,   1 2012-09-11 07:45 loop1
    22. brw------- root     root       7,   0 2012-09-11 07:45 loop0
    23. brw------- root     root       1,   7 2012-09-11 07:45 ram7
    24. brw------- root     root       1,   6 2012-09-11 07:45 ram6
    25. brw------- root     root       1,   5 2012-09-11 07:45 ram5
    26. brw------- root     root       1,   4 2012-09-11 07:45 ram4
    27. brw------- root     root       1,   3 2012-09-11 07:45 ram3
    28. brw------- root     root       1,   2 2012-09-11 07:45 ram2
    29. brw------- root     root       1,   1 2012-09-11 07:45 ram1
    30. brw------- root     root       1,   0 2012-09-11 07:45 ram0
    31. #
    32.  
  21. slutyman

    slutyman Well-Known Member

    never mind he found it :p
  22. Shabbypenguin

    Shabbypenguin Well-Known Member Developer

    holy crap, MTD partitions? how old is this phone? who makes it?

    lol ok well uhhh lets get started then eh?

    adb shell dd if=/dev/block/mtdblock0 of=/sdcard/mtdblock0
    adb shell dd if=/dev/block/mtdblock1 of=/sdcard/mtdblock1
    adb shell dd if=/dev/block/mtdblock2 of=/sdcard/mtdblock2
    adb shell dd if=/dev/block/mtdblock3 of=/sdcard/mtdblock3
    adb shell dd if=/dev/block/mtdblock4 of=/sdcard/mtdblock4
    adb shell dd if=/dev/block/mtdblock5 of=/sdcard/mtdblock5
    adb shell dd if=/dev/block/mtdblock6 of=/sdcard/mtdblock6
    adb shell dd if=/dev/block/mtdblock7 of=/sdcard/mtdblock7

    then lemme know how big each one is, ideally we are looking for 12MB's or less

    does this phone have fastboot? or any other downloading software flashing mode?
  23. divinebovine

    divinebovine Well-Known Member Contributor

    Made by Alcatel, distributed by PCD, branded and sold by Virgin Mobile, running Gingerbread (2.3.5), with low-spec hardware, its purpose is to be incredibly cheap.

    Did you want me to find the size of those, or slutyman?

    Would it be more convenient to do something like wc -c /dev/block/mtdblock0? (Edit: Doesn't work. Nevermind.)

    FYI, here's some mount info...
    /dev/block/mtdblock1 /system
    /dev/block/mtdblock5 /data
    /dev/block/mtdblock3 /cache

    So 1, 3, and 5 are not the one you're looking for.
  24. divinebovine

    divinebovine Well-Known Member Contributor

    Oh and BTW it's /mnt/sdcard not /sdcard...that'd be important to others who are trying this.
  25. Shabbypenguin

    Shabbypenguin Well-Known Member Developer

    ive never dealt MTD phones before so im not sure on how its mapped out etc.

    boot kernel will work but recovery would be ideal. so if 1, 3, 5 arent it then its gutta be one of the others :)

Share This Page