adb shell - error: device not found


  1. ChapelJuice

    ChapelJuice Member

    I've seen different posts about this, but none for the captivate, and none in the past month, so...

    Last night I rooted my captivate using the stickied thread in this forum. Worked great! Simple, and not much to it. I have the Superuser Permissions app in my app list.

    This morning I installed the android sdk and the drivers from the samsung website, enabled usb debugging on my phone, connected the phone, and did the following in my cmd prompt:

    C:\android-sdk-windows\tools>adb shell

    (yes, that is the correct location of the android sdk folder)

    ...but all i'm getting is 'error: device not found'.

    I tried uninstalling my drivers and doing it again, this time connected to a different USB port, and still the same thing.

    Anyone have any insights? I'm able to successfully connect my phone to my machine and view it like a storage device (drag folders around, etc).

    Advertisement
  2. rrrrramos

    rrrrramos Well-Known Member

    Try going to the install directory, then doing

    cd tools
    adb shell
    su
  3. ChapelJuice

    ChapelJuice Member

    Thanks for your quick reply!

    But, I got the same thing. I did notice when I plug it in I get a notification (windows xp) that says:

    "A problem occurred during hardware installation. Your new hardware might not work properly."

    And I only get that message when I plug my phone in while USB debugging is on.

    I've also read that people say to plug the phone in with USB debugging off, then once it's plugged in turn it on, however I'm unable to do this (I get a pop up on my phone that says "Attention USB is connected. Remove the cable").
  4. biocalves

    biocalves Member

    Did you install both drivers from the stickied USB thread? That's what fixed everything for me.
  5. Darkeligos

    Darkeligos Well-Known Member

    Whenever you get an error in the command prompt, try typing this out and then retrying your command:

    Code (Text):
    1. adb kill-server
  6. shocker

    shocker Well-Known Member

    is busybox installed and running on your phone?
  7. ChapelJuice

    ChapelJuice Member

    Bah, I tried all of your suggestions above, and still get device not found. I uninstalled the drivers and installed the ones at the top of the stickied thread, but noticed something a bit strange. I downloaded USBDeview and saw my devices (listed below), but only one of them says it's connected (again, USB Debugging is checked):

    SAMSUNG_Android
    SAMSUNG SGH-I897 Card USB Device
    Communication
    Connected = Yes

    SAMSUNG_Android
    CDC Abstract Control Model (ACM)
    Communication
    Connected = No

    SAMSUNG_Android
    USB Mass Storage Device
    Mass Storage
    Connected = No

    SAMSUNG_Android
    S3C6410 Android ADB
    Vendor Specific
    Connected = No

    Also, I installed BusyBox and have the latest version...but how do you 'run' it? You mean just have the application open when I connect the phone to the machine? I did see that there's a green dot in the superuser permissions app next to it, so does that mean it's running?

    Again, thanks for your help.
  8. keredini

    keredini Well-Known Member

    Make sure you have USB Debugging turned on in Settings > Applications > Development. A few times after rooting / flashing I forgot to turn it back on and ADB won't connect until it is.
  9. iMouseOne

    iMouseOne Active Member

    I've gotten that error before while trying to use the SDK. Even though the computer saw the phone using Mass Storage setting without a problem.

    Wasn't until I plugged it into a different usb port that it worked. Go figure.
  10. ChapelJuice

    ChapelJuice Member

    Yeah, thanks all. I tried it on a different computer and it worked right away, so not sure why my work machine can't get it to run still. Kind of annoying.
  11. ChapelJuice

    ChapelJuice Member

    Okay, so just to kind of close this thread and to hopefully make other peoples lives easier if they're having the same troubles, I finally got this working. How, you may ask? Well, I've read it before on these forums, but I didn't want to believe it. All I did was just kept uninstalling and re-installing the Samsung drivers, and eventually it worked. Didn't do anything else.

    So...if you're having the same troubles as me...keep un/re-installing the drivers, and it should work eventually. :)
  12. yahoowizard

    yahoowizard Well-Known Member

    Try KIES. Go on and click something like Driver Reinstallation. Does the trick.
  13. vwdoc2000

    vwdoc2000 New Member

    I am in the process of rooting and Im getting the same thing. Wh I turn my phone on it shows google with a lock at the bottom. Loads up in the storage setting, I have not mounted it and while typing adb shell i get the same error. I have not been able to complete the rooting process and now my phone is locked at this screen
  14. viking79

    viking79 New Member

    I have a captivate and an intel iMac. What worked for me was to plug the USB cable into the back of the computer instead of the keyboard. It didn't like the keyboard port for some reason. At the same time I removed my Flip Mino (so maybe a conflict, but I think it was the Keyboard port, not everything likes being plugged in there).

    Eric

Share This Page