ADB won't recognize droid, but USB drivers seem to be working fine?


  1. spectrrr

    spectrrr Well-Known Member

    I keep getting error: device not found when I try to use adb with my phone.

    ~Windows XP SP2, 32bit
    ~The SDK is installed and working.
    ~The USB drivers have been downloaded through the SDK.
    ~The phone is in USB Debug mode.
    ~The USB drivers have been installed in windows.
    ~Windows device manager shows that everything is working fine.
    ~Windows recognizes the phone when it is plugged in.

    The ONLY thing that does not work is that the phone won't show up in the list of devices adb sees. Everything else appears to be setup and working just fine!

    Any ideas? It's got to be a simple noob mistake on my part...

    Advertisement
  2. UBRocked

    UBRocked VZW Nexus Please!!! VIP Member

    I had a lot of problems with the USB drivers on Windows 7. I had to delete and reload the drivers a few times before I got it to work...it was a pain in the butt.
  3. spectrrr

    spectrrr Well-Known Member

    WHOOOPS, left out the most important bit of info! The OS! Original post has been updated to include it. I'm running running plain vanilla XP 32bit, so compatibility issues SHOULD be at a bare minimum.
  4. DroidSuks

    DroidSuks Well-Known Member

    From within your tools folder.. e.g. c:/AndroidSDK/tools .... it you type adb devices at the cmd prompt it should list the serial number of your device. Does it do this?.

    Have you tried rebooting your machine?.
    Do you have USB debugging turned on... on your phone?.
  5. spectrrr

    spectrrr Well-Known Member


    No, it does not list any devices.
    Tried rebooting.
    USB debugging is turned on in the phone.

    Question - how do you turn off the adb service? The first time I boot and use adb it turns the service on... but if I change anything and want to try adb again, I have to reboot just to be sure its refreshed. It would be nice to just type the command to stop the service and then restart it :D
  6. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    Once the service is running, it is running unless you kill it in Task manager. That is why it is a service - it is running outside of the normal app space.

    I am not 100% sure, but logging off may also turn off the service, but IIRC, running any adb command will start it again.

    I can see why in your case you keep trying to restart to get verification that the service is running - however, rest assured, if it is not running it will tell you and start it - if ti cannot start it it will generate an error. If it cannot connect to the service that is running ,it will also generate an error.

    So, rebooting every time is kind of pointless.

    Now, as to why it is not working: tell me this, did you let Windows Update install the drivers, or did you go to USB and PC Charging Drivers - Motorola USA and grab the drivers from there?
  7. spectrrr

    spectrrr Well-Known Member

    ahh, just to clarify my previous question a tad, from a debugging standpoint I wanted to be certain that the adb device list had refreshed after I tried anything on my computer (I KNOW its running :)). Force killing it and restarting the service works well enough, not sure why I missed it the first time I looked in the task manager... :)

    I pulled the drivers down from within the Android SDK and then pointed windows at them when I plugged in the phone and it asked.
  8. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    Hmmm, try removing those drivers and using the link I provided then and seeing if that makes a difference....

    As for rebooting, now I understand your rationale - but glad you found it in Task Manager, as well, saving you the reboot / log off trouble.
  9. milrtime83

    milrtime83 Well-Known Member

    Did you connect the phone to your computer and mount it so the computer saw it as a normal usb drive to transfer files before you installed the motorola driver?

    Not sure if this is your problem but it sounds similar to what I was having problems with.
    When I first connected my phone to my computer and mounted it the computer associated a generic usb driver with the phone. After that the motorola driver wouldn't work. It wouldn't let me just update the driver the phone was using. I had to uninstall the generic driver and then install the motorola one for it to work correctly.
  10. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    Lol that is what I was trying to (unsuccessfully, I should add) say when I mentioned the drivers via Windows Update....
  11. spectrrr

    spectrrr Well-Known Member

    Got it.... not sure exactly what did it, lots of uninstalling and reinstalling of any drivers that were unfortunate enough to get in my way :)
  12. bonesy

    bonesy New Member

    Also to kill adb service the command is adb kill-server
    to start it adb start-server
  13. authorwjf

    authorwjf New Member

    Like you I had similar problems getting my Motroloa DROID to show up as a device in Android Device Chooser dialog under Eclipse. I am running the 32-bit version of Windows 7. I found a number of forums that tried to address this issue, but no one seemed exactly sure what was happening, and a number of the sites suggested re-installing Windows.

    It just so happens that prior to doing Android development I wrote device drivers for Windows. So I am at a bit of an advantage here. USB drivers can be touchy, but you shouldn't have to re-install your OS. More than likely what is happening is the OS has associated your DROID with the generic driver that comes with the Windows Android SDK.

    You can verify this by bringing up the Windows Device Manager. If in your root node you see, ANDROID PHONE instead of ADB INTERFACE, this post should solve your problem. Obviously, if you have not already gone out to the Motorola website and downloaded the 32 or 64 bit drivers for the DROID, this needs to be your first step.

    After you run the MSI you downloaded from Motorola, reboot your machine, bring up your old friend the device manager again, and reconnect your DROID. As mentioned in other posts on this thread, you need to have the USB debugging turned on from the DROID's application menu.

    Expand the ANDROID PHONE node, right click, and choose UPDATE DRIVER SOFTWARE. You will be presented with two options, the one you want is BROWSE MY COMPUTER FOR DRIVER SOFTWARE. When the next dialog comes up, select LET ME PICK FROM A LIST OF DEVICE DRIVERS ON MY COMPUTER.

    As long as you have the SHOW COMPATIBLE HARDWARE box checked, you should see a couple options. Ideally, you are looking for MOT COMPOSITE ADB INTERFACE. However, in some cases only ANDROID COMPOSITE ADB INTERFACE shows up. This *should* work as well. The one thing you don't want is the generic ANDROID ADB INTERFACE, which seems to be the default (thus the problem to begin with).

    Click NEXT and the driver will install. Its possible at this point (in fact likely), Windows will force you to do a reboot. Once that is complete you should be good to go. Hope this was helpful!
    eccentric, inshakhan and mndev12 like this.
  14. Drachnem

    Drachnem Member

    I have done everything I read here, I even tried to add my PID to the driver. Shows up as "Android Phone > Android Composite ADB Interface.

    However when I run "adb devices" it does not show my phone. I'm about to call it quits on rooting 2.2.

    I have tried the moto driver, google's driver, and the SDK Driver
    I have tried them all stock, and tried to add my PID
    I installed the JDK stuff as well
    Windows 7 Ultimate, Droid X
  15. psytropic

    psytropic New Member

    I have a question up on the forums as well about what USB drivers to use.

    I have tried the SDK usb drivers and they install fine, but I also get no ADB devices listed. When I go to Motorola's Site and get the drivers there, everything works fine, except I uninstall the bundled MotoConnect app. It seems worthless to me. SO I say go for the USB drivers from Motorola.
  16. pamateriales

    pamateriales New Member

    HI FRIEND, JUST DOWNLOAD THE FOLLOWING FILE MEGAUPLOAD - The leading online storage and file delivery service
    THAT MIGHT BE THE MISSING ABD FILE, UNZIP IT, COPY IT AND PASTE IN YOUR ANDROID SDK TOOLS FOLDER. THEN DO ALL THE THINGS YOU DID, I MEAN OPEN A COMAND PROMPT, cd\ then cd\androidsdk\tools\ and finally adb devices. It should solve the problem. I have another problem, when I run (as administrator) the rsd lite, it starts and shortly afterwards it says "fail" and cleans up the the dialoge line, if you can help me, I be very thankful.

    pamateriales@yahoo.es
  17. tom42

    tom42 New Member

    Even though I had all drivers installed and working, uninstalling the drivers within the Windows Control Panel ("Devices and Printers") while the device (Motorola Xoom) is still plugged in and then installing the adb driver first via www.motorola.com/staticfiles/Support/Experiences/Global_Drivers/MotoHelper_2.0.53_Driver_5.2.0.exe from the official motorola site again does the trick. the device then immediately shows up in the device window within eclipse (Window->Show View->Other->Android->Devices)
  18. inshakhan

    inshakhan New Member

    A simple THANKS button is not enough to thank you! I've spent 2 days trying to get my phone recognized again in the ADB device list & your method worked - after countless other forum posts & other methods that I've tried. To give you some background, ADB worked fine for me when I first installed it - then I flashed CM7 & it didn't work anymore so I've been trying to get it going again.

    I'll post exactly how I did it, in case it will help anyone, because it wasn't EXACTLY as you described. Mine is a Captivate & I'm running Win 7 x64. I did like you said & right-clicked it in Device Manager (for me, it was listed with the yellow ! under "Other Devices" & it was called "Captivate"). I selected "Update Driver Software", then "Browse my Computer", then "Let me Pick from a list of device drivers". It came up with a long list - the top one just said something like "ADB Device" (sorry, I don't remember the exact wording). Then I clicked "Next" & then it said it was successful & it was now showing in Device Manager under the node "ADB Interface" & instead of being named "Captivate", it was "Samsung Android Composite ADB Interface". Then I disconnected the USB, did an "adb kill-server", then plugged in the USB again, then "adb devices" and there it was - finally! Thank you so much!

    - Insha
  19. reggjoo

    reggjoo Well-Known Member

    What if you took all of these steps, and the adb usb drivers, and the drivers for windows xp, won't install correctly. My problem is that's after updating my kernel from 2.2.1 , to 2.3.5(cm6 to playfulmod 7.2), my adb stopped working. I switched back to cm6, and it was working again, switched to 2.3.5, and it still wouldn't work, My driver's seem to install, but when I go to device mgr, it still had the yellow exclamatioin mark! As we know, if windows doesn't see it installed, then adb's no gonna see it. CM6 works fine, and as far as the mounting of the sdcard, that's fine too. I'm working off of the jdk, the sdk, version 9, running eclipse, and using qtadb as a gui. My phone is huawei ascend, but I'm not getting any real answers from that forum, your forum seems to be more helpful. My adb is set up correctly, since just by reverting back to my previous rom, everything works. I think I need to find any and all things (file, and id's) relating to usb fuctions for this phone, and what's changed in this rom(playfulmod 7.2), because some roms spoof the kernel into believing that the phone you're putting it on is a diffrent phone. Can you guys help me?
  20. trurl3

    trurl3 New Member

    I took all steps, install all possible drivers and have in device manager clean position:
    >Adb Interface--> Mot Composite ADB Interface
    but my phone isn't recognised by soft such as Android Commander od QtADB.
    My device is shown in adb cmd window, but is offline...
    When I went to recovery and taped in -> tools adb deamon, then phone was recognized and visible, but after reboot situation returns to 'offline'. What can I do?
    My phone is Moto Defy and ROM CM10 24/09 from Quarx
  21. zaiggen

    zaiggen New Member

    Some times devices like Nexus 10 or Nexus 7 has a little problems with both USB Debugging options enabled and the Media Device (MTP) enabled [Storage -> Menu on tne top right of the screen -> USB computer connection], Disable the MTP (and the PTP if enabled) to left the USB Debugging enabled, hope this works for some Nexus Users. :)

Share This Page