Adventures in USB OTG; what are you using it for?General


Last Updated:

  1. Unforgiven

    Unforgiven -.. --- - / -.. .- ... .... Moderator

    Joined:
    Jun 23, 2010
    Messages:
    31,632
    Likes Received:
    28,597
    Sorry, that was me. I meant to let you know but got called into a meeting at work.:eek:
     

    Advertisement
  2. Highland Ranger

    Highland Ranger Well-Known Member

    Joined:
    Mar 22, 2010
    Messages:
    234
    Likes Received:
    25
    using it for mass storage, seems it can read FAT or NTFS but can't get movies to play from the stick . . .
     
  3. binary visions

    binary visions Well-Known Member This Topic's Starter

    Joined:
    May 14, 2010
    Messages:
    3,334
    Likes Received:
    1,443
    Might be your movie app and/or the codec of the movie. You need to have a movie player app that can handle your movie.

    I was using MX Player and testing it out with a .MKV file that was encoded with H.264.

    The file extension should be obvious, but if you don't know the codec information, the media player on your computer should be able to tell you. For instance, VLC has a menu Tools > Codec Information that will tell you the codec used.
     
  4. chistery

    chistery Well-Known Member

    Joined:
    Sep 9, 2009
    Messages:
    231
    Likes Received:
    7
    I can't get my Sony camera to work. I plug it in and the gallery appears, but no pics. Any suggestions?
     
  5. binary visions

    binary visions Well-Known Member This Topic's Starter

    Joined:
    May 14, 2010
    Messages:
    3,334
    Likes Received:
    1,443
    Are you sure you don't have an additional folder in the gallery, that contains your Sony pictures?

    I've tried this with 4 cameras now - a Canon point-and-shoot, an Olympus point-and-shoot, and two Nikon DSLRs. I also turned on PTP on my Galaxy Nexus and tried it. In ALL cases, the gallery popped right up, and there was an additional folder that had the PTP device's pictures in it.
     
  6. MusicAddict

    MusicAddict Well-Known Member

    Joined:
    Jul 9, 2011
    Messages:
    80
    Likes Received:
    2
    I've seen the note about needing a NTFS kernel but I'm wondering if stock JB will read EXT3/4?
     
  7. asterix007

    asterix007 Active Member

    Joined:
    Nov 29, 2009
    Messages:
    29
    Likes Received:
    2
    Is it possible to use external storage with out rooting the Nexus 7?? I do not want the hassle of rooting the device, I've no other needs which would require rooting. The capability to expand the in-built storage and to be able to play movies stored on external USB stick is very desirable. Can anyone explain if this is possible???
     
  8. binary visions

    binary visions Well-Known Member This Topic's Starter

    Joined:
    May 14, 2010
    Messages:
    3,334
    Likes Received:
    1,443
    Sorry, but right now the only way to use mass storage devices is to root.

    You have other options, such as Seagate's GoFlex Satellite drive:
    GoFlex Satellite Wireless | Seagate

    That's a lot less convenient than just plugging in a thumb drive to your tablet, but you don't have to root.

    It's not impossible that Google will release a software update to correct this issue - but for the time being, it requires root in order to use mass storage devices.
     
  9. asterix007

    asterix007 Active Member

    Joined:
    Nov 29, 2009
    Messages:
    29
    Likes Received:
    2
    Thanks, that's an interesting option. Have you or anyone else tried out streaming over wireless from a hard drive (like the one in the link above). I'm wondering if the performance is reasonable.. Please comment.
     
  10. binary visions

    binary visions Well-Known Member This Topic's Starter

    Joined:
    May 14, 2010
    Messages:
    3,334
    Likes Received:
    1,443
    I have a friend who is using one. He says performance is good - which you'd expect, since you typically stream with the hard drive <10 ft. from the device. He streams HD movies from his.
     
  11. asterix007

    asterix007 Active Member

    Joined:
    Nov 29, 2009
    Messages:
    29
    Likes Received:
    2
    The Seagate Wireless drive has bad reviews on Amazon, plus it is almost as costly as the tablet itself. Media streaming over Wifi has many kinks still, plus in this case there is the added cost of wifi in the hard drive. I'll pass...

    Will keep looking for another way to mount a USB stick... Any other suggestions with out rooting?
     
  12. ydnaroo

    ydnaroo New Member

    Joined:
    Feb 7, 2011
    Messages:
    2
    Likes Received:
    0
    Hi. Does PTP work without the Nexus 7 being unlocked and rooted?

    Cheers - Y
     
  13. binary visions

    binary visions Well-Known Member This Topic's Starter

    Joined:
    May 14, 2010
    Messages:
    3,334
    Likes Received:
    1,443
    Yes, the only function for OTG that you need root for (so far) is mass storage.
     
    4ubest and ydnaroo like this.
  14. binary visions

    binary visions Well-Known Member This Topic's Starter

    Joined:
    May 14, 2010
    Messages:
    3,334
    Likes Received:
    1,443
  15. Claghorn

    Claghorn Well-Known Member

    Joined:
    Feb 3, 2012
    Messages:
    340
    Likes Received:
    45
    I've got some movies too big to fit on a FAT filesystem. Has anyone tried NTFS or other filesystems that will allow large files? (I can't experiment till my OTG adapter arrives).
     
  16. binary visions

    binary visions Well-Known Member This Topic's Starter

    Joined:
    May 14, 2010
    Messages:
    3,334
    Likes Received:
    1,443
    If you read the first post, you'll see that I have an NTFS kernel and tried an 8gb movie just fine. :)
     
  17. Claghorn

    Claghorn Well-Known Member

    Joined:
    Feb 3, 2012
    Messages:
    340
    Likes Received:
    45
    Yea, I saw that you had an NTFS kernel. I didn't see if the stock 4.1.1 kernel was NTFS aware though - I've only rooted my tablet, not installed a new rom.
     
  18. binary visions

    binary visions Well-Known Member This Topic's Starter

    Joined:
    May 14, 2010
    Messages:
    3,334
    Likes Received:
    1,443
    Ahh, I see.

    The stock kernel does not support NTFS. I linked to another kernel - you don't have to install a new ROM. Just install the kernel. No data wiping needed.
     
  19. Claghorn

    Claghorn Well-Known Member

    Joined:
    Feb 3, 2012
    Messages:
    340
    Likes Received:
    45
    Running a "mount" command in a shell, I see that many filesystems are mounted with ext4, so it might be simpler to format the sdcard as ext4 than to replace the kernel. I don't have any Windows boxes I want to talk to anyway.
     
  20. CrackBaby

    CrackBaby Well-Known Member

    Joined:
    Jun 29, 2012
    Messages:
    338
    Likes Received:
    25
    I hope we see a crop of new, tiny usb-to-go adapters with a low profile bust out on Amazon soon.
     
  21. binary visions

    binary visions Well-Known Member This Topic's Starter

    Joined:
    May 14, 2010
    Messages:
    3,334
    Likes Received:
    1,443
    I have a new Cisco/Linksys USB300M USB-to-Ethernet adapter that I've been playing with.

    It's very nice - pretty tiny, and it works well with the Nexus 7.

    Extremely handy for network troubleshooting.
     
  22. CarsnGadgets

    CarsnGadgets Well-Known Member

    Joined:
    May 17, 2010
    Messages:
    1,067
    Likes Received:
    252
    Using my OTG cable to connect my six axis PS3 controller to my Nexus 7, and I'm playing Dead Trigger which works perfectly with the controller.
     
  23. MusicAddict

    MusicAddict Well-Known Member

    Joined:
    Jul 9, 2011
    Messages:
    80
    Likes Received:
    2
    If you get conformation on this please let us other linux nerds know. :p I'm waiting on my parts in the mail.
     
  24. Claghorn

    Claghorn Well-Known Member

    Joined:
    Feb 3, 2012
    Messages:
    340
    Likes Received:
    45
    Actually, I just got a OTG cable in the mail, and tried plugging in the sdcard I had formatted as NTFS, and it mounted just fine, so apparently the stock kernel does have NTFS support (or stickmount works some kind of fuse mount magic).

    Unfortunately, the movie file I copied to the sdcard has a DTS soundtrack which apparently MX Player cannot play (sigh).

    I'm reformatting the card as ext2 now to give that a try (I don't think a journal is really needed for a card I'll only be reading).
     
  25. Claghorn

    Claghorn Well-Known Member

    Joined:
    Feb 3, 2012
    Messages:
    340
    Likes Received:
    45
    Couldn't get that to work at all, so I think I'll stick with NTFS. It apparently really is enabled in the stock kernel, the mount command shows me this after stickmount does its thing:

    Code (Text):
    1. /dev/block/sda1 /storage/sdcard0/usbStorage/sda1 ntfs ro,nosuid,nodev,relatime,uid=0,gid=0,umask=00,nls=iso8859-1,errors=continue,mft_zone_multiplier=1 0 0
     

Share This Page

Loading...