After kitkat update battery drainSupport


  1. SwampRat

    SwampRat New Member

    Hi,

    I updated yesterday from jelly bean to kitkat on Samsung Galaxy S4 O2 Uk network. Everything worked fine, but my battery drains so quickly 1% every 2 mins. When it reaches 30% my phone completely switches off/shuts down, so I have to plug it into charger before I can switch back on!

    I see, from reading some stuff that's about on the net that people are having problems with SG S4 and kitkat, and im pretty savvy when it comes to launchers and whats running in the back ground and what shouldn't be running. I just don't understand how it can drain the battery so quickly?

    I even updated go launcher to latest version to see if that makes any difference, along with all other apps.

    Anyone got any ideas if they're bringing out a kitkat update to fix this? or any ideas how I can stop it wiping out my battery completely at 30%?

    Thanks for your time

    Advertisement
    :
  2. Rukbat

    Rukbat Well-Known Member

    It's a bug in the update. Different phones are getting different bugs. See if O2 has a location that can reflash KitKat to the phone for you or, if not, at least 4.3. (A working older ROM is better than an unusable newer ROM.) If O2 can't, see if there's a Samsung office near you. Samsung has a tool that can do it.
  3. ironass

    ironass Well-Known Member

    This sort of behaviour is not unusual immediately after an update and is not a firmware problem. 2 things that you can do are...

    1. Wipe Cache Partition as per #1.2 of Update Problems - Dummies Guide

    2. Re-calibrate your battery memory by using Battery Calibration, once, and allow a few charging cycles.
  4. SwampRat

    SwampRat New Member

    Thanks guys for both your input, im not sure what to make of it then? is it a bug with this kitkat update or just something random that happens after any update, not sure I understand u both as you say different things?

    I will definitely try that battery calibration app, seems like it would be an easy fix if it works. Altho your advice about going back to jelly bean, I don't really understand flashing roms, lol etc, I have looked up on net how to rollback to jelly bean from kitkat but nowhere says how to do it, apart from an Italian youtube vid that I don't understand.

    I would much rather go back to jelly bean if I could but im guessing that would involve some kinda factory reset? and its a mission to make the phone back to how it was lol. But if its possible and you guys know a noobs instructions on how to restore back to jelly bean I would definitely be interested in that? I did my kitkat update through Samsung kies just fyi.

    Ironass (lol cool name) thanks for the link but the first one wipe cache partition for dummies doesn't work for me, just sends me to blank page?

    Thanks again
  5. icedtea

    icedtea Well-Known Member

    that app is for rooted only.. i tried that. mine is not rooted. i tried a similar app name .. hope this will help. .. :|
    ironass likes this.
  6. ironass

    ironass Well-Known Member

    My bad, as they say. I've been testing a couple of apps. Here's another one for unrooted phones... Battery Calibration Pro
  7. icedtea

    icedtea Well-Known Member

Loading...

Share This Page