After Kitkat update, the battery charges slowlyGeneral


  1. Enzohyeah

    Enzohyeah New Member

    As the name of the thread states, after installing the Kitkat update for my Samsung Galaxy Note 3, it charges extremely slowly. Slow as in 1% per hour slow. I've tried killing all active applications, and disabling Google location reporting with no noticeable improvement. Is there something else I should be doing?
    Please help if you have any ideas.
    Thanks.

    Advertisement
    :
  2. Rukbat

    Rukbat Well-Known Member

    There's one other thing you should be doing. To get an idea of the charging rate, not the rate of the current left for charging after all the apps that are running have used what they need, turn the phone off and see how long it takes to charge. If it charges somewhere around normally, something in the phone is using a lot of current (which is what I suspect). Then look at your battery profile to see what's using all that power.

    If still charges slowly, something in the charging software is off. 1% per hour means over 4 full days to charge the battery, In over 50 years in the electronics business, I can't recall a secondary (rechargeable) battery of any kind that took that long to go from flat to full charge.

    At any rate, the phone is under warranty. If it's not a runaway app that's causing the problem (and that you can just uninstall), bring it in and ask for a warranty repair or replacement.
  3. dontpanicbobby

    dontpanicbobby Guides Guide

    I have no idea why that would be. I just installed the T-Mobile KitKat update tonight with 72 percent power showing at 8:09 PM. After the update it charged to 100% before 10:00 PM when I left for work. I was using the wall wart to charge not a computer USB port. How are you charging your device? and welcome to the Note 3 Android Forums Enzohyeah.
  4. stlouisfan

    stlouisfan New Member

    Have you checked to see if the developer options (usb debugging) are on?
    Had this issue after trying to update to KitKat
    Stlouisfan.
  5. Hazerade

    Hazerade Member

    I had a similar issue. It turned out to be my cable. I want using the factory one. After switching it's good now.
  6. Enzohyeah

    Enzohyeah New Member

    I did what you said, Rukbat, and turned the phone off to charge. It did just fine, then after starting up the battery lasted me from 8a to 11:30p. Problem solved. Thanks a lot for the advice!
Loading...

Share This Page