Aigopad m80D won't connect to WIFISupport


  1. dagx

    dagx New Member

    hello there
    i just came back from a trip to thailand, where i got myself an aigopad m80D.

    i was so excited about it, but when i got back home i was so disappointed that i couldn't get it to connect to any WIFI networks. tried many networks with wep, wpa, and open. nada.. nothing!
    simply won't connect !

    it shows the network name, then when i try to connect it says obtaining ip address and nothing happen. then it shows the name of the network again and tries to connect again. sometimes it would even say the network is not in range. i am really tired. i surfed for hours and read many many pages, but a solution is yet to be found. the company won't even reply to my emails. needless to say, a tablet without wifi is useless :-(

    anyone knows what to do ?

    Advertisement
  2. 3x3

    3x3 New Member

    Is it because of the wifi security encryption?
    If not,May be you should send it back for replacement.
    Where did you get it in Thailand?
  3. dagx

    dagx New Member

    i tried it with different networks and even with opened ones. nothing works.
    now i downloaded the newest update from their chinese website (thanks to google translate) and installed it. now wifi doesn't even turn on/ it only says "turning on wifi" and nothing happens.

    i got it at the IT mall in bangkok. sadly, i am now back in israel. so i don't think i can send it back for repair or anything :(
    i am stuck.
    does anyone know any custom rom that i can try to install on it? maybe it can solve the problem :(
  4. 3x3

    3x3 New Member

    I know the place.IT Mall in Ratchadapisek rd.
    Too bad I'm living in the south now.
    It does come w/ one year warranty,you should try contact aigo Thailand and see if they can help.

    Forums | aigo.co.th

    Not much of the activity in there but may be they can give you some advice.

    I'm going to get mine too.Just order one online and will get it in a couple of days.
    Hope mine don't come w/ that kind of problem.:)


  5. basti65

    basti65 New Member

    Hello there,

    I'm feeling with you. I bought the same tablet about 2 weeks ago and also met the same problems.
    I have several routers here and it wouldn't connect to these who all happen to be wlan n routers. Except for my oldest router which is working by the obsolete g standard. And this one the m80d can connect to. So in my case all the other possible causes like hidden ssid or encryption weren't the culprit. On wireless g I can hide the network and chose whatever encryption. It will allways connect.
    Another work around is to use tethering on a mobile phone. That worked like a charm on both phones I tried it with.

    I hope you can solve the issue this way. Only the fact that you upgraded your tablet with that patch might cause some more trouble.

    Since I live in Bangkok I might help you to get into contact with their shop at Pantip Plaza.

    Hope I could help. Good luck to you ;)

    Basti :)

Share This Page