Ainol Novo 7 Advanced - HELP! Drivers & Firmware questionsSupport


  1. Calab

    Calab Well-Known Member

    I just received an Ainol Novo 7 Advanced tablet... It's currently running Android v2.3.4.

    Two things I'm having issues with...

    #1) Windows 7 64bit drivers.

    I've never seen any kind of Android device shown in the Device manager. I've also never seen an ADB device listed.

    With the tablet connected to my PC all I see added is a Mass Storage Device. USB debugging is turned on. If I restart the tablet in DFU (?) mode by holding Vol+ and pressing Power 5 times I get a "USB Device(VID_1f3a_PID_efe8)" device listed.

    What should my Device manager look like when I connect the tablet? How about when the tablet is in DFU mode?

    #2) Firmware.

    This tablet is running Android 2.3.4 (Gingerbread). Honeycomb v3.2 is available, as is Ice Cream Sandwich.

    I'd like to update to ICS, but the flashing software (LiveSuit 1.07) is not behaving as expected. I get the blank popup window after the device drivers load, but the progress bar never changes from 0%.

    Is there something I'm missing in the process?

    A couple tutorials I've tried to use to update: One Two Three

    Details from my device:

    Model number:
    Novo7Advanced
    Android version:
    2.3.4
    Baseband version:
    2.0
    Kernel version:
    2.6.36-android
    weng@Exdroid #11
    Build number:
    crane_aino-eng 2.3.4 GRJ22 eng.weng.20111125.135834 test-keys

    Advertisement
    :
  2. Calab

    Calab Well-Known Member

    Just to clarify... When I try to use LiveSuit to update, I never see this:

    [​IMG]

    ... When I hold Vol+ and press Power five times, the LiveSuit software automatically jumps to this (with the progress bar still at 0%):

    [​IMG]

    :(
  3. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    Hi Calab. I can't help with your issue, but I've moved your query to the Novo 7 forum, hopefully folk here will be able to assist.
  4. Epic Banners

    Epic Banners Member

  5. Calab

    Calab Well-Known Member

    Thanks... but the Novo 7 Advanced is a different beasty than the Novo 7.
  6. Calab

    Calab Well-Known Member

    I was able to get ICS to update on my Novo 7 Advanced. :D

    I downloaded all of the files again and it seems to have made a difference. I am going to assume that the image file for ICS that I had originally was corrupted and LiveSuit wasn't updating because the file was faulty.

    I guess I'm lucky, as I could have trashed my tablet!!! :eek:
  7. Epic Banners

    Epic Banners Member

    hey, i just got my Ainol Novo 7 Basic yesterday, im planning on updating to 4.0, im just wondering where did u get the update file from, i know urs is advanced but still might help me, the update file i found for basic wont download on my computer for some reason, might be my internet
  8. TJK616

    TJK616 New Member

    New to forum,have been looking for NOVO 7 advanced and would appreciate some direction. To be my first tablet.Can you private message a recommended source to purchase/ I appreciate it. New Guy....
  9. Epic Banners

    Epic Banners Member

    well i have basic and i got mine off ebay, i saw some advanced ones on there aswell, also there is other sites which can be found by using google search
  10. bsharwood

    bsharwood New Member

    I've been trying to do the upgrade now all day, with no luck. Just getting the file from the Ainol site is taking forever. I found one on another site, but it didn't work (perhaps corrupted), so I figure I go right to the source.

    Do you think there might be an issue using a mac to load up the software on the microSD card?
  11. Epic Banners

    Epic Banners Member

    should not matter realy i dont think .. and if ur on about upgrade to 4.0.1 on novo 7 basic then link to my upload at bottom , this one worked for me when doin it by sd card and turnin on with volume + and power buttons .. (plus u need to take everythin off sd card and just have update in )



    MEGAUPLOAD - The leading online storage and file delivery service
    bsharwood likes this.
  12. bsharwood

    bsharwood New Member

    Epic,

    Thanks for the help. And definitely appreciate the fast download. I have tried again with this file but no luck.

    I upload it to the SD card via the USB connection to the device. It's on a card called NO NAME which is in the device, and it looks like I clear it out before uploading your update.zip file. (I empty it and then empty my trash on the mac)

    When I run the updater, I get the little android standing in front of a box with an arrow coming out of it and a progress bar below. The progress bar reaches about 1/3-1/2 along the strip and then I get the same android guy standing in front of a triangle with an exclamation point.

    My only current theory is that my SD card isn't totally clear when I upload it on there. (maybe there are invisible files, which I should try to look at through a command line) Therefore something happens during the update process.

    Maybe I should upload the update.zip file via another device?
    Any other ideas?
  13. bsharwood

    bsharwood New Member

    I'm not sure whether this is problem related, but when I look at the hidden files on that SD card I'm also getting a few extra files called LOST.DIR, ._update.zip, .trashes, and ._trashes.

    Might this be what's preventing the update from working?
  14. bsharwood

    bsharwood New Member

    update again: I've now figured out how to remove all the other files off the SD card except for update.zip. Same thing happens.

    Looking for any other thoughts/advice/ideas.
  15. Re: Calab January 11th, 2012 12:00 PM
    > Just to clarify...


    I see that same screen when I click the second Icon without any tablet connected, have you tried LiveSuit on a different PC?

    Have you tried the 32bit drivers?
  16. nikpartlion

    nikpartlion Member

    Maybe you can help me Calab?
    I'm new to android, and I just got an Ainol Novo Adavanced. I want to update it to ICS or Jelly Bean or something at least newer than Gingerbread.

    I also got livesuite for this, however the program is translated badly I think and it's really confusing.

    Not sure if I have the right ROM or anything...
    Can you send me a link to the ROM that you used?

    Can someone walk we through how to update my tablet through livesuite?

    Thanks,
    Nick.
  17. nikpartlion

    nikpartlion Member

    Messed up my first post..sorry new to forums, disregard this
  18. nikpartlion

    nikpartlion Member

    Also does my tablet have to be off when I use Livesuit?
  19. nikpartlion

    nikpartlion Member

    Update:
    O.K. I worked out how to do the livesuit thing
    1. Start Livesuit
    2. Say no to prompt
    3. Click the button on the left (box/cube thing)
    4. Select the .img to update the tablet

    Now make sure tablet is off

    5. Hold down Volume + button while connecting tablet to PC through USB
    6. Begin rapidly clicking power button until next prompt appears on computer
    7. Say yes to the next prompts and livesuit will do its thing
    8. Turn on tablet.

    One of the images I used malfunctioned and seemed to invert whatever happens when I touch the screen (e.g. Touch at the top of the screen will act like I touched the bottom). This .img also made my tablet vibrate continuously... I couldn't turn it off...

    I tried another image which managed to save me from the malfunctioning one however this image was (I think) still gingerbread...
    The one that messed up was newer than gingerbread

    So now I am back to Gingerbread but at least with a working tablet again *phew*

    I still would like to update though so I can have the play store and everything so if someone can help me in regards to that, that would be really great!
  20. nikpartlion

    nikpartlion Member

    Yay! I now have ICS on my tablet!!

    I found the ROM for ICS here:

    Original Firmware

    Follow the same steps as before, extract the .img from the link above and use it with Livesuit.

    I believe there may even be a newer update for Ainol Advanced on there.
    Anyway just use the latest firmware on there and download :D

    ICS runs better than I thought it would on a 512mb Ainol Advanced Tablet. It can be laggy and things crash occasionally but overall not too bad. :)

    If anyone knows if there is a jellybean update let me know.
Loading...

Share This Page