Alarm Clock not working

Last Updated:

  1. Jigsy

    Jigsy Active Member

    Hi Everyone,

    I was wondering if anyone else had encountered this problem when setting the alarm and it fails to go off at the required time ?

    It happened to me last week, I set the alarm early for work but it failed to go off. Luckily for me I was already awake and thought I had set it wrong. I forgot all about it... Until this morning when it did the same again. I did a test on the alarm and set it go to off after a couple if minutes to test if it was working and it this time it went off properly.

    Has anyone else had the same problem ?

  2. Mine only works if the phone is turned on and isn't on Vibrate or Silent. Its a pain when you can't turn the phone off and still count on the Alarm to go off.
  3. jimeller

    jimeller Well-Known Member

    do you use a task killer??

    killing the clock will result in the alarm not working.
  4. Slug

    Slug Check six! Moderator

    Alarms should still sound even in "Silent" mode. See this thread.
  5. MattW

    MattW Well-Known Member

    You are right - the phone must be switched on in order for the alarm to work (it won't switch itself on in response for an alarm event like an ordinary cell phone) - the penalty of a phone which is more computer than phone :)
  6. Scarps

    Scarps Member

    Yes I've had many failed alarms too.
    I'm assuming that if I see a clock widget on my homescreen that the clock is active and working? Even if I use taskiller or equivalent??

    I've never tried alarm with phone switched off. only sleep mode.
    I've had 1 successful alarm call in 1 month!!!

    Am gonna read that other thread.
  7. Scarps

    Scarps Member

    OK think I sorted out my prob. It is by killing the 'clock' that I disable the alarm even though it says it's set to run with the little clock sign in top right.
    Seeing the clock widget on the homescreen working doesn't mean the 'clock' app that the alarm needs is running.

    So don't kill the clock = alarm goes off.

    set alarm then kill clock = no alarm goes off.

    rubbish but good to know!
  8. Jigsy

    Jigsy Active Member

    Thanks for all the replies guys. It seems as jimeller rightly pointed out Taskiller is indeed the culprit. I really should of picked up on that earlier but I have only had the phone for a few weeks and I have been so busy installing apps that I really did'nt give it much thought. For anyone with a similar problem all I did was opened up Taskiller and held my finger on "Clock" until the options screen came up, once that happen I pressed "Ignore App". Since I have done this the alarm works as it should.

    Many thanks for all the prompt replies

  9. rolue

    rolue Active Member

    Why is this rubbish? If you kill the clock, it's features won't work.
    That's just common sence.
  10. MattW

    MattW Well-Known Member


    Uninstalling task killers would solve most of the 'problems' that people post about on here ;)
  11. daveybaby

    daveybaby Well-Known Member

    Seconded. If youre going to install a task killer then you should at least read up enough to understand what the tasks youre killing are doing.

    If you called up windows task manager and started randomly killing processes left right and centre, would you be surprised if your PC stopped working?
  12. Scarps

    Scarps Member

    If it were so obvious, this thread wouldn't be here.
    Killing the clock in taskkiller doesn't stop the clock from working, nor it's widget, but it stops the alarm from going off whilst still keeping it's icon in the top right. How is that common sense?

    anyway, thanks for the replies. This is a useful thread.
  13. AVP

    AVP Active Member

    I think the original question/problem was answered a long time ago. Why do posters always have to go off subject and start an argument. What are we a bunch of iPhone users??

    By mentioning this annoying characteristic that is common to many forums, I have added another response that in fact does not address the original problem but continues a separate discussion and for that I'm sorry.

    Just thought I would get it out there that I did learn from all your posts that the task killer was the culprit except for the last few posts that went off on a tangent about what is or is not common sense. Thanks for posting btw.
  14. Ivan_Croatia

    Ivan_Croatia New Member


    I have the same problem and I do not have Task killer installed so I guess it cannot be the culprit in my case, can it?

    This morning my alarm didn't work and screen lock was on. If you go to settings/application/manage applications/clock you will find that this application should prevent phone from sleeping and disable keylock.

    If anyone knows a way to fix this - please help. The phone is T-mobile G2 Touch (T-mobile version of HTC Hero).

  15. itandy

    itandy Well-Known Member

    I have been using Hero for a few months now. In the beginning, I did have the "alarm don't go off" problem. Then I add the clock app to the ignore list of Advanced Task Killer and it seemingly solved the problem.

    But recently I found the problem reappear again. This time, I found that if I turn on the screen at the time the alarm is supposed to go off, the alarm will come. But if I left the screen off instead, the alarm will not go off. If I restart the phone, everything will be fine. But sooner or later, the problem will appear again.

    During on incidence, I checked the PID (process ID) of the clock app and found it to be a relatively large number (2xxx). Normally when you restart the phone, the clock app will be launched pretty early so a small PID should be assigned (2xx). A large PID implies the clock app is restarted somehow. Since I have it ignored by Advanced Task Killer, then it must have been killed by something else. I suspect it was killed by Android itself when the memory runs out. It is an automatic process if your memory level is too low.

    This is my theory so far. I'm still trying to proof it. Any input is appreciated.
  16. Ivan_Croatia

    Ivan_Croatia New Member


    I've tried disabling screen lock (settings/sound&display/screen timeout; set to "never timeout"). It draws more energy because your screen will always be on but it solved the problem for me. Alarm works when screen is unlocked.

    I will disable screen lock when I go to sleep and enable it in the morning and that's it for me. If there is more elegant solution I will try it too.
  17. Stratus123

    Stratus123 New Member

    Hi folks,

    Right.. I don't have "taskkiller" or anything like that .. so that's not the problem.

    I love my new phone.. but this alarm thing is driving me nuts. this morning, it just didn't go off.. it really sucks

    I'll try disabling the "screen lock" - another forum I read said you need to make sure that the volume is set to max when you set your alarm - I'll try that too..

    The problem is... that all these things seem to work when you test them, but then the alarm still might not go off in the morning ... Bottom line is, you CAN'T trust it can you? If you can't rely on your alarm clock 100%, it's not useful as an alarm clock.

    I'm seriously annoyed that twice this week i've been late for morning commitments - and I've only just got this phone last tuesday :-(

    I'm going to start using my old phone for an alarm clock until I either sort this one out, or download an app that I can use instead -

    any suggestions on a good alarm clock app?
  18. MarDoubleT

    MarDoubleT Active Member

    Hi all,

    I had a similar issue - had to travel early on a Sunday and the Hero alarm was the only thing I had. Turned out the smartphone was only as smart as the user...

    It's set as standard for a 5 day working week, so it'll only sound on Monday - Friday, so it never went off on that Sunday. Luckily I somehow managed to wake up at 5am...

    Doublecheck the 'repeat' settings. If in doubt, set it to 'never' ie: uncheck all the days. Then it'll sound the next time that time comes around only.

    Does that help?

  19. yinas

    yinas New Member

    Hi guys.

    Motorola Milestone, same prob this morning.

    I just restarted the phone last thing before going to sleep last night, then set the alarm for 07:00.
    Got up at 09:30...
    Alarm time is still present, says it even on the lock screen:
    (current time) Wed, 09:30
    (alarm time) Wed, 07:00

    It just did not go... as if it skipped that minute.

    I dont own any taskiller app (except maybe Astro Filemanager)

    Just gave it another try, alarm went off properly, even with screen locked.

    Btw think I found an entry in Google Code bug reports on this... lets see if 2.1 fixes that.
    Otherwise lets find a trusty alarm app...
  20. SFA_AOK

    SFA_AOK Well-Known Member

    I've had the situation where the time for the alarm has passed, I've pressed a button to turn the screen on, the lock screen appears and for a split second it will appear as a time before the alarm and then it will update straight away to the correct time, causing the alarm to go off.

    I've not had it happen very often thankfully, and when it has happened, it's when I haven't rebooted the phone in a while. I do wish the phone* was more reliable in these sorts of things. Like last night, I lost my data connection - I just assumed it was a temporary thing. Woke up this morning, still not there; rebooted the phone and it was working fine. It'd only been on a for a few days, I don't think that's so unusual...

    I don't have any task killers installed. I do have MCR 3.1 - does that include a task killer as part of its magic to improve the phone's performance?

    * I say phone but with the milestone post above, maybe it's an OS problem :(
  21. TheAppMan

    TheAppMan Member

    My solution to this problem was quite simple:
    Buy Acctim Smartlite Alarm Clock. at - Your Online Shop for .


    Sorry, but, there's no way I'm gonna trust an alarm which maybe sortof kinda works. Imagine the scene when you come in late for work:

    Boss: Why are you late?

    Me: Because the alarm on my super-duper smart, Skynet-like phone which was as powerful as my previous laptop erm......didn't work.

    Boss: :mad:

    Simply not worth the potential hassle, IMO.
  22. Ironic that this exact situation happened to me today and now I'm seeing this post. I woke up almost an hour and a half late when my wife got me up. I wasn't sure if the alarms didn't go off or if I slept through it.
  23. skinnyjerk

    skinnyjerk New Member

    Hello all,

    I have the Cell South HTC Hero, same as the Sprint version, and my phone did the same thing the other day. I HAD taskiller installed, but removed it for other reasons. I noticed after I had uninstalled taskiller, the alarm didn't work. I set the alarm and waited for it to go off, and it did... BUT there was no sound or vibration. So after some playing around I went to the alarm clock, selected the alarm that I wanted, then tried to change my alarm sound. I then noticed that when I changed from one sound to another they didn't play, or make any noise. So while I had the alarm sound open I turned up the volume on the side.... Sure enough there is a volume for the alarm.. and it was all the way down. Don't know why?? but it was.. The alarm had worked in the past, but one day it stopped, and that's what I figured out. It has been working flawlessly ever since.

    Hope this helps.
  24. fabiensf

    fabiensf New Member

    My problem is different... The alarm screen props up but no sound, and the screen crashes! There is no way to get out of the alarm screen except by removing the battery!

    anyone else encounter this??
  25. Ivan_Croatia

    Ivan_Croatia New Member

    This morning I heard the phone VIBRATING! No sound. I didn't set alarm sound to vibrate, just ringtone sound.
    Luckily, it was enough to wake me up but bottom line - you can't trust this phone for alarm. I'm getting old school alarm clock.

Share This Page