Album art problem - linked to database?Support


Last Updated:

  1. joe281180

    joe281180 Member This Topic's Starter

    Joined:
    May 3, 2010
    Messages:
    7
    Likes Received:
    0
    Hi,
    I'm having a problem with the music app on the desire.
    Basically I've got about 2 hundred albums on there, all mp3 with artwork (jpg) embedded.
    Basically there are 6 albums where the artwork does not show up, it just displays the generic music note symbol, the rest of my music all displays the artwork no problem.
    After much experimenting, it turns out that if I change the name of one of the problem albums (to anything - I just added an extra character to the end of the name) then the artwork is displayed. But then if I change the album name back again, the artwork is not displayed. Wierd!
    I'm assuming that there is some sort of internal database on the phone that has got an incorrect or corupt entry for those album names, but I just can't clear it.
    I have tried deleting the 'albumthumbs' directory but this did not have any effect.
    Can anyone think of a way to clear the problem, without doing a factory reset, as I don't want to have to re-set up my apps etc.

    Many thanks
    Joe
     

    Advertisement
  2. Vordyn

    Vordyn Member

    Joined:
    May 15, 2010
    Messages:
    18
    Likes Received:
    9
    Settings -> Manage Applications -> Media Storage and choose clear data, this will wipe the media library database from the phone.

    Now power off and switch the phone back on, go into the Music app or Photo's and Videos and the music library will rebuild ..... this can take a long time, be patient
     
  3. joe281180

    joe281180 Member This Topic's Starter

    Joined:
    May 3, 2010
    Messages:
    7
    Likes Received:
    0
    Thanks Vordyn, thats done it.
     
  4. joe281180

    joe281180 Member This Topic's Starter

    Joined:
    May 3, 2010
    Messages:
    7
    Likes Received:
    0
    Hi,
    After I thought this problem was solved, it has come back again.
    I had followed Vordyn's instructions and that fixed the problem.
    But a few days ago I added some more music and removed a few albums and now I have got a problem where some album art appears corrupted - it looks like green blocks in which you can just about make out the image of the album cover. The wierd thing is that it is affecting albums that previously displayed the artwork just fine. I have tried deleting the media library database as described by Vordyn, as well as deleting the 'Album Thumbs' folder. I also tried formating my SD card and copying the music back on to it, but the problem persists.
    I guess there could be another database somewhere on the phone that has got some bad information in it.
    Any help would be really appreciated
     
  5. chris100575

    chris100575 Well-Known Member

    Joined:
    May 2, 2010
    Messages:
    130
    Likes Received:
    25
    Thankyou Vordyn, I was having the same problem and it was driving me mad!
     

Share This Page

Loading...