ALFA D81 - Help Please on Charging


  1. gilesaj

    gilesaj New Member

    I was given a smartphone by my children (Android 2.3 MTK6515) and it came in a box and I think it is all in Chinese, and the manual is in Chinese as well. It is a ALFA D81 with "Google" on the back.

    I managed to get the battery and the sim card fro my old phone in but I am new to smartphones and need help.

    I plugged the adapter to the house Power and then plugged the USB cable to this adaptor and then the other end of the cable to the phone.

    Nothing seems to be happening though so I was wondering if I have it set up OK, is there some button I am supposed to press ??? The screen remains blank and there is no lights on the phone ?

    Because I don't have a manual in English and can't find one on the web I am running blind. I would have thought that there would be some indication it is charging ???



    Thanks.

    PS: I am an old fart and this is all new to me.

    Advertisement
    :
  2. mikedt

    mikedt 你好 Guide

    You should get some kind of indicator that it's charging. Maybe the charger is duff? Try charging it from your PC or another USB charger.

    BTW I'm always finding that instruction books are in Chinese, but then everything else is in Chinese as well.
    gilesaj likes this.
  3. ExtremeNerd

    ExtremeNerd Well-Known Member

    That seems to be your issue. A battery should have come with your phone and should be used. They generally are device specific and may have connectors in a different place. Try using the battery that came with the phone.
  4. mikedt

    mikedt 你好 Guide

    I didn't notice that in the post. That could certainly cause a phone not to charge, using an incorrect battery.
  5. gilesaj

    gilesaj New Member

    It is only the SIM card that I took from the old phone. The battery came with the phone. Luckily they sent two batteries and one of them works and charges. The other is dead flat and will not charge.

    Thanks for the replies.
Loading...

Share This Page