ALL I want is WiFi tether-Do I need root?


  1. Streetman

    Streetman Well-Known Member

    Can I get WiFi tethering any other way?

    Advertisement
  2. Nu11u5

    Nu11u5 Well-Known Member

    If your phone is rooted you can try Barnacle Wifi Tethering. I'm waiting to get the 1.6 update and root it before messing with it, though. ymmv
  3. psychoace

    psychoace Well-Known Member

    No, the kernal needs to be hacked to support it which it hasn't been.
  4. Streetman

    Streetman Well-Known Member

    You mean it's not hacked on my phone, right? Others have got wiFi tethering on their rooted Behold II, haven't they?
  5. Nu11u5

    Nu11u5 Well-Known Member

    The creators of Barnacle claim that "no custom kernels or ROMs are required". It does not specifically mention netfilter, though, with is a kernel feature commonly needed for some (but not all) tethering apps. If you have root try it and see.
  6. Streetman

    Streetman Well-Known Member

    I know someone in town with a Samsung i7500 who claims she tethers. Perhaps I can chat with her about how I would get it.
  7. Streetman

    Streetman Well-Known Member

    i7500=Galaxy, Behold II's foreign counterpart and nearly the same phone
  8. yatimameiji

    yatimameiji Well-Known Member

    I've tried that tethering app, it doesn't work because we cannot build a kernel with netfilter in place to setup the NAT(network address translation, think of your home router). We can't build a kernel because Samsung will not release the full source as they claim copyright over particular kernel modules. The End
  9. esolveguy

    esolveguy Member

    I read thru all the posts in this forum (and others). Is the conclusion, then, that the Behold 2, even when rooted, can't be used with Barnacle or the Android WiFi Tether app? I've tried both and so far no luck. I even installed the Galaxy ROM and the Galaxy file. With that ROM, I can get the app running and the WiFi SSID to show up, but my computer doesn't obtain an IP address. With the default Behold ROM Barnacle would crash. Has anyone gotten past this or is this a lost cause? I have gotten PDANet to work, but that's a hassle since you need a USB cable connected. (The Bluetooth option would have worked with Android OS 2.x, but unfortunately, Samsung isn't delivering on that upgrade). Does anyone have any other non-wired solutions for the Behold 2? I don't suppose this would work.
    Thx - Guy
  10. masterotaku

    masterotaku Active Member

    I've tried Barnacle, and gotten it to briefly work with a rooted phone and a custom rom. What appears to be the problem is the Behold II's unstable "su" privileges, which keep getting reset.

    I can get it to work briefly on my rooted 1.6 Take5 install after a fresh boot, or after manually using ADB to re enable superuser privileges, but sooner or later something within the anal retentive part of this firmware bh_man wasn't able to beat into submission reverts su, and it stops working.

    When I need to tether out and about, I use my usb cable and PDANet. If I have a need to support more than one system wirelessly, I use the notebook I have the phone tethered to as an ad-hoc hotspot.
  11. esolveguy

    esolveguy Member

    I've gone back to using PDANet myself. That works fine. I was just trying to find a way to eliminate the need to carry around a USB cable, which I often forget.
  12. markanon

    markanon Active Member

    An alternate method, you can tether with no changes to your phone if you use Ubuntu 10.04. I just plug my phone into my computer via USB, setup a new a new mobile broadband connection, and voila!

    On your phone, you need to uncheck "USB Mass Storage Mode Only". I use Open Home, so this is found under Menu->Settings->About Phone ->Additional Settings. If you're using TouchWiz, I'm not sure where it would be.

    In Ubuntu, click the network icon in the upper right, then click "New Mobile Broadband (GSM) connection." It will say that you need your account information and some other stuff... don't worry about that, you don't need it.

    Clicking through the promps, click "united States", then "T-Mobile".
    Under "Select your Plan" click "T-Mobile G1"

    I'm currently writing this post using this method on Ubuntu 10.04.

    woo hoo!:)



    esolveguy likes this.

Share This Page