All In One Recovery Thread


  1. getitnowmarketing

    getitnowmarketing Well-Known Member

    PLEASE NO LINKING OF THESE DOWNLOAD LINKS OR REHOSTING!!! Please direct users to this thread!!!!

    [​IMG]

    This thread is an all in one recovery thread.

    Prereqs:
    1. You must have a rooted device
    2. Adb setup on computer (terminal on phone can be used in place of adb but adb is preferred)

    Supported devices:
    LG Ally (aloha)
    LG Optimus S
    LG Optimus V
    LG Optimus M
    LG Vortex
    LG Chic (alessi)
    LG Optimus P500, Optimus T P509 (thunderg)
    HTC Droid Incredible See link here Xda
    LG Shine Plus
    Gz'One Commando
    Optimus C
    HTC Incredible2 (vivow)
    HTC Rezound (vigor)
    HTC Merge (lexikon)
    HTC Thunderbolt (mecha)
    HTC EVO 4G (supersonic)


    Updates for 3.06:
    Recovery and some binaries are recompiled for arm6-vfp or armv7a-neon which on most devices gives a notable increase in speed.
    Added gui ability to restore clockwork mod 3x, 4x, & 5x backups.
    Added the developer menu: see below for many new features.
    Lg devices I figured out the kernel api to reset the FACT_RESET_3 from doing a privacy wipe. This mode will automatically be checked & reset to FACT_RESET_6 so you will not get stuck in recovery.
    Added ability to wipe /system & /sdcard
    Key mapping on aloha & shine plus now use Vol-up & Vol-dn power and back so keyboard is no longer used.
    Removed battery % check from nandroid.

    Want to submit a new device see thread here : http://androidforums.com/getitnowma...new-device-recovery-creation.html#post2714334

    Recovery Features:

    ADB as root user

    USB-MS Toggle :mounts sdcard as mass storage

    Backup/Restore:
    Nand Backup : Select Items to backup with the [X]
    Nand Restore : browse to and select nandroid backup to restore
    Nand Restore Clockwork : browse to and restore cwn backup
    As of 2.2.1 sd-ext is backed up as whole so link2sd users should work fine

    Flash Zip From Sdcard: Update.zip must be in root of sdcard or you can directory browse. (Fixed dir-browsing)
    Toggle Signature Verify : Turn of signature checking on flashing zips

    Wipe Menu:
    Wipe data/factory reset: wipes all
    Wipe cache
    Wipe Dalvik cache : Wipes Dalvik cache in all possible locations if moved by apps2sd
    Wipe SD:ext : Wipes Apps2sd ext partition
    Wipe Battery Stats
    Wipe rotate settings
    Wipe data only
    Wipe system
    Wipe sdcard
    Wipe .android secure : Wipes froyo native .android_secure on sdcard

    Partition Sdcard:
    Partition SD: Partition's sdcard for apps2sd (this formats card so all non backed-up data is lost)
    Repair Sd:ext
    SD:ext2 to ext3 : coverts apps2sd ext2 partition to ext3
    SD:ext3 to ext4 : same as above but ext3 to ext4 (requires kernel support for ext4 which all but shine have)

    Mounts:
    Gui mounts to avoid typing in terminal to mount and cd into a dir to mount system, data, cache, sd-ext (if exists), sdcard

    Other:
    Fix Permissions
    Move recovery log to SD
    Key Test : Output keycodes for debugging recovery
    Check Battery Lvl

    Developer menu:
    Make and flash boot from zimage : This makes a mkboot folder on sdcard and mounts sdcard as mass storage then you copy a zImage and kernel modules into this folder and it will create a new boot like anykernel and flash it.

    Install su & superuser: Installs or fixes su & superuser install (removes old if exists)
    Install eng (unguarded) su: Installs engineering su that doesn't use superuser (removes old su & superuser if exists)
    Reboot to bootloader: reboots to bootloader/hboot
    Reboot recovery : reboots phone back into recovery

    I have included flash_eraseall binary to recovery which can be used to fix/erase corrupted partitions that will not mount correctly to nandroid restore to.
    Useage from adb shell is : flash_eraseall /dev/mtd/mtd4 (where mtd4 is the number of the partition from "adb shell cat /proc/mtd" you want to erase)

    Trouble Shooting:
    1. Use option under Other menu to move recovery log to sd. Mount your sdcard to pc and read that file called recovery.log. It should have detailed cause of error.
    2. If you get an out of memory error reboot device and do it on a fresh reboot.
    3. If you get a file not found on the "mv /system/etc/install-recovery.sh /system/etc/install-recovery.sh.bak" skip it and move to the next step as this file will not be in your rom unless it has recieved an ota-update and if so needs to be disabled.
    4. Permission denied means you are not root user (#)
    5. If rebooting into recovery you get a little android guy with a ! and does not look like picture above you still have stock recovery and did not remove the install-recovery.sh.
    6. You did check the md5sum for a match before flashing correct?

    Please check all the above issues before posting. This is the format I request to be used for troubleshooting.

    Device :
    Recovery Version :
    Error :
    Please upload the recovery.log AS AN ATTACHMENT that you moved to sdcard and read. Posts without this log will be ignored!!!
    Please no PM's!!!!!

    Device system paths:
    Ally: /dev/block/mtdblock4
    Optimus M: /dev/block/mtdblock5
    Vortex: /dev/block/mtdblock4
    Optimus V: /dev/block/mtdblock5
    Optimus S: /dev/block/mtdblock5
    Optimus P500/Optimus T: /dev/block/mtdblock1
    Chic: /dev/block/mtdblock1
    Shine Plus: /dev/block/mtdblock1
    Optimus C: /dev/block/mtdblock5
    Commando: /dev/block/mtdblock2


    Directions to flash recovery:

    UPDATED Easy install via script:

    MUST BE ALREADY ROOTED:

    1. Download and unzip recoveryflash.zip onto sdcard. You should have a folder called recoveryflash on sdcard after unzipping.

    2. Place the recovery.img you downloaded in this folder in /sdcard/recoveryflash and then turn off sdcard as mass storage . (Do not rename the recovery.img from the download)

    3. Reboot phone and wait for sdcard to mount (about 5 - 10 seconds) after you see home screen.

    4. Become root user in abd shell or terminal emulator with command without quotes "su" & you should have a # prompt

    5. Enter these commands in terminal emulator or adb shell # prompt one at a time and press enter after each line. If anyone has trouble with the 1st line you can also use a root enabled explorer like root explorer or estrongs and copy/paste the recoveryflash.sh into /data/local and then start with the 2nd line.
    Code:
     
    cat /sdcard/recoveryflash/recoveryflash.sh > /data/local/recoveryflash.sh
    chmod 0755 /data/local/recoveryflash.sh
    /data/local/recoveryflash.sh
    
    6. It will automatically install & reboot you into new recovery. Using the script above your old recovery.img was copied to /sdcard/dump-recovery.img. If you had the stock recovery copy that file to a safe place as running the script again will overwrite it.

    Old manual way:
    Download your device specific recovery and check md5sum for a match before flashing. Download flash_image.zip and unzip it to root of your sdcard. (Not in any folder)
    Copy your devices recovery.img to root of sdcard.

    Below can be done via adb shell or terminal emulator on phone via root # shell not a $ shell
    Note do not type the # or $ as they are for reference only!
    Code:
    $ su
    # mount -o remount,rw -t yaffs2 (your device /system path) /system
    # cat /sdcard/flash_image > /system/bin/flash_image
    # chmod 755 /system/bin/flash_image
    # mv /system/etc/install-recovery.sh /system/etc/install-recovery.sh.bak
    # flash_image [B][COLOR=black]recovery[/COLOR][/B] /sdcard/(your device recovery.img name)
    # sync
    
    Example for LG Ally above would be:
    mount -o remount,rw -t yaffs2 /dev/block/mtdblock4 /system

    Device specific recovery keys:

    Key mapping for Optimus Line & Vortex:
    Move up & down = Vol-up & Vol-down
    Select = Menu
    Backup = Back
    Boot recovery from device off: Vol-down + Home + Power and release at LG logo.
    Chic(alessi): Vol-up + Vol-down + Power

    LG Ally & LG Shine Plus:
    Move up & down = Up & down on sliding keyboard | vol-up & vol-dn on 3.06
    Select = Enter on keyboard | Power on 3.06
    Backup = Vol-down | back on 3.06
    Boot recovery Ally: Send + Menu + Power
    Boot recovery Shine Plus: Vol-down + Home + Power

    Commando:
    There is no known way to boot recovery from device powered off. To enter recovery its adb reboot recovery or use many of the apps from market to reboot into recovery. This means that if you flash a bad rom or boot.img you cannot enter recovery to fix and will have to get a new phone. Be carefull!!! You have been warned.


    Adb reboot recovery can also be used to boot custom recovery on most devices.

    WARNINGS:
    Do not flash a radio.img

    Source for recovery & recovery kernels My Github

    Special Thanks:
    Thanks to :

    Amon_Ra for his awesome source and a few pointers. His original Source Link Buy him a redbull
    Worstenbrood's desire recovery Link
    My many testers (too many to name one by one)

    MD5's for 2.2.1:
    fcccddea6110fa6bcf676bdc409e0261 recovery-RA-alessi-2.2.1-GNM.img
    05f57d682efe7845f7584087aa533ebb recovery-RA-aloha-2.2.1.1-GNM.img
    f370e39969c8ce4bdd0dd18b897cddeb recovery-RA-optm-2.2.1-GNM.img
    4a8e8d4a64cc027020f6dc2e1371a6ee recovery-RA-optS-2.2.1-GNM.img
    354419bf92ea0bfcc2609e88243a8889 recovery-RA-optV-2.2.1-GNM.img
    368e7e2fa2e5962040e3ee00f02f39c2 recovery-RA-thunderg-2.2.1-GNM.img
    97e551cdcf6574f86da237fd4259c755 recovery-RA-vortex-2.2.1-GNM.img
    14a7a269ddc1173cc1a8bf00ea4cf443 recovery-RA-shineplus-2.2.1-GNM.img

    MD5's for 3.06:
    eb0668a7c7f2b82e6ac02362a620668b recovery-ra-alessi-3.06-gnm.img
    4207aa235c3c6132e1544d85d1b15fb8 recovery-ra-aloha-3.06-gnm.img
    7848d5b729497ac8ebf3c5cfef87483d recovery-ra-commando-3.06-gnm.img
    c280fc5cfacf1018211f9ed4ffd42d87 recovery-ra-dinc-3.06-gnm.img
    9f7bf7f3668221a25861f4783cdb733b recovery-ra-lexikon-3.06-gnm.img
    ccd64cadf2b98e8f446e79d5a5c3d1a8 recovery-ra-mecha-3.06-gnm.img
    ed89883f8be5a780701f23c54b281df5 recovery-ra-optc-3.06.img
    4039dab9b98fea1ea6f4fbcbd75fbd77 recovery-ra-optm-3.06-gnm.img
    00eb45621474648d6b0cdda0b31b06b8 recovery-ra-opts-3.06-gnm.img
    3882b2b74d855b03bca6016300d84b79 recovery-ra-optv-3.06-gnm.img
    d4ca1d65a05be881f8fd6d54695d8408 recovery-ra-shineplus-3.06-gnm.img
    2976958267bb43c5c15a18739f90ace4 recovery-ra-supersonic-3.06-gnm.img
    aa9402d7c91fa5b3045d50aaaeedfa86 recovery-ra-thunderg-3.06-gnm.img
    8f5551165bdc7c3fec3845312dc96269 recovery-ra-vigor-3.06-gnm.img
    c2e2f9af9607e9334b5e268c7b23e050 recovery-ra-vivow-3.06-gnm.img
    e47260ee2b5294585002ae8519131012 recovery-ra-vortex-3.06-gnm.img


    Download Link -old for 2.2.1
    Download Link 3.06
    Donation link to Buy me an Energy Drink is below:
    [​IMG]

    Contact me on twitter @getitnowmarket

    Advertisement
  2. azuma73

    azuma73 Well-Known Member

    Reserved for future use. Thread still under construction.
  3. dinlaca

    dinlaca Member

    I was one of your (few) donators.

    Wondering if you will be adding support in your recovery for the LG Thrive (ATT GoPhone) or LG Phoenix (ATT Postpaid) phones.

    I can provide you whatever image files (or directory information) that you might need to construct such a recovery.

    Alternatively, if you don't have time to do this, if you can give me some pointers so that I can build my own, that would be much appreciated.

    Thanks for letting me know.
  4. wrath_00

    wrath_00 Well-Known Member

    doesn't work on the optimus v followed directions to the letter. when reboots go to lg screen flashes then boots to android.
  5. getitnowmarketing

    getitnowmarketing Well-Known Member

    Can you try to do "adb reboot recovery" and try? Perhaps I have the keys to boot wrong. You also removed the install-recovery.sh correct? If still having issues I'll need the exact kernel config from stock. With the most current stock rom can you pull me a kernel config with "adb pull /proc/config.gz" and upload that for me please? I used LG's defconfig for opt V as I didnt have a actual device config handy. There have been issues with bad defconfig files in other LG sources.
  6. baldrob

    baldrob Member

    This is great that you are making a recovery for the commando. It's been rough these past two weeks running a stock rom after coming from cm7 on my incredible. I'm in the early stages of a rom for the commando now, but had no idea how I was going to get it on my phone when finished.
  7. nwh10

    nwh10 Active Member

    I had your recovery utility ver. 1.2.5 installed on my Ally. I tried to install 2.2.1 using adb shell and the seven lines of code shown in your original post above.

    At the 5th command (the mv line), I received an error message: File not found. I checked the directory, and install-recovery.sh did not exist, so it makes sense that it couldn't be renamed.

    At the next line (the flash_image line), all the instructions scrolled up the screen with the message "Out of memory". This makes no sense. There is 20MB free in internal memory.

    Please advise how to correct. At the moment, if I boot into Recovery, all I get is a blue screen, and I have to pull the battery to proceed.

    Thank you.
  8. getitnowmarketing

    getitnowmarketing Well-Known Member

    Please read items #2 & #3 in troubleshooting.
  9. nwh10

    nwh10 Active Member

    Thanks - sorry - missed the troubleshooting section because it came before the installation instructions. :)

    However....I rebooted, went through the instructions from the top (except for the mv) and am still getting the out of memory error.
  10. getitnowmarketing

    getitnowmarketing Well-Known Member

    That oom error is for virtual mem not actual free space on /data btw. No idea why you get that after fresh reboot. Must have a bad ram leak in an app. If you already have a version of my recovery boot into recovery and type:

    Code:
    adb shell
    mount /sdcard
    flash_image recovery /sdcard/recovery-RA-aloha-2.2.1.1-GNM.img
    
    Then reboot
  11. nwh10

    nwh10 Active Member

    As I mentioned in my first post, when I boot into recovery, I just get a blue screen. If there's any text, it appears as microscopic white specks. Have to pull the battery to boot phone.
  12. getitnowmarketing

    getitnowmarketing Well-Known Member

    You aren't still using 2.1 eclair are you? The new one requires you to have froyo. The blue screen is fastboot. You can use the android sdk to flash the recovery via the blue fastboot screen on ally. Command is fastboot flash recovery nameofrecovery.img

    Else grab my slightly older 2.2.1 from rom manager which will work on both eclair and froyo.
  13. nwh10

    nwh10 Active Member

    I'm on Froyo 2.2.1.

    >>You can use the android sdk to flash the recovery via the blue fastboot screen on ally. <<

    Can you give me a few more specifics, please? Here's what I did:

    Booted phone to recovery mode. Blue screen (fastboot) appears.
    Connected phone to computer via USB.
    Computer doesn't recognize the USB device.
    Launched adb shell
    Error message (after starting daemon): device not found.

    Edited a few minutes later:
    Adb shell is probably not the right command.

    From computer at command prompt, launched fastboot devices. Received error message that AdvWinApi.dll is missing from computer. I'll reinstall SDK.
  14. elomic

    elomic New Member

    why is that when i click on the download link for mediafire it just loads forever and does nothing else.
  15. nwh10

    nwh10 Active Member

    GNM,

    I'm not having any luck communicating with the phone when it's in fastboot. When I the phone is in fastboot and connected to the computer via USB, the computer says "USB device not recognized", etc. Not a good sign, and I don't know how to install the driver. And then when I issue the command "fastboot devices" from the cmd prompts, the devices don't display. The cursor just comes back at the DOS prompt. There is no error message.

    The phone connects to the computer and accepts adb shell commands with no problem if it's not in recovery mode.

    Suggestions?
  16. getitnowmarketing

    getitnowmarketing Well-Known Member

    Nwh10 no idea why you are having so much trouble use the version in rom manager to make it easy. Fyi if using windows you need fastboot driver I wrote for aloha. Its in original ally recovery thread.
  17. HaoSs

    HaoSs New Member

    hello guys, i have a little problem, can't restore a 1 day old backup... error " : Verifying backup images... md5sum: WARNING: 1 of 1 computed checksums did -match Error: md5sum mismatch . "

    and 1 more question, are the backup done whit the 2.2.1 custom recovery compatible whit the 1.1.0 ?
  18. nwh10

    nwh10 Active Member

    GNM,

    Yes, I'm using Windows.

    To recap:
    From normal phone operation, when I hold down the power button & select Recovery, the phone boots to a blank blue screen with no writing.
    Then I connect the phone to the computer.
    The computer reports "USB device not recognized."

    I have been to the original Ally recovery thread here:
    http://androidforums.com/getitnowmarketing/146564-ally-recovery-img-here-custom-roms.html
    and then downloaded the AndroidSDK kit (android_ally.rar) on Mediafire.

    I replaced the Android SDK I was using with the one contained in the rar. There were slight differences.

    Rebooted the computer.

    From the blue screen (fastboot) mode & connected to the computer, I have gone to Device Manager and updated the Unknown Device driver by pointing to android_winusb.inf. The computer says the device is already using the best driver.

    From a DOS prompt, the fastboot command either waits forever for a device or doesn't find the device.

    The path to the directory containing the driver is in the environment variables. The computer has been rebooted several times. The phone has been rebooted to the blue screen several times, and is still not recognized by the computer.

    So I guess there's still something wrong between the fastboot driver and the device. What step am I missing to force the device, when in blue screen fastboot & connected to the computer, to be recognized by the computer?

    If I can't get past that problem, how can I get around the out of memory error (described upthread) that occurs when I run flash_image from adb shell?
  19. wrath_00

    wrath_00 Well-Known Member

    As soon as I can get to a computer ill send it my computer is fried. I'm running the optimus v so if someone could pull the file needed and post it it would be a big help.
  20. nwh10

    nwh10 Active Member

    GNM, just want to report the outcome of the problems I was having. I went to IRC #ally per your PM suggestion, and found a person there who got everything straightened out. It wasn't pretty....he ended up going back to stock rom and moving forward from there. It involved several utilities, forcing a key to write to the registry, and more. But I'm back in business running Velocity 1.1 and your 2.2.1 recovery.

    Thanks for your efforts and for pointing me in the right direction.
  21. chefjw

    chefjw Member

    Okay so tried this on my Optimus V same thing as Wrath00. Using both the key combo and adb reboot recovery it just stalls then boots normally. I have the config.gz file I just need to know where to upload it to be honest. Zipped the config and made it an attachment.

    Attached Files:

    Masema and wrath_00 like this.
  22. wrath_00

    wrath_00 Well-Known Member

    Cool. Thanks maybe when GNM gets a chance he can rework the recovery.
  23. daveman

    daveman Member

    If you could please sir put a sticky with a link to this in the optimus m - all things root. The only way to find this thread over there is to search thru the older methods to find the post with the link.

    Thanks for your hard work!
  24. chefjw

    chefjw Member

    So anyone know how to completely remove whatever this walkthrough does so I can try a different recovery without having any issues.
  25. chefjw

    chefjw Member

    Okay so I was able to get into recovery once but it locked up and could not makes choices or anything. And now when I go back to adb shell its not letting me SU its saying permission denied. Not sure wth is going on cause I have SU installed and Titanium Backup and have made backups of stuff and installed SetCPU for root

Share This Page