All In One Recovery Thread


Last Updated: 2014-05-19 10:12:42
  1. Zoandroid

    Zoandroid Well-Known Member

    I have been in the habit of making a weekly Nandroid backup, and every time I do I find myself wishing that RA recovery would list the name of the Nandroid file it just created before I reboot and dig up that information with a file explorer (I keep a log for the Ally and copy down these Nandroid names as they are made).

    Could this be a possible feature upgrade for RA Recovery, to list the Nandroid name when it is done creating it?

    Advertisement
  2. aperseghin

    aperseghin Active Member

    ok this is BS,
    search is STILL BING ! ! ! wtf
  3. dots

    dots Well-Known Member

    Why were you expecting something differnet? All this is for is to flash the custom recovery image.
  4. aperseghin

    aperseghin Active Member

    OOPS MY BAD, wrong thread... i meant to post thin in the thread for breakneckmod4.. sorry
  5. teh_dude

    teh_dude Well-Known Member

    http://androidforums.com/optimus-m-all-things-root/352401-do-not-use-clockwork-mod-rom-manager.html

    There had been a variety of users who ran into the same basic problem, and if I'm not mistaken, it points mainly to the use of CWM. Simply installing ROM Manager itself causes no harm of course.

    Agreed.

    I'd like to provide an analogy for you to illustrate that using a more efficient way is not, as you seem to imply, a bad idea. Take for example two different methods in basic Calculus on how to take a derivative of a function. The basic understanding in either case is that the derivative of a function yields another function that represents the slope of the original at any given point. If you're already familiar, cool. If not, just think of slope in common sense terms--skiing down a mountain that is sloped either steep or gently.

    Taking the derivative the manual way, you must take the limit of the function plugged into the difference quotient as h -> 0. For an example, I'll use a basic equation: y = f(x) = x^2:

    d(x^2) = lim.. (x+h)^2-x^2 = lim.. x^2+2xh+h^2-x^2 = lim.. 2xh + h^2 =
    ....dx.......h->0....... h........... h->0.......... h............... h->0 h .......h

    lim.. (2x + h) = 2x
    h->0

    Or, you can take the derivative the super fast way, by simply reducing the exponent by a value of 1, and applying the original exponent as a coefficient of your variable. Demonstrated with the same function as above, f(x) = x^2:

    d(x^2) = 2x^1 = 2x
    ....dx

    Now if you're already familiar with this, you'll know what I'm talking about. If you're not, that's okay. Surely you can still see the MASSIVE difference in efficiency. In fact, the second method shown here is vastly used, and the first method is only taught practically as a formality to show where it comes from. You can learn what a derivative really is with either method. Once you start taking derivatives of much more complicated functions, it becomes impractical and illogical to use the long method.

    Just the same, while I recommend that all new rooters heavily investigate what they're doing, understand what it is that they're doing, have a backup plan and a way to revert what they're doing, and overall be completely aware of the consequences, both potential and guaranteed, I believe that a rooter can understand these consequences in this context without going through and manually typing a bunch of stuff in ADB. Just the same, I enjoy administrator access on any computer I own, but I enjoy it at the level of a competent user--not a Windows developer.

    Efficiency is a good thing, and is sufficiently separable in this context from the issue of knowledge vs ignorance.

    EDIT: All of the above said, while it doesn't take much typing to manually flash a recovery, I look forward to when ROM Manager compatibility issues are addressed, and/or someone makes a competing app that achieves the same goal.
  6. infamous-blob

    infamous-blob Member

    when I enter the command : cat /sdcard/flash_image > /system/bin/flash_image the terminal says " cannot create directory becaude it is read only"
  7. chaveza427

    chaveza427 New Member

    Model: LG Vortex
    Problem:
    when entering
    cat /sdcard/flash_image > /system/bin/flash_image
    I receive this:
    /sdcard/flash_image: no such file or directory
  8. teh_dude

    teh_dude Well-Known Member

    look where you put flash_image on your SD card. is it in any folders? for example, for anything I intend to install like this, or any zips I want to flash, I always put them in a folder on my SD card named "a". So in my case, I had to modify the statement to "cat /sdcard/a/flash_image....", so it would look in the correct location.
    DaniellieeE and chaveza427 like this.
  9. chaveza427

    chaveza427 New Member

    Yeah I found it, thank you so much, it worked perfectly once I realized I had the stuff in a folder named "recov"
  10. KingOfGreen

    KingOfGreen Well-Known Member

    did you run the "# mount -o remount,rw -t yaffs2 (your device /system path) /system" correctly? this mounts system as read/write
  11. netizenmt

    netizenmt Well-Known Member

    This Custom Recovery works very well, once you figure out those commands.

    BY the way, don't sell the LG Vortex short. It's a decent phone and a good successor to the Ally if money is an issue for you. (I got mine free after $50.00 rebate.) It's extremely easy to root and there is very little need for a custom ROM. Just delete the crap you don't want and install what you do. AND it runs Netflix! :)

    I do miss knowing what's going on in the Ally community though. Doesn't look like anything juicy has emerged on the Custom ROM scene since Velocity 1.1 though. StormDroid isn't out yet, nor is CM7... and nothing else appears to be happening.
  12. stpx88

    stpx88 New Member

    Sorry, I am noob to this, but Im not that clear on what Im supposed to do. I have the LG Optimus M. Can anyone please help.
  13. KingOfGreen

    KingOfGreen Well-Known Member

    download the flash_image file and the recovery specific to your phone and download terminal emulaior on your phone and run said commands, BAM custom recovery. check the 1st post, it says it all
  14. zorgo

    zorgo New Member

    Please someone tell me the code to get into the custom recovery for the lg optimus one please i need help i've tried for hours please reply and tell me
  15. dots

    dots Well-Known Member

    Do you mean by a command in terminal or a hard key combination. Cause the hard key combinations are listed in the original post.
  16. star2doc

    star2doc Member

    Netflix also appears to run on the Optimus M...
  17. Aplus

    Aplus Well-Known Member

    A little choppy, but, yeah, it works.
  18. niket

    niket New Member

    when i coded
    $ su
    su
    # mount -o remount,rw -t yaffs2 /dev/block/mtdblock1 /system
    it showed sumthing like this
    "Usage : mount[-r] [-w] [-o options] [-t type] device directory "

    # cat /sdcard/flash_image > /system/bin/flash_image
    it showed sumthing like this
    "cannot create /system/bin/flash_image:read-only file system "
    please tell me what to do,..
  19. niket

    niket New Member

    You must unzip flash_image.zip into root directory of sdcard (not in any folder)[/QUOTE]
    and u answered




    when i coded
    $ su
    su
    # mount -o remount,rw -t yaffs2 /dev/block/mtdblock1 /system
    it showed sumthing like this
    "Usage : mount[-r] [-w] [-o options] [-t type] device directory "

    # cat /sdcard/flash_image > /system/bin/flash_image
    it showed sumthing like this
    "cannot create /system/bin/flash_image:read-only file system "
    please tell me what to do,..
  20. sixpack

    sixpack Active Member

    This worked perfectly thanks a bunch!
  21. niket

    niket New Member

    hey @ SIXPACK pls help...
  22. sixpack

    sixpack Active Member

    Not sure in your case but did you do the following:

    <Assuming you are using adb from pc command prompt> After you issue the su command it asks for permission in your phone for superuser approval, after you approve, did you then select the mount as mass storage on your phone again?

    Don't exactly remember if that's how I did it but I think so.

    Cheers!
  23. niket

    niket New Member


    no i hav used terminal emulator got permission 4rm superuser..and then typed those commands bt it showd sum different
  24. sixpack

    sixpack Active Member

    Maybe you are not fully rooted? I heard there are two kinds of root. But besides that I have no idea, hope you figure it out.
    niket likes this.
  25. prabha4u4ever

    prabha4u4ever Member

    how to get the command screen where i can perform all these operations said by you..i know its a combination of keys but pls guide me the keys

Share This Page