All In One Recovery Thread


Last Updated: 2014-05-19 10:12:42
  1. tovida

    tovida Member

    Thanks it works... It gave me some kind of error in the end. Something like "mtd: bad read at 0x00000000" but when I went to the terminal emulator and typed reboot recovery it restarted and gave me the picture above!

    Advertisement
  2. jaykf014

    jaykf014 Member

    Running ally 2.2.2. Rooted with superoneclick. Attempted flashing recovery as described. No errors when issuing commands. Used terminal emulator to do it. Entered command 'reboot' at the end. Held the buttons in on boot to enter recovery. I ended up in safe mode. Did I miss something?

    EDIT:
    Joined IRC and had a discussion with some folks there. I ended up downloading "quick boot" app and was able to boot into both fastboot and recovery that I had flashed. I just now turned off my phone and attempted booting into recovery - it worked this time.
  3. EvolutionMr

    EvolutionMr Active Member

    when ever i type in su in adb shell it says permission not granted.. any help?
  4. UtilityPole

    UtilityPole Member

    I've run into a problem. Every time I type in the line:

    # cat /sdcard/flash_image > /system/bin/flash_image

    I get the message "No such file or directory". What am I doing wrong? Thunderg's stored on my sd card, phone's rooted, su has permission. :confused:

    Make sure you've installed SuperUser onto your phone. Once you've done that, open up the cmd promp. type in 'adb shell', hit 'Enter'. Then type in 'su' then hit Enter. Right after you do that, look at your phone- SuperUser will be asking you to grant it access- select 'Yes'.
  5. shroomster

    shroomster Member

    Is the mediafire link not working anymore from OP?
  6. Mud-and-Guts

    Mud-and-Guts Member

    Any info on the commando testing?
  7. AUTiger99

    AUTiger99 New Member

    I installed the latest scottsroms on my LG Optimus S and now my phone won't boot past the All In One Recovery menu. Please help!
  8. EdAndInn

    EdAndInn Well-Known Member

    :D

    Great recovery!

    Thank you very much for this Recovery recovery RA optm 2.2.1 GNM.img

    Worked well on my LG Optimus M.

    I used FlashImageGUI App to flash this to my phone.

    I then flashed PlayfulGod CyanogenMod Custom ROM successfully using this Custom Recovery.

    Kudos to you!

    :D
  9. netizenmt

    netizenmt Well-Known Member

    A friend of mine has the LG Axis from All-Tel, which is basically the same as the LG Ally. I know from reading elsewhere that custom ROMs for Ally do not work on the Axis. I was wondering if the All-In-One Recovery would work? Or if anyone is aware of a Custom Recovery for the LG Axis. Basically I'm looking to backup the original firmware and then remove the bloatware. Don't really need or want a custom rom. Thanks!
  10. wiihacker

    wiihacker New Member

    I used FlashImageGUI App From the market to flash the recovery-RA-vortex-2.2.1-GNM.img to my wife's rooted 2.2.1 Vortex last night and it worked great.:D
  11. getitnowmarketing

    getitnowmarketing Well-Known Member Developer

    Ive been long afk from android. Look for a major update on all recoveries soon as I just finished writing the code.
    dautley and alfick3 like this.
  12. sixpack

    sixpack Active Member

    Awesome! I can't wait! Thanks for all your work!
  13. getitnowmarketing

    getitnowmarketing Well-Known Member Developer

    Updated all
    Alexcess likes this.
  14. asrhael

    asrhael Member

    Hi guys!, today i decided to flash a new kernel to my LG P500h phone (Optimus One, Thunderg) but i dont want to permanent install the Custom Recovery, so i tried to boot from Fastboot interface and then flash the ZIP.

    My way was using the command:
    , and my P500 boot ok the recovery, but the menu doesnt work (with the volume key) and i cant enter to any option listed. With this way, i thought upgrading the kernel using the "zip method".

    Why can i boot temporaly to this recovery from Fastboot?, all the UI looks ok during the boot, but i can manipulate it! :[...someone have an idea? (i tried with the recovery-RA-thunderg-2.2.1-GNM.img too)

    Thanks a lot!
  15. getitnowmarketing

    getitnowmarketing Well-Known Member Developer

    Please someone else confirm on an optimus device for 3.06. I hope I didn't mix up the recovery binaries for the entire optimus lineup.
    asrhael likes this.
  16. asrhael

    asrhael Member

    Me again!, finally i decided to install the Custom Recovery to my system (instead of booting). The recovery-ra-thunderg-3.06-gnm.img works like a charm!, i flashed using Fastboot, specifically the command:

    And now i have the Paolo Kernel on my P500h. Thanks developer..and please say me how works the "uninstall option"..i saw in some part of the option list.

    Best regards,
    Asrhael
  17. asrhael

    asrhael Member

    Why the "Developer menu"->"Reset LGE boot mode" doesn't work?.
    When i press it, Ra-thunderg 3.0.6 dont ask me for the "yes/no" and just nothing appear to be changed on my system.

    Best regards,
    Asrhael
  18. getitnowmarketing

    getitnowmarketing Well-Known Member Developer

    It does work. I have it check for fact_reset_3 upon boot and reset it to mode 6. That item also manually changes it. Read your recovery.log after having used it via cat /tmp/recovery.log or use the move log 2sd option.
  19. asrhael

    asrhael Member

    Thanks in advance for your help man. In my recovery.log i have the next lines:

    I don't see any warning like the other options when i use the MenuButton in the "Reset LGE boot mode".

    Can you help me with this? thanks a lot!

    Best regards,
    asrhael

    Attached Files:

  20. getitnowmarketing

    getitnowmarketing Well-Known Member Developer

    Its only to check for fact_reset_3 that gets you stuck in recovery if you do a wipe via settings/privacy. You had mode_1 so it was ignored. No need to mess with it as its auto deteced. Im actually going to remove the menu to manually change it as I have it already checked and done automatically if needed.
  21. asrhael

    asrhael Member

    Thanks dev, I understand that the "fact_reset_1" prevents me from restoring the LGE boot. I also understand that you're working in a version that allow to the end user to change this value allowing us to restore the LGE boot successfully.

    If you have some news, please tell us!

    PD: This is another question, and i hope you have the answer :] . Why can't I boot only your *.img directly from Fastboot?. The image is loaded fine, but the keys doesn't work (the menu is "static").

    Best regards,
    Asrhael
  22. getitnowmarketing

    getitnowmarketing Well-Known Member Developer

    No its fact_reset_3 not 1 that prevents rebooting normally out of recovery. I have no idea on thr fastboot boot to boot it from ram. I use that all the time on the devices I own. I however do not have any Lg's but the lg ally so I cant tell you why your device does that Ive never heard of that happening to anyone else either. Are you using the bootloader from a different device?
  23. rom67

    rom67 New Member

    I have a Optimus T p509 (which I successfully rooted using Z4root) and every time I put in the code to flash the recovery I get the error message: create /system/bin/flash_image: read-only file system... I have used a terminal emulator from the market and adb shell and I have tried many times with no luck....

    Any help would be greatly appreciated!
  24. Jamdat1243

    Jamdat1243 New Member

    A quick question.
    Your new link for 3.06 contains a flash_image file but it isn't zipped. The old link for 2.2.1 contains a flash_image.zip file. Since your instructions indicate that the zip file must be unzipped, I'm a bit confused as there is no zip file for 3.06.
    I compared the MD5 checksums for the 3.06 and 2.2.1 flash_image files and they are different.
    Has the flash_image been updated for 3.06? Is there something wrong with the download?
  25. asrhael

    asrhael Member

    Hi getitnowmarketing. Im using a "enabled fastboot", because my device has it blocked by default.

    I followed the next guide for do it that: xda-developers - View Single Post - [HOW TO] Fastboot on LGP500

    Bye!

Share This Page