Ally Recovery.img is Here!!! Custom Roms!!!


  1. AFGadd

    AFGadd New Member

    Hi Guys,

    Having a few difficulties installing the image. Everything goes fine until I run "flash_image recovery", then the cmd box says
    Code:
    can't find recovery partition
    Any advice would gratefully appreciated,

    Using a (UK) T-Mobile GW620 with V10U_00 (1.6) firmware.
    The mobile is rooted with superuser.

    Many thanks,
    Andrew
  2. getitnowmarketing

    getitnowmarketing Well-Known Member Developer

    Its not made for your device. This is for VS740 LG Ally Cdma Verizon only.
  3. AFGadd

    AFGadd New Member

    OK, thanks very much for you swift response.
  4. bamaredwingsfan

    bamaredwingsfan Well-Known Member

    I just tried to install recovery via the sdcard with terminal emulator, and got the same error above. Then when i did the reboot, it would show a bluescreen that said something fastboot? And only way i could get the phone to get out of that screen was a battery pull.
  5. getitnowmarketing

    getitnowmarketing Well-Known Member Developer

    Nowhere in my instructions did I ever say to use terminal on the phone. Use adb shell or fastboot. Best way is from inside recovery follow starting from step 1.
  6. bamaredwingsfan

    bamaredwingsfan Well-Known Member

    Yeah i missunderstood your post:D But anyway i got it now :eek: Good thing i didn't brick the phone, the old lady would raised some kind of hell on that hahahaha
  7. flick159

    flick159 Well-Known Member

    Thank you very much for this. Your tutorial was very thorough and easy to follow.

    Stupid question, are there any key bindings for the recovery? As in, when at the recovery screen, can you select items from the list or are all of those commands done with a root prompt in adb?

    Forgive the noobish-ness, just curious.

    Thanks again.

    EDIT: Nevermind, figured it out. Opened the keyboard and used the d-pad.. duh lol
  8. rsy8806

    rsy8806 New Member

    Hey i had that same thing happen? what did you do to correct it? did you just end up using adb shell through the computer? let me know..

    Thanks
  9. swc2001

    swc2001 Well-Known Member

    Hey there drellisdee first off thanks for everything you have done in this forum. I am a new member of this site. However I have been lurking for a while trying to get this custom backup system up and running. Seeing that I am a Noob and haven't done anything like this in years I have been less than successful. Well I will try and cut to the chase. I can't get past go hardly. When I go to the adb shell and I get the $ sign I type Su and I get permission denied. I have tried with my phone and my wifes. Is there anyway we could talk on this site and maybe get me walked through this. Man I sure would appreciate it. Again your awesome Thanks so much

    swc2001
  10. getitnowmarketing

    getitnowmarketing Well-Known Member Developer

    You are getting that error because you are not rooted. That part is assuming you are already rooted. Look in the how to root ally thread for a app that I linked for 1 click root. Or else follow the steps exactly from step 1 on and you can do it without root.
  11. swc2001

    swc2001 Well-Known Member

    WOW!!! Ok that is so Cool.
    It was EASY EASY EASY!!! Even this 32 year old man could do it.
    I found this thing called reading helps.
    So what all can you do with this? Is anybody Gunna make a Early Version of Froyo 2.2 that can be Flashed to the LG Ally? LOL that would be super Cool.

    swc2001 is embracing his inner Nerd right now. LOL :)
  12. swc2001

    swc2001 Well-Known Member

    Well so here it is... Thanks to everyone on this site especially drellisdee.:D
    [​IMG]

    Well my next question is how extensive is this Nandroid backup thing-a-ma-jig. I mean its only 275 MB in size? What all does this thing backup?
    Does it back up all your apps and settings and all that good kind of stuff?

    My first impression was that it is an exact image of the phone... AKA you could go get yourself a brand new Ally out of the box and put this on it (provided you put the Nandroid backup system on it) And it would be a clone of the original phone having all the same apps having the same background and ring tones etc etc. Is this the case?

    Also I saw this Google Backup thingy in it. What is that?
    Basically it would be super awesome for all of those nifty features in this Nandroid Backup Recovery system to be detailed out and told what they are and what they do. Maybe you guys have already covered it somewhere i just missed the memo. (that happens to me alot) I seem to miss stuff even when its in front of my face. Well anyeway I really appreciate it everyone.
    I really look forward to what you have to say about this drellisdee.

    FROYO FTW BABY!!:D

    Attached Files:

  13. Vmanisme

    Vmanisme Well-Known Member

    It backs up an image of your phone. So yes apps and all that but I am not sure on flahing it to another phone because every phone has its unique ID for OTA, I could be wrong but as far as I know its impossible to flash ur nandroid backup to another phone. Someone correct me if I'm wrong
  14. z0mbiexx

    z0mbiexx Member

    when the droid scene first got root and a recovery most the roms were basically just someone elses phone they modified and put up as a nandroid to download. so for the droid atleast it can be done.
  15. swc2001

    swc2001 Well-Known Member

    Hey Vmanisme thanks for weighing in. on this
    Number one it is awesome that this little thing backs up EVERYTHING that is really great. However the reason i asked this question was I was wondering what whould happen if your a clutz like me and you I dunno drop your phone in the lake.:eek: Yes I have done that with my Lg EnV back in the day. It was completely fried. LOL So I had the insurance and I got me a brand new EnV... THe only thing was.... It was stock no games no ring tones no background NO NUTTIN. It stunk!! LOL So I was hoping it was kind of like creating an image for a computer that could be put on any machine with the same specs and same motherboard. That way "you really never lose anything no matter if even the worst case happens." I really hope that is the case. That was the big draw for me.

    BTW Vmanisme I saw your Thread for fastest Ally because of some Rom I think? You think you could PM me more about this... It sounds really Cool.
    I am assuming you flashed this to your Ally using the Android Backup System in the begining of this thread. Hey Thanks again

    swc2001
  16. swc2001

    swc2001 Well-Known Member

    Now thats what I am talkin bout!!!
    Can someone confirm this for the Ally.:D

    z0mbiexx thanks... I saw you have this Velocity thingy too. maybe you could PM me so I dont hijack this thread to a different discussion.

    Thanks.

    swc2001
  17. Vmanisme

    Vmanisme Well-Known Member

  18. getitnowmarketing

    getitnowmarketing Well-Known Member Developer

    Yes you can flash your nandroid to another ally and it will have a carbon copy of the phone you took it from. The roms we are making are from a /system and /boot from a nandroid.
  19. swc2001

    swc2001 Well-Known Member

    Wow That is really Great drellisdee!!
    That really opens up the world on these phones.
  20. getitnowmarketing

    getitnowmarketing Well-Known Member Developer

    updated recovery.
  21. Bradferguson

    Bradferguson Member

    I am getting a permission denied when i try to flash the new recovery. its the RA_GNM_v1.2.1.img. i have clockworkmod now. any help would be great. Thanks
  22. getitnowmarketing

    getitnowmarketing Well-Known Member Developer

    please use v1.2.2 as the usb mount storage button is mapped wrong on v1.2.1. Please post more detailed info on what method you used to flash it. Copy of your cmd prompt shell would be ideal.
    Bradferguson likes this.
  23. Bradferguson

    Bradferguson Member

    Microsoft Windows XP [Version 5.1.2600]
    (C) Copyright 1985-2001 Microsoft Corp.

    C:\Documents and Settings\Compaq_Administrator>cd c:\android\sdk\tools

    C:\android\sdk\tools>adb shell
    $ su
    su
    # flash_image recovery /sdcard/recovery-aloha-RA_GNM_v1.2.1.img
    flash_image recovery /sdcard/recovery-aloha-RA_GNM_v1.2.1.img
    flash_image: permission denied
    #

    Hope this helps . and where do i find v1.2.2
  24. swc2001

    swc2001 Well-Known Member


    Hey Brad That is the exact same thing that has been happening to me as well.
    Has this happened to anyone else?

    So Drellisdee where do we pick up version 1.2.2 ?

    Also what is the real difference between the version 1.13 and these new recovery systems 1.2.1 / 1.2.2. Its my understanding that the original version couldnt flash froyo but the latter can. Is that correct?

    What are the official loading instructions for this new Recovery are they the same as with the old? I loaded the old recovery system with the Terminal on the phone. It worked like a charm.

    Do you somehow have to take version 1.13 off then put 1.2.2 on?

    Anyway Thanks a miliion to all who are involved.... good stuff.
  25. dots

    dots Well-Known Member

    It's at the bottom of drellisdee's original post.

    On Another note. After i flashed v1.2.2 i get the verification error no signature when trying the flash update zip option. This happens when i tried flashing the Velocity rom, my own custom rom, as well as the kernerl drellisdee made. (This also happened when i flashed v1.2.1)

Share This Page