[ALPHA] ICS for Optimus M (NOW COMPILED AND BOOTING)


  1. tripdoc79

    tripdoc79 Well-Known Member

    yeah none of that is working lol.. pretty much.. it boots lol.. the apps work.. half of the settings dont work.. wifi doesnt work, telephony doesnt work.. list goes on lol

    but one thing i have noticed.. its not very laggy.. which means when its functional it should run pretty smooth.. thats a plus
  2. PlayfulGod

    PlayfulGod Well-Known Member Developer

    check the RIL stuff, most of the time thats what will keep talk and text from working
    tripdoc79 likes this.
  3. AndroidHogs

    AndroidHogs Well-Known Member

    Ok if you have problems flashing this just use Reppards flashable kernel. that will help you get it flashed on your phone if you have any problems. :) ICS YAY
  4. Misleadb4

    Misleadb4 Well-Known Member

    It flashed just fine for me and booted up normally, cant do much but it was the novelty of having Ics on the om for a minute or two that had me try. Now cant wait to get stuff workin on it, good job everyone, thanks. ^
    tripdoc79 likes this.
  5. reppard

    reppard Well-Known Member

    Like PG said the Ril binaries are needed for the phone service. For the sdcard you will need to edit the fstab file, i believe its located in the /etc dir. You might have to go into the init scripts to get the sd working as well. Let me know when you get service and I can help you out with the apn so txt works out of the box. Good work Tripdoc!
    droidhaxz, mikekelso421 and alfick3 like this.
  6. DeadlyFoez

    DeadlyFoez Active Member

    Sorry man. I did not mean to tell you what you already knew. I'm just trying to report what has not already been mentioned.

    Yeah, it is snappy when the touch screen plays nice. I'm very happy with these results so far. You are all doing a very great job here.

    I really can not wait for you all to make a build based off of CM9, but you have proven that it is possible on our phones to bring ICS to it. Not even LG can compete with what you guys are doing. I :bowdown: to you all working on this.

    Kudos to you folks. I'm more than happy to test anything and report my results.
    LightShowJerk likes this.
  7. Android?What!?

    Android?What!? Well-Known Member

    Nice job guys, but now I've tried to flash this and it gets to the android screen then just stays there, I waited about 5-7 minutes and restored my last backup. Any ideas?
  8. AndroidHogs

    AndroidHogs Well-Known Member

    Did you try flashing the rom then reppards rock kernel?
  9. Android?What!?

    Android?What!? Well-Known Member


    Ahah yea I had to do a little proof reading before I just jumped right in. Thanks for the help, I'm loving the rom.
  10. tripdoc79

    tripdoc79 Well-Known Member

    lol.. loving that nothing works? lol ;)
  11. bobdamnit

    bobdamnit Well-Known Member

  12. tripdoc79

    tripdoc79 Well-Known Member

    yo reppard, any thoguhts on this? i havent touched the kernel source yet, and that wheres the drivers are right?


    1. As of Android Ice Cream Sandwich 4.0, touch screen drivers may need to be changed to comply with the Linux input protocol specification.
      The following changes may be required:
      • When a tool becomes inactive (finger goes "up"), it should stop appearing in subsequent multi-touch sync reports. When all tools become inactive (all fingers go "up"), the driver should send an empty sync report packet, such as SYN_MT_REPORT followed by SYN_REPORT.
        Previous versions of Android expected "up" events to be reported by sending a pressure value of 0. The old behavior was incompatible with the Linux input protocol specification and is no longer supported.
      • Physical pressure or signal strength information should be reported using ABS_MT_PRESSURE.
        Previous versions of Android retrieved pressure information from ABS_MT_TOUCH_MAJOR. The old behavior was incompatible with the Linux input protocol specification and is no longer supported.
      • Touch size information should be reported using ABS_MT_TOUCH_MAJOR.
        Previous versions of Android retrieved size information from ABS_MT_TOOL_MAJOR. The old behavior was incompatible with the Linux input protocol specification and is no longer supported.
      Touch device drivers no longer need Android-specific customizations. By relying on the standard Linux input protocol, Android can support a wider variety of touch peripherals, such as external HID multi-touch touch screens, using unmodified drivers.
  13. Chckycrk

    Chckycrk Well-Known Member

    Why does ICS have to be so damn complicated? lol
  14. tripdoc79

    tripdoc79 Well-Known Member

    lol.. im going to see if i can track down the driver source and edit and add it to reppards kernel..
  15. PlayfulGod

    PlayfulGod Well-Known Member Developer

    yea the driver src is in the kernel src which reppard, myself, and BobZhone all have on our githubs
  16. tripdoc79

    tripdoc79 Well-Known Member

    thanx again PG, soon as my daughter goes to bed ill be downloading it to see what i can do
  17. tripdoc79

    tripdoc79 Well-Known Member

    changed some things around, fixed some errors i skipped last time, just got done compiling, took about 8 hours, gonna flash it and see if anything is differant lol.. then getting the kernel and driver source to fix the touch screen
    Android?What!? and Misleadb4 like this.
  18. tripdoc79

    tripdoc79 Well-Known Member

    silly question, but does anyone know what kind of screen we have? lol.. im looking through these driver files.. and there are alot of differant manufacturers.. done some google searches.. but come up empty..
  19. tripdoc79

    tripdoc79 Well-Known Member

    guess i could look through the kernel make fiels and figure it out lol.. duh

    found it.. in case anyone lese is wanting to try this, its the synaptics_i2c_rmi.c file
  20. Pappy62

    Pappy62 Well-Known Member

    What issues (if any) would there be in compiling the newest LG kernel into this build?
    From what I've heard, it solved the FC issues some have had...
  21. tripdoc79

    tripdoc79 Well-Known Member

    just for shits and giggles.. i repacked the boot.img with bobz kernel.. dont knoww hat going to happen.. but we'll see in a miinute

    yeah just what i figured lol.. no go.. no boot even.. back to editing the driver.. was looking at Bobz coding of the synaptics_i2c_rmi.c file and it is totally differant than mine.. was still making obsolete calls.. but the differance is huge in how its written.. so android.source say that ABS_MT_TOUCH_MAJOR had been replaced by ABS_MT_PRESSURE, does this apply to ABS_MT_WIDTH_MAJOR as well? have they been combined into one call? time to go looking again.. try to figure this out..
  22. AndroidHogs

    AndroidHogs Well-Known Member

    I believe we have a hvga 320x480.
  23. reppard

    reppard Well-Known Member

    As PG stated the drivers (or modules in linux fashion) are included with the kernel source and compiled into the kernel. You can look at the .config file to see which screen it is, I get remember off the top of my head. Should be able to pull a config file from your phone with adb pull /proc/config.gz if you have trouble finding it. Looks like its going to take a little source hacking with ICS =)
  24. tripdoc79

    tripdoc79 Well-Known Member

    thanx for the tip ont he config.gz reppard.
    i have the srouce, and i have the config, and i have a replacement synaptics_i2c_rmi.c file that looks to have the right calls, i edited it a bit to update TOUCH_MAJOR to PRESSURE, not sure if that is going to work or not.. but, im trying to build the kernel, is there anything i need to do this? i did some reasearch, and installed a bunch of stuff to cross compile, however i am still getting this error:

    make: arm-eabi-gcc: Command not found
    CHK include/linux/version.h
    make[1]: `include/asm-arm/mach-types.h' is up to date.
    CHK include/linux/utsrelease.h
    SYMLINK include/asm -> include/asm-arm
    CC kernel/bounds.s
    /bin/sh: arm-eabi-gcc: not found
    make[1]: *** [kernel/bounds.s] Error 127
    make: *** [prepare0] Error 2


    new to this kernel thing... thanx in advance again
  25. NeoSabin

    NeoSabin Well-Known Member

    You are missing the arm-eabi- gcc dependency.
Loading...

Share This Page