1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

??? Am I rooted?


  1. C3Pdr0id

    C3Pdr0id Well-Known Member

    I rooted my phone, tested it with root checker & it passed.

    I tried to open Titanium & it "couldn't acquire root access"?

    any ideas?

    Advertisement
    :
  2. breadnatty08

    breadnatty08 pain rustique VIP Member

    What phone do you have? What process did you use to root?
  3. C3Pdr0id

    C3Pdr0id Well-Known Member

  4. sdrawkcab25

    sdrawkcab25 Guides Guide

    Did you click the "problems" button in titanium? Have you tried any other root only apps?
  5. C3Pdr0id

    C3Pdr0id Well-Known Member

    Titanium Backup just displays "Asking for root rights..." & the circle at the top just keeps spinning.

    At one point weeks ago it worked, I was cleaning the dalvik cache

    I tried Andromizer & it does nothing.
  6. C3Pdr0id

    C3Pdr0id Well-Known Member

    Last resort would be to reset to factory (hard reset) & go from there.....

    Trying to avoid the nuclear option but it's always on the table, lol

    if this were to happen in the future I'd like to know if a file is corrupting - if anyone else has experienced this (from search it shows this to be the case- but no real solutions) & what happened to cause it & how they fixed it
  7. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    Have you tried clearing the cache/data on the Super User app? It has worked for me in similar situations in the past.

    Also worth checking to see if USB Debugging is enabled, I know TB can play funny if that's not enabled.
    sdrawkcab25 likes this.
  8. rosser725

    rosser725 Active Member

    EDIT: Never Mind
  9. sdrawkcab25

    sdrawkcab25 Guides Guide


    I second this ^^^
  10. C3Pdr0id

    C3Pdr0id Well-Known Member

    Thanks for the help so far

    debugging is enabled
    it's simply not rooted anymore it looks like??
    I tried it again yesterday & reverted to the default carrier's wallpaper

    edit: I went into SU & couldn't find anywhere to clear the cache?

    see all my screen shots once I add them....
  11. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    It's not actually in SU Settings, it's normally done under the standard phone settings.

    Settings -> Apps -> All -> Super User -> Clear Cache/Data
  12. C3Pdr0id

    C3Pdr0id Well-Known Member

    ok, I'm not rooted anymore & am stumped as to how but here's the proof in the pudding I think:
    so time to start over.

    I'm befuddled because yesterday is when I tried to root again to download a helper file so I could make a gps switch via the app Macrodroid

    I was confused why the helper file would not DL, the developer told me it's because I wasn't rooted. W/O root scripts & helper files can't be DL'd.
    That's when I tried to root again & the carrier wallpaper appeared AND the helper file DL'd............

    Attached Files:

  13. cooldudezach

    cooldudezach Well-Known Member

    Alright, I think I know what your issue is. The problem is that you made a very common mistake when rooting the Hydro/Rise. There is a specific version of su/superuser that works, and it looks like you used the latest version of the rooting script.

    Easy Fix:
    Open Superuser, set grant root access to allow, prompting does not work, will refuse root every time because of it.

    Not-So-Easy Fix:
    You need to remove superuser and SuperSU. Having both on your phone anyway is a good way to ruin your root access.
    After removing them, you need to re-root with the correct rooting script.
    [GUIDE] Root your Kyocera Rise! - Android Forums at AndroidCentral.com



    Note to Everybody:
    If anybody asks how to root the Rise/Hydro, please send them to this link.
    C3Pdr0id and El Presidente like this.
  14. C3Pdr0id

    C3Pdr0id Well-Known Member

    Wow, easy method worked like a charm!!
    Makes sense why it was just waiting spinning, it was stuck at the prompt.
    Thanks a ton!

    cooldudezach you are a cooldude, I'll vouch to that, lol

    Thank you to all who helped me avoid the nuclear option ;)
  15. cooldudezach

    cooldudezach Well-Known Member

    did you reroot the phone, or set it to always allow?
Loading...

Share This Page