Amon_RA 1.6.2 Custom Recovery: trackball not required!


Last Updated: 2012-06-06 02:07:38
  1. scary alien

    scary alien not really so scary Moderator

    Yeah, the install doesn't scare me...although if you have to install the Android SDK anyway for D.E. (makes sense that it uses this as its underlying means of communication), then you're pretty close to being able to issue adb commands manually ;) :p [and wanting or being able to use a PC].

    I'll be posting stuff that should also work from people's phones too without the need for the PC (at least, that's that plan :D).

    Cheers!

    Advertisement
    knitpurlgurl likes this.
  2. scary alien

    scary alien not really so scary Moderator

    All,

    Sorry this took me so long, but I've finally added the installation instructions to the top post above.

    As you can see, there are four scenarios discussed for the when and how to install this recovery. I've used erisuser1's Gscript on-phone installation method for already rooted users that want or need to install this tweaked recovery to their phones. I will be contacting jcase to see whether or not we can come up with a one-click type app (similar to his 1-click root app) for flashing this recovery (no promises regarding the outcome of this since its his proprietary app).

    Anyway, let me know if you see anything wonky or have questions / issues in the above instructions.

    By the way, big props again to erisuser1--it took me quite a while to tweak/test/debug/document the Gscript method mentioned above, and I had a template/example to reference! It gave me a new appreciation for the amount of work and effort he put into his Universal Eris Root for Dummies! method and the care, time, and excellence he puts in all of his posts.

    Cheers!
  3. TheLedge93

    TheLedge93 Member

    Thank you so much!!!! (even though it's super freaking late lol) I have to flash a different rom, because the one i'm using (taintedvanilla_1.4) crapped out, and now no one can hear me when i call. and i was like "oh well, on to EE4.0" then i booted in recovery, and my trackball didn't move. i was extremely upset. but now it's fixed...i hope. my phone has been in the 3 little skating guys for awhile now...
  4. scary alien

    scary alien not really so scary Moderator

    Glad it was helpful to you...happy to have helped.

    We don't see too many references to Evil Eris ;) anymore since there's been so many new custom ROMs built since then (EE was one of the early "choice" / popular ROMs). Goo d luck!

    Cheers!
  5. Frisco

    Frisco =Luceat Lux Vestra= VIP Member

    A link to the OP has been added to the Root Guide sticky.
    scary alien likes this.
  6. tproctor

    tproctor Well-Known Member

    I'm trying to do Scenario 3 and I keep getting a /system/bin/su: No such file or directory error. I'm running Nonsensikal v12.5 and have the SU app. Any ideas?
    scary alien likes this.
  7. scary alien

    scary alien not really so scary Moderator

    Yeah, sorry about that... I added the "root check" to help ensure that only rooted phones were trying to use this--and this was before I really tested with Gscript and realized that the script itself would require su to run (i.e., for the flash_image command).

    I also assumed that all custom ROMs would put their su programs in /system/bin/su, but I'm guessing that Nonsensikal and others don't, eh? :p [can you tell me where Nonsensikal does store theirs? no biggie if you can't].

    I'll remove that check from the script... You can probably edit the Gscript script by long-pressing in the main menu and selecting Edit and changing the script to point to the correct location for su or removing that check all together.

    Also, if you give me a few minutes, I'll tweak the gscript-sa.zip and republish it so you can re-download...

    Thanks!
    tproctor likes this.
  8. tproctor

    tproctor Well-Known Member

    I think I'll give ya a few minutes!! LOL I don't want to screw anything up and I have no clue where Nonsensikal stores theirs.

    Thanks!!
  9. scary alien

    scary alien not really so scary Moderator

    Okay, I downloaded it, removed the su/root check and re-uploaded it. I'll publish its MD5 sum in a little bit.

    Sorry for the inconvenience... Let me know how it goes...

    Cheers!
  10. tproctor

    tproctor Well-Known Member

    This time, I get this error:

    If you are not rooted, didn't enable the Needs SU? checkbox, or there's a problem flashing the custom recovery image, you'll see something like this:
    [​IMG]

    And then below that it says /sqlite_stmt_journals/flash_image:not found.

    Thanks for your help in advance!
  11. doogald

    doogald Guides Guide

    That would be /system/xbin/su

    ;)
    scary alien likes this.
  12. scary alien

    scary alien not really so scary Moderator

    In the Gscript output that it produces when it runs, does it show an error after the line:

    Info: installing/securing flash_image ?

    (this is the point where the script copies the flash_image file from the /sdcard/gscript/tools directory to your phone's /sqlite_stmt_journals/flash_image location).

    Did you re-do all of the steps from the beginning? I'm thinking also that Gscript might be holding-on to the old script, so make sure you long-press and delete the gscript-sa script in Gscript's main menu when you first/re-launch it before you try to load the new version. I'm still a little new to this Gscript tool, so you might be encountering some of its eccentricities that I haven't quite accounted for.

    If you are still having issues, I'll be back home (where my Eris is sleeping ;)) in about an hour and a half and I'll be able to help debug this a little more deeply.
  13. scary alien

    scary alien not really so scary Moderator

    Ah, thank you doogald! A little voice inside my head told me not to include this check initially, but did I listen? Nooooo....:D
  14. tproctor

    tproctor Well-Known Member

    Ok, I deleted everything from before including Gscript Lite and started fresh. After reloading the app and downloading and extracting your .zip to the root of my sdcard, I ran the script. Below is what my screen looks like (I don't know how to take screenshots).

    create /sqlite_stmt_journals/flash_image: directory nonexistent
    stderr:
    stderr: chmod: /sqlite_stmt_journals/flash_image: No such file or directory
    stderr:
    stderr:/sqlite_stmt_journals/flash_image:not found
    stderr:
    stderr:

    I'm assuming that it is looking for a folder or location that is not found in Nonsensikal, but that's just my guess.

    If you come up with anything, let me know and I'll try it again. I would rather have another option of getting through Amon_ra's than the trackball because I think my wife's trackball is about to go on the fritz.

    Thanks for all the help.
  15. scary alien

    scary alien not really so scary Moderator

    tproctor,

    You might be on to something! (i.e., that maybe the /sqlite_stmt_journals directory does not exist in all ROMs (but certainly does in a stock ROM)).

    Like I said, I used the venerable eu1's root_part2.sh script as my template and tried not to deviate more than necessary and I assumed he had a very good reason for using this directory as the launching-pad for the flash_image program.

    Let me get home and re-test the script using the /sdcard/gscript/tools folder for running the flash_image file from and I'll let you know.

    Thank you again for being my beta tester on this...others yet to come will sing your name in song after all of this is fixed ;).

    I'll get back to you soon-ish.
    LexusBrian400 likes this.
  16. tproctor

    tproctor Well-Known Member

    I'm just glad to help out. I did look through the folders using Estrongs and didn't see that folder name anywhere. I'll check back in when I get off work in a couple of hours and see how it's going.

    Thanks again.
  17. scary alien

    scary alien not really so scary Moderator

    Okay, I've tweaked the Scenario 3 Gscript script some:

    1. I now check for both /system/bin/su and /system/xbin/su, but I don't exit the script if they are not found (this is just a diagnostic tool for debugging)

    2. I've moved from using the /sqlite_stmt_journals directory to temporarily house the flash_image program to /data/data/gscript-sa This should make the script work on all ROMs (crossing fingers ;)).

    3. I've re-uploaded the new version and it is now available for download. The published MD5 sum and file size have been updated.

    4. I've also updated the screenshots to reflect the display changes made in the script.

    5. If you have to re-extract the gscript-sa.zip file (via Astro) and re-run the gscript-sa.sh script from Gscript, its probably a good idea to

    a) delete the gscript-sa script from inside Gscript (long-press the gscript-sa script name and select Delete)

    b) delete (via Astro) the gscript-sa.sh file from the /sdcard/gscript directory before re-extracting it (this is probably unnecessary, but I'm still learning how Gscript behaves)

    I think that's it...thanks to tproctor for his patience and doogald (as always) for being there.

    Let me know how things go and if you have any questions, comments, or suggestions.

    Cheers!
    LexusBrian400 likes this.
  18. scary alien

    scary alien not really so scary Moderator

    tproctor,

    I spent some more time this evening tweaking the script and I've come up with a newer version that I'm going to package-up with the .zip file, but I wanted to make it available to you if needed (you shouldn't though, given the changes I made from earlier this evening). Anyway, this new version will check to see if the /sqlite_stmt_journals directory exists and then use it if it does. If it does not exist, it wil then try to use the /data/data/gscript-sa directory for housing the flash_image file.

    I've also added a log file feature to the script so that it will record what is going on when the script is run to the file /sdcard/gscript/tools/logfile.txt.

    Anyway, function-wise, it should be identical to the original and second version in that it tries to flash the trackball-optional custom recovery image to your phone.

    Here's the new script: View attachment gscript-sa.sh.txt If you need to use it, you'll have to remove the .txt suffix from it and copy/move it to the /sdcard/gscript directory. When re-extracting the .zip or updating/replacing a Gscript file, make sure you manually delete the script from the list of scripts shown on the main Gscript screen (and then re-add / load / save).

    Cheers!
    LexusBrian400 likes this.
  19. TheLedge93

    TheLedge93 Member

    Well. back with a status report. my phone WILL NOT boot into recovery. i have done it: the one-click way, Eris user1's way (including your non trackball solution), i've tried to go through HBOOT, FASTBOOT, and the regular boot, and the thing will not get past those 3 little green men. I'm wholesomely upset because now my phone has been rendered little more than a ipod touch that txts...any help? i'm not a complete starter at all this stuff, but i'm still confused about the ABD shell, and driver situations and all the stuff down that path of root. i need help, or advice, or something...
  20. tproctor

    tproctor Well-Known Member

    SA,
    Sorry I didn't get back to ya last night, but here's my results:

    Tried it on my phone and got a bunch of write errors. I thought I saw where it said Script Loaded so I tried rebooting into recovery. It hung at the skateboard screen and required a battery pull. Instead of just rebooting though, I booted into fastboot (Vol -/answer/end) and tried getting into recovery from there with no luck. Still stuck on the skateboards. So, battery pull again and reboot to see if phone still works and it came right up. I went straight to Gscript, deleted the gscript-sa, re-added the script, and re-ran it. When it got done, it was successful!!!! I tested it and everything worked perfectly. Now I don't need my trackball.

    Since everything ended up working on my phone, I decided I'd try my wife's phone (Nonsensikal v9.5) since she wasn't using it. I downloaded the file, got Gscript from the market and badaboom, badabang success!! Works like a champ first time.

    Thanks for doing this for everyone and thanks for putting up with me while I tried to get it on my phone!!
    scary alien likes this.
  21. tproctor

    tproctor Well-Known Member

    Can you boot your phone up? If so, I would do Scenario 3. If you have the gscript-sa zip and folder on your sdcard, I would delete it and reload it. I would even delete the Gscript app and reload it too. Just get a fresh start.
  22. scary alien

    scary alien not really so scary Moderator

    Okay, I'm just a little confused... So, you were rooted with Tainted Vanilla 1.4, had the silent-call issue, and tried to flash Evil Eris 4.0 and discovered you had trackball problems.

    You then did install the trackball-optional recovery and flash EE4.0 and encountered the 3 skateboarding androids? (implying that you are still running Tainted Vanilla 1.4 and you are able to boot normally?). Does this sound right? [By the way, if you were able to flash EE4.0 using recovery, did you do a Wipe Data/Factory reset before doing the flash?].

    If you are able to boot normally into Tainted Vanilla, why don't you try the scenario 3 method like tproctor suggested. Then, if the script says that it successfully installed the custom recovery, power down your phone and then boot into recovery this way:

    From the phone being in a powered-off state, press volume-DOWN and the end/power button at the same time. This should take you to the HBOOT menu and give you the option to press the volume-UP toggle to enter recovery. Reference this post re. this:

    http://androidforums.com/eris-all-things-root/177367-rooting-custom-rom-questions.html#post1592392

    One last thing... There are several ROMs out there that have the July 2010 2.1 OTA updates from VZW that seem to have fixed the silent-call issue you were having. I don't know that EE4.0 has this included, but certainly a ROM like xtrSense does (several others do too, but xtrSense is highly regarded).

    Let us know.
    LexusBrian400 likes this.
  23. TheLedge93

    TheLedge93 Member

    ok. So i had some call issues. decided that a different rom, or just a factory reset even, would fix the problem. i go on my merry little way, and turn off my phone (before any effort to re-root) once off, i press END+VOL UP and it does actually get to the recovery screen. i'm like "oh great! just gotta do th....what?!?!"

    the trackball didn't work...so figuring my root code went bad, i downloaded the eris 1 click to root program. did that stuff. tried recovery mode again (END+VOL UP)...trackball still didn't work, but it still was a ble to reach the green/black at this point.
    so after crying for 3 hrs and eating 3 pints of icecream to the lifetime channel, i searched the internet, and found your trackball-optional mod/patch or whatever you deem necessary to call it. i scrolled through scenario 3, went through the steps, and turned my phone off. turned on, while holding END+VOL UP but it never passed the skateboards.

    so i did a large number of battery pulls, each time alternating between recovery mode presses END+VOL UP, and just a regular boot (END) the regular boot was uneffected, and works fine (minus the calls of course). but the status of the recovery boot never changed.

    I thought maybe it was considered a impartial root, because i was never able to flash the "rootme.zip" file. soooo i scrolled to Scenario 2. then realized that's Scenario 1. so i did those steps. and incorporated all the necessary files. renamed the two .img files, ran gscript lite. did all that.

    took a deep breath of relief...turned my phone off. turned on with END+VOL UP, and the screen was STILL stuck at the skateboards. i left it at that very same screen all night, and went to sleep. woke up, and my phone was off.

    in a desperate cry of help, i read through the comments, and found the HBOOT and FASTBOOT methods. i first tried SEND/CALL+END and pressed the necessary buttons to get to recovery...screen hit the skateboards, and didn't change. then i tried END+VOL-DOWN, and went through those buttons and same thing. skateboards and nothing. (throughout this whole process, i'm still on tainted vanilla, and never was even able to get to EE4.0. and the reg boot still works ok.) sooo. that's my life's story. need anything else?
  24. scary alien

    scary alien not really so scary Moderator

    Wow, you are nothing if not persistent ;).

    I am rather at a loss...

    Just one clarification about the skateboard android guys: there are skateboard androids that show up at the bottom of the FASTBOOT screen and the HBOOT screen, but you are talking about the ones that show up in the middle of the screen when either booting into recovery (or trying to) or booting normally, right? (that's where its hanging, right).

    One other thought: did you verify the size and MD5 sum of the files that you downloaded (specifically, the recovery-RA-eris-v1.6.2-trackball-not-required.img)? Perhaps you have a bad / partial recovery image and that's why it won't boot into recovery... Its sounds like you know of every which way to boot into recovery, so that's why I'm thinking you have a bad recovery image.

    You could try scenario 3, being careful to double-check the MD5 checksums of the files as indicated above.

    Can you try this? I've done it about 25 times over the last several nights and its pretty quick. Just take your time and let us know.
    LexusBrian400 likes this.
  25. TheLedge93

    TheLedge93 Member

    Your right about the skateboards at the middle of the screen. The ones at the bottom load fine. Your turn to clarify. After all your writing and modding of your zip file. What is the md5 checksum? And what program do I need to check it? You've probably stated it more than once

Share This Page