Android 2.2 [Froyo] Bugs and Questions - Post em Here

Last Updated:

  1. frank325

    frank325 Member

    After installing 2.2, every time I load up my browser ( is my home page) it asks me to allow Google to know my location. I always hit yes and check the box to remember my preference, but it continually asks me every time. Anyone else seeing this?

  2. wrstone

    wrstone Member

    Yes, I've observed similar behavior. I can't prove it, but it's not entirely inconsistent with poor networking. If Google isn't consistently getting your location data, it could well trigger this kind of behavior.

    The overwhelming majority of issues I'm experiencing are pretty clearly due to buggy networking. Even the poor performance issues could be explained if the Droid is now more or less consumed with trying to make network connections.

    Bill Stone
  3. I updated to 2.2 manually a couple days ago, and for some reason my mp3 tags went nuts. For instance, certain tags got mixed, while others lost tags all togethor and are showing up as" null." Has anyone else experienced this? Is there anyway to fix it without deleting and re adding all my music?
  4. Skier809

    Skier809 New Member

    I forced the update on my girlfriend's droid and immediately had issues. The phone was running extremely slow and force closing apps left and right. I couldn't even make a phone call. I started removing apps and as soon as I removed handcent sms, everything started working fine. She doesn't stay up to date on app updates and she must not have updated it to a version with froyo support. For those experiencing issues, perhaps your should try going into settings>applications and start removing apps until things start working normally.
  5. Flowright182

    Flowright182 New Member

    I noticed this, really sucks. I also noticed that when the screen is locked and I turn the phone it doesn't go to landscape mode, the pin keyboard is just sideways. The pattern one used to go into landscape mode before. The only way it goes to landscape mode is if I slide the physical keyboard and type the numbers there but that's just annoying :/ :mad:

    Hope the other update fixes this :(
  6. wrstone

    wrstone Member

    I've not seen this, but I'm an audiophile with an interest in MP3 tags, so I can tell you a bit about it:

    MP3 tags are contained within the MP3 file. Any tags you may see while playing an MP3 is entirely up to the media player.

    (This isn't quite the case with album art, which can be inside the MP3 file or in the subdirectory containing your MP3 file. Generally, tags are in the MP3.)

    In general, media players can't write to MP3 files without special help.

    Therefore, if you're seeing whacked-out MP3 tags, the likelihood is that it's the player at fault rather than the MP3 file.

    If you want to check this, copy an MP3 with a messed-up tag to a desktop computer and try running that file with a player that knows how to read MP3 tags. My guess is that you'll see the tags normally.

    If you've got an MP3 tag editor, have a look at the MP3 file with it. Again, I suspect you'll see normal tags.

    The problem is almost certainly the media player you're using. If you're using the Droid's stock players, do yourself a favor and try Meridian. It's much better in almost every respect.

    I also wouldn't be shocked to learn that FRG01B introduced some issue into the stock media players. I suspect that these players may in some bizarre way be dependent on networking -- perhaps they talk to online databases to retrieve album art or MP3 tags?

    In any case, the big bug in FRG01B appears to me to have been networking. Any app on an affected Droid that requires networking may fail in an unpredictable fashion.

    Bill Stone
  7. Gulfstream5

    Gulfstream5 New Member

    Wow... quite a few issues out there. I have not noticed many of the things mentioned, but I have monitored my battery all day, and it's doing well.

    Been unplugged for 11hrs.15min - I still have 80% capacity showing, and I've used the phone normally today. :D
  8. jimdibb

    jimdibb Well-Known Member

    my issues:
    well, the 2.2 frg01 build seemed really bad, so I rooted and installed the FRG22 update.

    issues with frg01 (haven't seen if they're all fixed yet):
    mediadock app kept resetting the phone

    wifi network is erratic, but it's been erratic for me even with 2.1 -- and it's still erratic with FRG22. Sometimes the app gives me 'reasonable' 5mb down, 3+ up (I've got 25/25 fios). My pc shows 22+/22+. But then next run, the ping times out, and I get NO down, and 7 up, or 1100 down and ? up. Just now, the 'flash showcase' site almost hung for 60 seconds, then downloaded the rest like normal.

    now it's playing cnet tv through flash pretty well. oops, just froze again. for 15 sec, but now it's prebuffering like a champ. every so often it seems the wifi just takes a break.

    with 01, the Salt trailer on sony pictures (flash) was pretty stuttery. with frg22, the green lantern trailer played better, but again it's stuck while the wifi takes a break.

    I'm using a linksys-n router, but I might try setting up a G and see if that gives any better performance. (we don't notice any issues on our laptops.)

    pandora app stopped pausing when I pulled the headphones. there was a new api for that, right? Pandora must need to put out a patch?

    That's all for now. Hope this helps someone or raises some discussion.
  9. Thanks for the feedback. I'm actually using mixzing, but my tags are messed up in the stock player and cubed as well. Im going to try copying some mp3s onto my desktop like you said and see what happens. Has anyone else seen anything like this?
  10. bills534

    bills534 Well-Known Member

    Maybe I'm just dense but it seems that the 2.2 update removed the option to select the resolution the camera takes pictures at? Also I noticed the picture file naming changed.
    Old way: 2010-07-19 16.51.02
    New way: IMG_20100805_185128
  11. wrstone

    wrstone Member

    I can confirm this. The camera app has changed. Settings are now accessed by an onscreen menu bar running vertically down the right side of the camera view. It's actually a better interface for me, since I need not swipe the camera to change settings.

    However, there is no longer an option to alter the resolution of the still camera. This option seems to still exist in some fashion for video, but it's not particularly precise. I.e., there are presets for various resolutions, but no option to alter it beyond the presets.

    Yet more confirmation that I need a much better camera app. It always rather sucked, but removing options isn't really a change for the better. At best it's neutral, assuming it's hard-coded to always use the highest-res format.

    Bill Stone
  12. MajesticFlame

    MajesticFlame Well-Known Member

    You can still change the resolution. Under one of the settings (the first one) you can scroll down. :)
    wrstone and bills534 like this.
  13. chainsawmike

    chainsawmike Member

    I agree. I'm kind of scared they are going to screw something up with the new update. I'm sticking with this. Why fix it if it isn't broken?
  14. luvjones305

    luvjones305 Active Member

    We'll my issue are that when i call my phone to check if everything is up an running my phone do not ring i set my volume up high its not muted or nothing. The only time it works if i reboot the phone with my app called (fast reboot pro) then when i call my phone the ringtone[​IMG] work only once unless u reboot the phone again. I even text my phone that works good so my phone can not be muted at all if my text ringtone works its when a call come in it show a lil speaker with a x on top of it by the antenna bars far top right of the screen it shows for a quick second an the phone don't ring do you have the same issue or is there a place in this froyo FROG1B 2.2 build to check my settings because i check under (sound) an every thing is in order even when u plug the usb you don't hear it ring i even have the volume up on that to
  15. miijin

    miijin Member

    i can't get any wifi connectivity at all. when i turn it on it goes to obtain an ip and during that it turns off and begins the cycle again. I've reset the router, tried different devices on wifi all working and i've used no security and WEP with same results.
  16. bills534

    bills534 Well-Known Member

    thanks for pointing that out. Didnt really notice that scrollbar before. Now that I know that I can say that the camera software is a big improvement over where it was when I first got the phone.
  17. kozjegyzo

    kozjegyzo Active Member

    Hi All,

    I'm experiencing extremely high data usage 20+ MB per day after I installed Froyo. Before my daily max was 6 MB.

    Has anyone experienced this behavior?

    Can you suggest a data monitoring app that tells me data usage app by app? I have watchdog, and Netcounter and Netmonitor, but they are general, and cant tell me what app is doing all the mischief.

    I have an unrooted HTC Desire with OTA Froyo

    Here are my apps:

    kozjegyzo's Apps on the HTC Desire

    I live in Hungary and unlimited plans have bee abolished years ago, so I'm stuck with a caped one that get very expensive if I overrun.

    All help would be appreciated greatly...

  18. jimdibb

    jimdibb Well-Known Member

    I can give a few more frg22 problems.

    Pandora still does not pause when the headphones are removed.

    When my alarm went off while in the mediadock, the screen didn't come on. When I pushed the lock/power button, the phone rebooted.

    Going to bugless beast later today.
  19. Highland Ranger

    Highland Ranger Well-Known Member

    Probably need a summary at the top of this thread - reported issue/solution type thing. Can't do it now but might have time later.
  20. netagarfield

    netagarfield New Member

    Hello all new to the forum,
    Thought I would throw my 2 cents in since I did the manual update as well.
    Installed 2.2 yesterday. I previously had the 2.1 update id did manually as well.
    I have test every application especially touchdown which I use for work and have found no issues. I did notice after the upgrade it took the phone another 5 minutes to resume normal speed. I also did a reboot to make sure. On the Market the update all worked great. The only thing I have seen is coming out of an app to the home screen is sometimes there is a refresh delay on the app showing up, but this is infrequent.
  21. bilbravo

    bilbravo Well-Known Member

    What are you talking about?

    edit: I'm not trying to sound rude or anything, I really mean "i have no idea what you are talking about", but I'm interested. I re-read my post and thought "Man that sounds like I'm challenging someone" and that was not my intent.
  22. StrifeJester

    StrifeJester Well-Known Member

    It used to be you could only hold the phone upright or turn it left to get the screen to change orientation. Now you can turn it right or left. Not a big thing but it is nice having that ability.
    bilbravo likes this.
  23. bilbravo

    bilbravo Well-Known Member

    Whoah. Mind = blown. That is nice!
  24. wrstone

    wrstone Member

    Ok ... so having gotten sick of waiting for an official FRG22 to appear and fix my numerous FRG01B bugs, I decided to flash back to 2.1, then install FRG22 as outlined in this thread.

    The flash/upgrade process worked like a charm. Here are the results on my FRG01B bugs, by item:

    • Apparent speed of the device has increased dramatically. I'm not clear that it appears any faster than 2.1, but running craptastic FRG01B for a day has colored my perceptions.

    • The networking issues appear to be resolved.

    • YouTube works as advertised.

    • The Gallery works as advertised.

    • Apps that need Internet connectivity are now working as advertised.

    • "Trap!" is still a bit slow, but nowhere near as horrible as under FRG01B.

      As regards the 2D graphics bug introduced in the 2.1 upgrade, LagTest consistently shows 60fps with no sudden dips down to 20fps. The 2D bug seems to have been fixed.

    • Flash still sucks. Playing Falling Girl (one of the oldest, simplest Flash games out there) remains impossible. The girl falls slow as molasses in January at roughly 2FPS.

      The simple control of click-and-hold doesn't translate into press-and-hold on the handheld. There's no way to interact with the game.

      Even if you did, it's so laggy as to be pointless. This can't be due to networking issues, as those seem to have been fixed. It's just due to crappy Flash implementation.

      However, as Flash 10.1 for Droid is still in beta, I'm willing to overlook this. It better be fixed in the public release, however.

    Basically, this proves to me that FRG01B was indeed buggy as a cockroach nest. Furthermore, it also tells me that Flash sucks. If this crap is any indication, I'm starting to come around to Apple's way of thinking.

    Bill Stone
  25. alphaguy

    alphaguy New Member

    Re: Swype problems after installing 2.2

    The 2.1 beta does not work. You have to uninstall it, as well as the installer, go back to the beta email you got previously and do the install process again. It will recognize the new OS on your phone and install the correct version. Works great. Make sure you uninstall the old stuff first!

Share This Page