Android 2.3 & 4.0 WiFi Internet HD 1080P HDMI Google TV Box ARM Cortex A9 Firmware


Last Updated:

  1. payer

    payer Member

    I bought the box on ebay from tomtop but didn't receive it till today. The box is described as Google Android 4.0 Amlogic Cortex A9 1,2 GHz WiFi HD 1080P HDMI Internet TV Box 4GB V379.

    On the pictures the box looks similar to the one in the Visson ATV-108 FAQ. If I'm wrong - sorry for disturbing you ;)

    Advertisement
  2. grindinonyourm

    grindinonyourm Well-Known Member

    so upon a reboot i had a similiar problem as Shihabva, input signal getting lost to my HDMI tv. only way to fix it was to go back to the out of box experience and set resolution to 720p again and finish wizard and then input stayed on. and netflix still cuts out. AARRRRRGGGGGGG!!!!!

    UPDATE:
    http://forum.xda-developers.com/showthread.php?t=1584027
    this forum mentions a specific ICS rom that netflix seems to work fine on. wonder what it is in that rom that makes it work.
  3. stane1983

    stane1983 Well-Known Member Developer

    It handles all kinds of subtitle files, just rename subtitle to be same name as movie file. It supports packed subtitles (text ones) in mkv. With VobSub subtitles there are display issues, will take care of it, otherwise subtitles are handled just fine.
  4. stane1983

    stane1983 Well-Known Member Developer

    Everything is written in faq. Use DeviceChecker app from faq to see if your device is f16ref or c03ref.
  5. stane1983

    stane1983 Well-Known Member Developer

    Found a weird post on the net... Open Browser settings (Web browser of ICS), go to Advanced and set browser type to android. It doesn't make any sense to me 'cause I don't even know how netflix app looks, if it uses webview etc.... but try that... Maybe device reboot before starting netflix?
  6. grindinonyourm

    grindinonyourm Well-Known Member

    yeah...i found that post too. just tried it, no change. still timer acts like it cant count right. for instance, say i load up start trek TNG, by the time the opening credits are rolling, netflix timer says that episode is already more than half over...then timer stops, then eventually stream stops. every single time. on my 8726M3 tablet as well. maybe its processor specific. butits not networking related from what i can tell. its something in the ICS build itself. something particular to ICS because netflix works great on 2.3.4. although there is some error in my logcat about dhcpd not getting proper timing and that timing can skew. search the logcat i last sent you, you'll see it. otherwise im at a loss. and it still sometimes comes up with no audio. good video but no audio. and occasional video corruption, like this.


    [​IMG]
    also, netflix uses a crash reporting tool called crittercism..
    http://www.crittercism.com/

    i wonder if there is a way to intercept the logs it generates say from wireshark on a linux machine. i have an ubuntu machine set up that can act as an access point. i can capture wireshark logs then from my soft AP..maybe i can catch something, although im positive its not gonna be sent in plain text. any other ideas stane?


    UPDATE: http://www.youtube.com/watch?v=vg_ujLsBejI
    then there is this kid, just to rub it in......derp.
  7. payer

    payer Member

    Thanks! I'll do immediately after receiving the item from Shenzhen.
  8. stane1983

    stane1983 Well-Known Member Developer

    Which version of Flash player do you use?

    There is 10.2 flash player which is slightly modified to work better with Amlogic CPUs on ICS:

    Download install_flash_player_ics_1207.apk from Sendspace.com - send big files the easy way
  9. grindinonyourm

    grindinonyourm Well-Known Member

    thats the one i use. also, when i completely uninstall flash, netflix still works. flash web doesnt work, veetle doesnt work, but netflix still does. i dont think it uses flash on android. i could be wrong, but from what i see, it pulls a stream and throws it through ffmpeg by way of amplayer and the mediaplayerservice. no flash. no flash references in logcat either.

    UPDATE:
    http://www.youtube.com/watch?v=-gjrN0R-tzg&feature=player_embedded

    another vid of someone on ICS with an amlogic 8726M1 and netflix working great! imma try this version and log it and see what it says...

    Also, another oddity in netflix, when i use the seek bar to go to another part of a show or movie, while the bar moves, the video keeps playing like i didn't move the control. volume controls work, play/pause works, but seek does nothing.
  10. stane1983

    stane1983 Well-Known Member Developer

    Which version of neflix do you use?
  11. grindinonyourm

    grindinonyourm Well-Known Member

    i use the version from the US Play store,

    Version 1.8.0 build 561

    i will begin trying different versions of netflix on ICS.

    also, if i install yer cm9 build to try out netflix, will i be able to go back to yer newer fw or will my bootloader be stuck?
  12. stane1983

    stane1983 Well-Known Member Developer

    You can revert back, no problem. On cm9 build (mine, which uses amlogics recovery) you will see scrambled screen on boot - not to worry, it's normal :)
  13. grindinonyourm

    grindinonyourm Well-Known Member

  14. stane1983

    stane1983 Well-Known Member Developer

  15. grindinonyourm

    grindinonyourm Well-Known Member

  16. stane1983

    stane1983 Well-Known Member Developer

    That's exactly what I wanted to post... :) Try and report results

    Update: It's not gonna work... you also have services.odex file in framework folder... I have to see what this does to services...
  17. grindinonyourm

    grindinonyourm Well-Known Member

    cant upload services.jar because it is an odexed file. much more complicated to do if odexed. one click script available to re combine services.odex and services.jar files. but adb must be used with script. maybe you can make a non odexed services.jar because you have source.

    UPDATE: also, yer flash doesnt work with veetle. cant connect to stream. the flash 10.2 apk i gave you in that 'useful' pack does make veetle work rather well. just a tip..there is also a flash 11 in the useful apk, but it never worked for me..but it is for m3 platform i think.

    http://forum.xda-developers.com/showthread.php?t=991276&page=1175

    man, this is a long thread...


    and stane has gone silent.... ;)
  18. stane1983

    stane1983 Well-Known Member Developer

    ... doing a big thing.... I'm putting my kernel together (for c03ref), building the sources, testing... and after that only sky is limit :)

    We won't have any problems with small system or cache partition or implementing bluetooth or dvb-t dongle support...
    grindinonyourm likes this.
  19. jorgebirck

    jorgebirck Member

    Hey Stane !!

    I have used the ICS all day ... much better than version 2.3 ...

    Thank you!!, what can I do to add Portuguese (Brazil) in this ROM? Can I create a git repository for it?
  20. stane1983

    stane1983 Well-Known Member Developer

    You're welcome :) Nagh, I think git repo is too complicated for users to use. I'm preparing my own web server where all will be hosted, and I was thinking about adding small translate app web based. Will decide today and publish here.

    About language translations, Android supports all languages listed on this site:

    Android 4.0.3 Platform | Android Developers

    I only need translations for my or Amlogic apps (such as MoviePlayer or V.play networking...).
    What I mean, Android as OS is already translated to all those languages listed on site, I just have to include translation in my build.
  21. matinaki

    matinaki Well-Known Member

    Well, Stane1983, I have installed your 20120604 on My TVBox, very good work, but actually I have a small issue, most net pages loading normally, but to some, loading bar stucks close to end and page is not loading completely, even after 10 minutes of time.
    Here is such page: www.antenna.gr/webtv
    I can give you more examples if you need.
    On older 20120422 I had not such problem.
    Thanks in advance
  22. grindinonyourm

    grindinonyourm Well-Known Member

    Holy **** STANE1983! how did you figure out the ICS configuration? this is great news! are you going to incorporate any of the services.jar tweaks or the supercharger script into yer rom. i spent all night reading that thread and then another thread and then another....brain...melt....hurt....read somewhere that if you modify yer services.jar, you can add that to yer ROM and then bake supercharger script into it as well..did you try the script or use any of its suggestions?
  23. boostpt

    boostpt Member

    hi there,

    please help me, because I'm a Noob in this, and I need to buy a box.

    these firmware arm cortex A9, is suitable for this box:

    [SIZE=2][COLOR=#0d355e][COLOR=#000000][FONT=Arial][SIZE=2][COLOR=black][FONT=Verdana][SIZE=2]http://www.ebay.com/itm/330719369601?ssPageName=STRK:MEWAX:IT&_trksid=p3984.m1438.l2649

    it says CORTEX: A9[/SIZE][/FONT][/COLOR][/SIZE][/FONT][/COLOR][/COLOR][/SIZE]
    , but the case is not the same as listed in the 1st page of the threat
  24. stane1983

    stane1983 Well-Known Member Developer

    Read the FAQ. It's not Visson box, and I belive it's not even Amlogic. Similar device I saw that uses VIA chipset.
  25. grindinonyourm

    grindinonyourm Well-Known Member

    Stane1983, I tried to do the supercharger script and of course I got stopped at the first step because of low system storage...can't wait for yer expanded version with new kernel!

Share This Page