Android 2.3 & 4.0 WiFi Internet HD 1080P HDMI Google TV Box ARM Cortex A9 Firmware


  1. stane1983

    stane1983 Well-Known Member Developer

    Working on it, it's not that easy I taught it would be...
  2. jorgebirck

    jorgebirck Member

  3. stane1983

    stane1983 Well-Known Member Developer

    Status update: recovery mode running, hope i will have test build today with 360 mb system partition :)
  4. stane1983

    stane1983 Well-Known Member Developer

    That's your device on the picture? First of all it's not visson's device :) Second, It may be kernel differences for handling IR remote... I can modify update package for you if you provide me link to official firmware.
  5. migues

    migues Member

    Hello!. Thank you! ;) My TV BOX now is working for me! I had problems with AC3, but not now (with this new firmware).

    I have a cuestion for you, could you put the Spanish language in your future rom? (like the original rom, it came). :D

    Thank you again!

    (sorry for my english)


    Miguel.
  6. grindinonyourm

    grindinonyourm Well-Known Member

    NEW BUG: in the last 06042012 firmware, occasionally and permanently when it happens, the mouse pointer is replaced with your V play startup wallpaper. very random glitch! what file is the mouse point? can you send me the file stane1983 so i can overwrite it and get my cursor back...

    [​IMG]my normal desktop

    [​IMG]me trying to open Browser

    [​IMG]me tryin to open some other program...
    you can see my problem stane?

    when i look inside framework-res.apk, i see your pointer_arrow.png. but my system is using a weird cache something i think...!!!

    UPDATE: this has happened before at random and ive never been able to fix it, but i think i caused this one by wiping the dalvik vm cache and using a cache cleaner+ program...wont do that again...

    UPDATE: Also, news and weather widget was missing from 06042012 release where it was present before.

    UPDATE: i even removed your bootanimation so now im back to the stock android logo on boot and yet still pointer is screwy..

    UPDATE: ALSO stane1983, ADB over wifi works great on 06042012 firmware. i use a free widget called "adb over wifi". good stuff.

    UPDATE: ok so in the end i reinstalled from scratch, and its only when i set force gpu for 2d applications did the above mouse pointer corruption occur. so mystery partially solved. but i still cant make it go back to the pointer. is there a cache to clear for the pointer?
  7. stane1983

    stane1983 Well-Known Member Developer

    Try this: remove your sdcard, unplug your device, use paperclip to press reset button and hold, plug it back in and wait for 3 blinks of front leds then release reset button. That should format cache and userdata partitions.

    Update: That logo is placed on aml_logo partition and nowhere else so it's really weird how you managed to have this... :)
  8. grindinonyourm

    grindinonyourm Well-Known Member

    i already reinstalled from scratch.. i got a nice little setup that lets me go from blank to new ROM and all my apps in about 10 minutes..next time i'm ready to nuke this install, i'll do it again and see if this fixes it. how goes the new kernel?
  9. stane1983

    stane1983 Well-Known Member Developer

    It's actually modified source tree from gingerbread release and it's not working as expected with ics... Now weekend starts, so I hope I'll manage to get it ready in next day or two...
  10. stane1983

    stane1983 Well-Known Member Developer

    Big update folks!

    Recovery is running, kernel is running, Android is running.... Wifi working, mouse working...

    Needs to be fixed:
    - there is no sound output
    - USB/sdcard are not mounted in Android

    Features:
    - System partition 512 Mb, free after fresh install 257 Mb
    - Anything possible now, tested if my DVB-T tuner is recognized by system - it is, Pinnacle 73e. Didn't test functionality because of no USB or sdcard is recognized by Android.

    Hope will finish it today so I can upload...
  11. jorgebirck

    jorgebirck Member

    Thank you Stane!

    Can you please add:

    - Spanish and Porguese (Brazil) language;
    - EAC3 audio codec ;
    - Ralink 3070 wireless driver

    Thank you again Stane
  12. stane1983

    stane1983 Well-Known Member Developer

    AC3 and DTS are already included.... or did you mean something else?
  13. jorgebirck

    jorgebirck Member

    yeah i mean "DD+ (EAC3)" (Dolby Digital Plus) is unsupported in this Rom
  14. jorgebirck

    jorgebirck Member

  15. nitromethanol

    nitromethanol Member

    Hi everyone. I have an Measy X7 that have a ARM cortex 9.

    The original specifications are:
    HW AMLOGIC MESON-M1 8726M DVBC
    RAM 192 MB
    INT Storage 2GB
    AMLogic M1 Reference Board
    Android API Level 8
    Firmware 2.2.1

    I change to Android 2.3.3 from wistar firmware. Works, but have a lot of restrictions about applications.

    Did someone test this Android 4 on this box?
    Thanks a lot for any answers and sorry about my english.
  16. fivos

    fivos New Member

    Hello Stane,
    Any idea why BBC iplayer and Itv player are not working with ICS ATV-108 v1? How can this be fixed?
    Thank you
  17. stevan58

    stevan58 Member

    Hi Stane1983,
    I'm quite new here and I have just one question: I have Visson ATV-108 (f16ref board) so can I install your firmware update or I will brick my TV box? I want to solve the problem with AC3 which cannot be played properly on my device. Many thanks in advance hoping you can help me too.

  18. stane1983

    stane1983 Well-Known Member Developer

    No, you cannot install fw for c03ref board... if you have Visson's f16ref, here is 0603 firmware. Use 720p resolution, on 1080 there is bug in MoviePlayer app:

    Download 201200603_Android_ICS-ATV-108-f16ref.zip from Sendspace.com - send big files the easy way

    Note to all: If there are more users of new Visson's board, I can maintain both firmwares, it's built from same source code, but with different configurations... It takes twice longer to build fw for 2 devices, but if there are users (because it's pretty new board), I can manage that.
  19. stane1983

    stane1983 Well-Known Member Developer

    I can see that fw for f16ref board has been downloaded 3 times for now... It would be nice to receive some feedback. I was testing it on Vissons device which had some wifi and sound issues, so I'm interested in this:

    - does wifi work?
    - do you have any sound 'clicks' and lags on system (randomly)?
  20. stevan58

    stevan58 Member

    Many thanks stane1983 for your help, I just updated my Visson device (f16ref board) with your firmware 201200603_Android_ICS-ATV-108-f16ref and it's working! I hope you will continue to develop the FW for f16ref board too. I started to testing the MBOX and here it's my first feedback:

    • wi-fi is working but any time I start the MBOX I have to select my connection on wi-fi setting to let it working then the browser is working without any wi-fi break.
    • for now I had no sound "click" and lags on system
    • AC3 issue are solved and now it's working without any noise:cheers:
    • Market is not updating to Google Play and even I can browse all the content I cannot download or update any application, when I try I got this error message: [app name] could not be downloaded due to an error (921). I tried to manually update Market to Google Play but still get the same downloading error. :(
    • I cannot test Youtube for now cause I cannot download and install it form Market :(, any link where can I download it to testing?
    • Flash Player don't seems to be installed on MBOX, which version can I install and where can I find the download link?
    Any other Visson f16ref board user got the same problems? On the next few days I will continue to test the MBOX and I will add my feedback to this thread.
    Thanks again to stane1983 and to everybody will collaborate to the FW development of Visson f16ref board.
  21. stane1983

    stane1983 Well-Known Member Developer

    Visson f16ref board is new product, so I didn't build many fw's for it. My new pcba from Visson is on it's way to me (should be here on monday), so I'll test it. As I said, my current f16 board has some hardware issues, therefore Visson decided to send me a new pcba :) I think that's nice :)

    About continuing of developing fw, there is no problem, I will continue my work for both c03 and f16, it's easy and it's based on same Android source tree. Different is only android configuration and kernel.

    About market issues, will see what's going on... seems that system partition is too small... Tell you what, I'll build another fw today which will expand system partition. Other issues I can test and fix next week when my new pcba arrives.
    stevan58 likes this.
  22. hercan

    hercan New Member

    Dear Stane,
    I tried to upgrade my ATV 108 to 4-23_4.0firmware (I have MBX VISSON 2.0, Android 4.0.3, Kernel 3.02, ICS.MBX.20120422) by pressing reset button and confirmed 3 times signal. Then my ATV 108 started loading with green android man and come to the screen Android System Recovery <3e>.

    In the page Android System Recovery Utility there are 6 options as follows;
    - Reboot system now
    - Apply update
    - Wipe data/factory reset
    - Wipe cache partition
    - Apply update from cache
    - Set Efuse item
    -------------------------------------------
    Below these selections the status as follows;
    E: Bad bootloader arguments (null)
    E: Failed to mount/sdcard
    ...
    ...
    ...
    E: Cannot mount/udsk/Factory_update_param.aml
    -------------------------------------------

    1. I cannot choose above options with my iPazzPort nor with the ATV mouse is it normal?
    2. Do I need to use USB keyboard to select factory reset option or this is not the solution?
    3. Or do I need to prepare a SD Card prepared by Linux (which is completely difficult for us that we have never witnessed with Linux before)?
    4. My ATV 108 does not restart now, do you think it is bricked? Once I plug in the electric cord, the machine sreezes in a white screen with black and red lines and ATV 108 does not re-start. What do you recommend me?

    Hope that you can help.
    Best regards

    Attached Files:

  23. stane1983

    stane1983 Well-Known Member Developer

    Did you follow the procedure in FAQ? Files from 4-23_4.0firmware (there are 7 I think) must be extracted to root folder of sdcard, so in root of sdcard you need to have something like tihis:

    aml_autoscript
    ethmac.efuse
    factory_update_param.aml
    market_patch.zip
    u-boot-aml-ucl.bin
    uImage_recovery
    update.zip

    And your sdcard must be fat16 or fat32 formatted. If it's not working, it's not recognized by device. In that case, try another sdcard.

    Btw, navigation trough that menu does not work not with remote or usb devices. Will try to fix this.
  24. googlick

    googlick New Member

    Hi stane1983

    I haven't tried your f/w for f16ref (I'm waiting for device and I hope it'll be f16ref), but I've downloaded it and I've had a look into. I can see that system/xbin contains su, so a device can be rooted.

    But I haven't found aml_autoscript - is it obsolete or your just forgot to add it?
  25. andriodfan

    andriodfan Member

    Stane1983,
    I bought a second box and this time it is a f16ref board with FW20120504. It worked fine for three days and then had WiFi connection problems. I downloaded your 20120603 FM and flashed it this morning. My first comments are

    • After flashing I run Superuser and I got it Rooted
    • I noticed that the flashing did not erase my installed applications
    • Maybe because of the above I have the same WiFi connection problem.
    • Other applications I use work fine
    Please tell me if I should change or delete some corrupt data WIfi data file
    Note My other Box with c03ref board and 20120604 works like a charm

    Thanks
Loading...

Share This Page