Android 2.3 & 4.0 WiFi Internet HD 1080P HDMI Google TV Box ARM Cortex A9 Firmware

Last Updated:

  1. grindinonyourm

    grindinonyourm Well-Known Member

    So stane, I had the pointer glitch happen again...didn't happen ever except on the 0604 fw. Is the mouse pointer drawn in software or graphics driver frame buffer? Cos I think the frame buffer is corrupting..and takin the pointer graphic with it. I also got my hotmail account hacked by Not sure if it's related, but I started getting china spam right after I got my first atv-108. Then my account got hacked...I've recovered it but none of my accounts have ever been hacked before, so this is strange for me. I sure hope the amlogic sources are clean. I run antivirus on my android tvs too..just a heads up, there is a war on.

  2. stane1983

    stane1983 Well-Known Member Developer

    It's obsolete I believe, it didn't came with original fw, so I didn't put it in my fw either.
  3. stane1983

    stane1983 Well-Known Member Developer

    I don't belive amlogic sources are dirty. Perhaps it was just coincidence. About cursor problem, I believe it's related to small system partition. In 0604 I added few more languages, fw is bigger... Little more patience please... I have some serious problems with kernel for my next release... Hope will solve soon.
  4. miuna

    miuna Member

    Hi where can I find the working link for version 4.0 ATV ICS-108 with 900 MHz clock! Developed by stane1983. Links posted on the forum do not work and the problem of excessive heating of the processor in this case there is no problem to be afraid to deal with this very easy to handle. The problem may be too low voltage, which causes instability but decides this kernel.
  5. stane1983

    stane1983 Well-Known Member Developer

    I deleted that version from sendspace. I paid hosting service, all roms will be available soon. I will post the address.
  6. hercan

    hercan New Member

    Stane I have good news for you.
    You were right. The problem was absolutely on SD card. I changed the card and tried using one other having 2 GB capacity. I formatted it as fat32 and unzipped the mentioned files. Once I restart ATV 108 this time there was a blue line under the android man and started to load the boot. Now I have my system back and I am so happy. Now I can buy a 55'' led tv without smart specifications as I already have it with andoid tv box. Thank you so much. FYI
    Hakan Ercan
  7. stane1983

    stane1983 Well-Known Member Developer

    I did it!

    System is fully working and stable (afaik). Now building whole system with aditional languages that were requested and I will put it online today.

    Feeling soo good now :D
  8. tsamy

    tsamy New Member

    Hi Stane thanks for your efforts, i have a problem with the Market as it is usually give me no connection even the browser working and the set is connected with Ethernet not wifi
    and also the browser sometimes suddenly stop and give me certificate issue.
  9. stane1983

    stane1983 Well-Known Member Developer

    Wait for new fw, I belive many things will be solved with it.
  10. stevan58

    stevan58 Member

    Hi stane1983,
    testing again your FW 201200603 on my ATV 108 f16ref board, I found other issues:

    • there is not signal from the A/V out port, the image can only be displayed on TV using the HDMI connection, is there any setting to enable the A/V out or it's a bug?
    • only English and Chinese language are available
    hope that the new FW for f16ref board will fix all the problems.
  11. stane1983

    stane1983 Well-Known Member Developer

    About Market issue (there was problem with cache partition), languages etc, c03ref firmware is uploading, f16ref firmware is building... About A/V output, need to check that, It's probably kernel issue.

    So, today I will upload both versions of fw with same features... be patient little more :)
    stevan58 likes this.
  12. stane1983

    stane1983 Well-Known Member Developer

    - new kernel
    - System partition resized to 512 Mb, Cache partition to 64 Mb
    - System languages: Catalan, English (United Kingdom), English (United States), Spanish, Spanish, Spanish (Latin America), French,
    Croatian, Italian, Portuguese (Brazil), Portuguese (Portugal), Romanian, Greek, Bulgarian, Russian, Ukrainian, Arabic - Egypt, Arabic - Israel, Simplified Chinese, Traditional Chinese

    Download section: V-Play download section

    Firmware for f16ref board will be uploaded during the day and will be visible on download page.
    migues and pleven4ever like this.
  13. tsamy

    tsamy New Member

    why link not working to me ?
  14. stane1983

    stane1983 Well-Known Member Developer

    Explain... It's working, link is redirecting you to download page where you choose which file you want to download.... direct links to files are not working, but download from page works.
  15. stane1983

    stane1983 Well-Known Member Developer

    Hi again,

    site: V-Play download section

    Both c03ref and f16ref firmwares are up. There is also under Tools section DroidTV.apk. It's for testing purposes to test DVB-T functionality.

    On both firmwares there is support for DVB-T USB sticks which uses dib0700 driver (devices listed here under first post).

    Just install DroidTV and insert your DVB-T stick into box. DroidTV requires superuser access.

    On f16ref board, mine new board didn't arrive yet, but it's working on my old f16ref board, but with weird clicks and no wifi...

    Same features for both versions of device...
    pleven4ever and payer like this.
  16. jandy123

    jandy123 Member


    Very nice speed improvement with your new kernel (antutu score 2560). Graphics performance is clearly improved, as well as slight increase in CPU performance. Btw. mounting SDHC cards also works in the new firmware (had problems before).

    I do have a few questions.
    - When I mount a network share using, I used to be able to start movieplayer and, using the file browser. I could select and play remote videos, etc. Now, only see the sdcard mount. Any way to fix this ?

    - When playing videos using movieplayer, my screen gets to full 720p, disregarding my screen size/position adjustments. This means that menu buttons, etc, get out of the screen. Could this be fixed ? Btw. the mouse cursor stays visible when playing videos.

    Anyways, clear improvements here. Keep up the good work !

  17. stane1983

    stane1983 Well-Known Member Developer

    About not seeing NetShares in /mnt folder, I forgot to add symlink.... will do that in next release, sorry.

    You can do that by typing in terminal:
    su (to get superuser)
    symlink /NetShares /mnt/NetShares

    About mouse visibility, didn't notice that, automatically moving mouse on right side of screen. Will fix that.

    Thanx for your review :)

    What about netflix, does it work?
  18. jandy123

    jandy123 Member


    Thanks. I fixed the link problem. Mouse pointer was not a problem indeed (my bad), but video-player resizing still is. Can this be easily fixed ?

    I actually cannot get the flash plugin to work (the one you provided on the previous page). When I try opening a flash video inside browser, I get a blank screen and the browser crashes badly. Any ideas ?

  19. stane1983

    stane1983 Well-Known Member Developer

    Under Tools you have FlashPlayer_ICS.apk. Tested on my new f16ref, but should work on c03ref aswel. Please confirm
    mikizvi likes this.
  20. hansmaiser

    hansmaiser Active Member

    Hi stane,
    Is it possible to flash your rom on the atv-101? It should have similar firmware as the 108.

  21. jandy123

    jandy123 Member


    Flash still not working. New version has sound, tries to go fullscreen (by default), but gets garbadged screen in the upper left quarter of the screen. It completly crashes the whole system...
  22. miuna

    miuna Member

    The ATV-101 everything works the same as the ATV-108 is no difference. The new soft stane is OK congratulations. To display the image on the TV properly you must turn off the TV feature "Display Area" (on my Panasonic Plasma TX-P50Y) then the function keys do not go beyond the screen. Regards
  23. stane1983

    stane1983 Well-Known Member Developer

    Settings -> Display -> Set display position - that's solution to your problem, not turning off features on your tv :)

    For everyone else, I'm looking for Flash solution for c03ref. On f16ref, Flash from my download page works as expected (at least for me, if otherwise, inform me)
  24. leoandroid

    leoandroid Member

    Hi Stane!

    First of all I congratulate you on your work! You're a genius!

    What is the Flash problem with c03ref? I used the last firmware (0604) and didn't have problems in youtube web or similar, except in

    Sorry for my english. I'm from Argentina
  25. stane1983

    stane1983 Well-Known Member Developer

    It messes the screen. I belive I found a problem and working on solution...

Share This Page