Android 2.3 & 4.0 WiFi Internet HD 1080P HDMI Google TV Box ARM Cortex A9 Firmware


Last Updated:

  1. leoandroid

    leoandroid Member

    Ok. I'm using the new firmware but the bug mentioned by grindinonyourm is still happen. the mouse pointer is replaced with your V play startup wallpaper.

    Advertisement
  2. stane1983

    stane1983 Well-Known Member Developer

    Can you please explain to me how you managed to do that? I'm not kidding, Me and my colleague are unable to reproduce that kind of error. It doesn't really make any sense... maybe it's kernel related... don't know.... Please help me on that one :)
  3. leoandroid

    leoandroid Member

    My english is very bad but i will try to! :)

    Recently i installed the new firmware. I added google account and set my google account i one of LCD.
    When i plugged off my box and plugged in in another TV happened the bug.

    i dont know how to fix it, so i must re-install the firmware.

    It's very strange because it's not allways.

    The last weekend i've tried in other LCD and the bug has not been happened.

    EDIT: The bug also happened without exchange my TV.. I plugged of box, but when i plugged in the bug is happened again.
  4. leoandroid

    leoandroid Member

    Also i found a bug over Wifi. The same bug that official firmware, when you're connected the wifi is disconnected from internet. The icon turns gray and you have to shut down and reconnect.

    EDIT: Its very strange. I found various errors in new firmware, like no access to root, wifi disconnect, etc.
    I made a soft reset and the errors disappeared.

    I'll keep commenting on my tests.

    Great Job!
  5. stane1983

    stane1983 Well-Known Member Developer

    Will try to figure it out.... I mean I will figure it out :)

    About Flash, I found a problem and solved it. It was kernel related issue. Since on current recovery system I cannot upgrade just kernel, I'm uploading new firmware package to server with Flash fixed and preinstalled (version 10.2). Tested on YouTube desktop version from standard Browser, works like a charm in fullscreen or normal flash on webpage :) Will post new post when upload is finished.
    leoandroid likes this.
  6. stane1983

    stane1983 Well-Known Member Developer

    Hi,

    V-Play download section

    There's new fw package, 2012-06-12, fixes Flash and probably other issues. Flash Player 10.2 is included in package.

    Sorry for inconveniences and my apologies to all who downloaded last package (2012-06-11 over 60 downloads). I simply overlooked kernel configuration bug.... once again, sorry :)

    Update: f16ref firmware doesn't have that problems, just install Flash player from my site, it will work fine. From now on working Flash version will be included in all firmware releases.
    pleven4ever and leoandroid like this.
  7. leoandroid

    leoandroid Member

    You're a machine! i'm testing the last fw and now you makes a new release!
    Great job
  8. stane1983

    stane1983 Well-Known Member Developer

    It's same release (system will report 20120611), I didn't built Android from scratch, just kernel, but that changes to kernel should have some influences on system behavior, especially on h264 video decoding.
  9. nitromethanol

    nitromethanol Member


    Hi Stan1983. I appreciate your work. I am trying to install this firmware on a Measy X7. We start installing, this message apperar:

    ..." ert failed: getprop("ro.product.device")== "c03ref" || setprop("ro.build.product") -- "c03ref"
    error in /udisk/update.zip
    status 7)
    -- Install apk aborted "....


    Can you give me a clue? Thanks a lot.
  10. leoandroid

    leoandroid Member

    I'm downloading. I will try it!
    Thanks buddy.
  11. stane1983

    stane1983 Well-Known Member Developer

    Recovery says that firmware is not for your product. I'm developing firmwares for Visson ATV-108 c03ref and f16ref boards, I'm not into 'cooking' roms or something like that. I don't believe my firmware will work on your device, especially 'cause it's not based on c03ref board. Does your device use Amlogic chipset?
  12. stevan58

    stevan58 Member

    Dear stane1983, I'm testing your new 20120611 FW on my f16ref board and it's a very good job! Issue about market are solved, speed and graphics are very improved with a better performance, flash player is working too. I have some questions:
    - I still have no signal from A/V after boot the MBX but it can be manually set on Display>Output Mode>480i or 576i and in this case A/V out it's working but when you reboot the MBX the the system automatically set to HDMI by default and if you connect the MBX to a TV with only composite audio/video then you have no image and sound. Can you please check it when you will receive the f16 board and try to solve?
    - Wi-fi sometime got disconnection (grey icon) and I noticed that the wi-fi signal power is lower than other devices connected to my wi-fi spot even the MBX is not far from it.
    - I cannot put the MBX in standby or switch off using the iPazz Port which is full working (it can be done only with the remote control which is not working for all the other functions), is there any way to solve the issue considering that the MBX have no any power switch.
    Thanks in advance, keep up your great job!
  13. nitromethanol

    nitromethanol Member

    Stane:
    Thank you very much for answering! Yes, is an ARM Cortex 9. I allready install an android 2.3 from other thread. But can not install a lot of applications. Here is my CPU detail. Thanks for your time!

    /system/etc # cat /proc/cpuinfo
    Processor : ARMv7 Processor rev 1 (v7l)
    BogoMIPS : 1599.0
    Features : swp half thumb fastmult vfp edsp neon vfpv3
    CPU implementer : 0x41
    CPU architecture: 7
    CPU variant : 0x1
    CPU part : 0xc09
    CPU revision : 1

    Hardware : AMLOGIC MESON-M1 8726M DVBC
    Revision : 0020
    Serial : 000000000000000b

    The update-script is different i see....Have a look from the wistar update.zip

    File:/META-INF/com/goolge/android/updater-script

    assert(getprop("ro.product.device") == "m1ref" ||
    getprop("ro.build.product") == "m1ref");
    show_progress(0.500000, 0);
    format("MTD", "system");
    mount("MTD", "system", "/system");
    package_extract_dir("recovery", "/system");
    package_extract_dir("system", "/system");
    symlink("toolbox", "/system/bin/cat", "/system/bin/chmod",
    "/system/bin/chown", "/system/bin/cmp", "/system/bin/date",
    "/system/bin/dd", "/system/bin/df", "/system/bin/dmesg",
    "/system/bin/getevent", "/system/bin/getprop", "/system/bin/hd",
    "/system/bin/id", "/system/bin/ifconfig", "/system/bin/iftop",
    "/system/bin/insmod", "/system/bin/ioctl", "/system/bin/ionice",
    "/system/bin/kill", "/system/bin/ln", "/system/bin/log",
    "/system/bin/ls", "/system/bin/lsmod", "/system/bin/mkdir",
    "/system/bin/mount", "/system/bin/mv", "/system/bin/nandread",
    "/system/bin/netstat", "/system/bin/newfs_msdos", "/system/bin/notify",
    "/system/bin/printenv", "/system/bin/ps", "/system/bin/reboot",
    "/system/bin/renice", "/system/bin/rm", "/system/bin/rmdir",
    "/system/bin/rmmod", "/system/bin/route", "/system/bin/schedtop",
    "/system/bin/sendevent", "/system/bin/setconsole",
    "/system/bin/setprop", "/system/bin/sleep", "/system/bin/smd",
    "/system/bin/start", "/system/bin/stop", "/system/bin/sync",
    "/system/bin/top", "/system/bin/umount", "/system/bin/vmstat",
    "/system/bin/watchprops",
    "/system/bin/wipe");
    set_perm_recursive(0, 0, 0755, 0644, "/system");
    set_perm_recursive(0, 2000, 0755, 0755, "/system/bin");
    set_perm(0, 3003, 02750, "/system/bin/netcfg");
    set_perm(0, 3004, 02755, "/system/bin/ping");
    set_perm(0, 2000, 06750, "/system/bin/run-as");
    set_perm(1002, 1002, 0440, "/system/etc/dbus.conf");
    set_perm(1014, 2000, 0550, "/system/etc/dhcpcd/dhcpcd-run-hooks");
    set_perm(0, 2000, 0550, "/system/etc/init.goldfish.sh");
    set_perm_recursive(0, 0, 0755, 0555, "/system/etc/ppp");
    format("MTD", "boot");
    show_progress(0.200000, 0);
    assert(package_extract_file("boot.img", "/tmp/boot.img"),
    write_raw_image("/tmp/boot.img", "boot"),
    delete("/tmp/boot.img"));
    show_progress(0.100000, 0);
    unmount("/system");
  14. stane1983

    stane1983 Well-Known Member Developer

    Provide me with info on what DeviceChecker.apk from my download page says (V-Play download section)
  15. stane1983

    stane1983 Well-Known Member Developer

    Sorry man, I don't have in any of my source trees (gb or ics) configurations for m1ref board. Afaik it's generic M1 reference board and it could be configured anyhow.
  16. stane1983

    stane1983 Well-Known Member Developer

    Working on A/V... for standby, I have same situation for c03ref too.... Will figure something up...
  17. sl0re10

    sl0re10 Member

    I don't know about your problem/s with wireless; but when most wireless routers lock up it is overheating related.
  18. test12

    test12 New Member

    stane1983,

    Nice work, but would you please add Dutch (Nederlands) to the firmware?

    ____________
    Test12
  19. jandy123

    jandy123 Member

    @stane:

    Thanks for your efforts for fixing flash. I'll test today and report here.

    Btw. yesterday I tested the camera application with a web cam which used to work on 2.3.4. The application crashes immediately after starting it. The kernel detects the usb device, but maybe the v4l2 module is not compiled in your kernel (it does not get loaded anyway) ? I remember v4l2 was the module which used to be loaded by my 2.6.34 kernel on 2.3.4 fw.

    What can we do about the annoying scaling issue ? Whenever I play a video it uses the full 720p screen, which on my tv, means that the image "gets outside" the screen. I've noticed this happening with any video player (standard, mx player, etc.).

    Cheers.
  20. stane1983

    stane1983 Well-Known Member Developer


    You're right. v4l2 is not compiled with kernel. Will add it. During my testing and fixing kernel for not showing any picture I disabled it and forgot to enable... :)

    About scaling issues, I need to go deep into Amplayer sources, currently they are not reading variables (if you set your screen position) but uses default values. It's very high on my todo list, will solve it, maby in next release... same thing for f16ref firmware. I belive the same behavior is on stock rom, but I'll change that :)

    @test12: No problem, Dutch will be added to next release
  21. jorgebirck

    jorgebirck Member

    Hey Stane, this is great! Some questions:

    1) In all usb (wifi and BT) devices, it seems there's more limited driver access in this ICS, can it be ? Or its fixed with the new kernel?

    2) Support for "DD+ or E-AC-3" ?

    Thank you!
  22. miuna

    miuna Member

    Can I ask for the Polish language to the menu, it would be nice if their is already enough. Today I will start testing the latest ROM, unfortunately, today it is a game my team at Euro 2012 and some lack the time. I greet
  23. jandy123

    jandy123 Member

    Ok, if you compile v4l2, could you also compile a few more: uinput.ko and xpad.ko ff-memless.ko ?

    It seems that this is the case indeed. Maybe the ubootenv.var.720poutputx, etc. properties from build.prop might help here?
  24. stane1983

    stane1983 Well-Known Member Developer

    Will include uinput, xpad and ff-memless.

    About scaling issue, yeah, those variables are responsible for that and they are used for scaling in Android. When reproducing video material, Amplayer uses default values, not the boot environment variables... That's problem in Amplayer library. Will fix that, but will take some time, source is not commented so well... :)
  25. GuruSoda

    GuruSoda Member

    Hi Stane,

    First, congratulations with this firmware, is very good!

    I discovered this firmware thanks to @jorgebirck, and work all perfect! but without the remote control.

    I installed cifsmanager but can't mount nfs shares, googling i found that is necessary have same modules in the kernel, the modules are:
    exportfs.ko
    sunrpc.ko
    lockd.ko
    auth_rpcgss.ko
    rpcsec_gss_krb5.ko
    nfs.ko

    Please, you can add in the next release this modules?.

    And thanks for relive my media player.

    Thanks!
    stane1983 likes this.

Share This Page