Android 2.3 & 4.0 WiFi Internet HD 1080P HDMI Google TV Box ARM Cortex A9 Firmware


  1. stane1983

    stane1983 Well-Known Member Developer

    Thank you for info provided, will add it to next release :)
  2. GuruSoda

    GuruSoda Member

    Stane:

    Thank you for your answer!.

    This is a little detail about the last features of the firmware, in the System language not exist "Spanish (Latin America)" but there are other spanish languages​​ and working properly.

    Thanks.
  3. grindinonyourm

    grindinonyourm Well-Known Member

    Mouse cursor problem still here as well. Didn't start happening until stane1983 firmware 0604. New firmware does it as well. Only way to fix the issue is to do a system recovery. After reinstall, everything is fine for a small amount of time, then it happens again. So far, I can tell you this, it nevers happens after first install reboot. And it only happens after a reboot. It never just switches in the middle of a use session. It does it on the tv I used for recovery(hdmi), and it does it on other hdmi tv's as well. It does it in 1080p and 720p on hdmi. It is almost as if it's flipping a memory address or something. No other rhyme or reason to the bug.
  4. stane1983

    stane1983 Well-Known Member Developer

    grindinonyourm, I will try to figure out what I've changed for that to happen...

    To everyone else owning ATV-108, why don't we move to my subforum Stane's ROMs - Android Forums and discuss issues there? :)
  5. jandy123

    jandy123 Member

    @stane:

    Flash player is still a no go. Although it seems to work minimized, when I enable full screen I do not have video, though audio works. If I minimize it again, usually it works, but if I do it one more time, usually it freezes my system. Any ideas ???
  6. stane1983

    stane1983 Well-Known Member Developer

    Provide me a link of flash video you're having problems with...
  7. jandy123

    jandy123 Member

  8. stane1983

    stane1983 Well-Known Member Developer

  9. nitromethanol

    nitromethanol Member

    Hi Stane. Thanks for answering. I found a thread that change parameters in Build.prop file, on the installed device.

    Original file:

    Code (Text):

    ....
    ro.product.brand=generic
    ro.product.name=m1ref
    ro.product.device=m1ref
    ro.product.board=m1ref
    ....
    ro.build.fingerprint=generic/m1ref/m1ref/m1ref:2.2.1/MID/eng.hhcn.20110908.114259:eng/test-keys
    ....
     
    Modified file:
    Code (Text):

    ....
    ro.product.brand=MID
    ro.product.name=f02ref
    ro.product.device=f02ref
    ro.product.board=f02ref
    ....
    # ro.build.product is obsolete; use ro.product.device
    ro.build.product=f02ref
    # Do not try to parse ro.build.description or .fingerprint
    ro.build.description=f02ref-eng 2.3.4 GB.f02ref.20111110 eng.xlknb.20111110.120443 test-keys
    ro.build.fingerprint=MID/f02ref/f02ref:2.3.4/GB.f02ref.20111110/eng.xlknb.20111110.120443:eng/test-keys
    # end build properties
    # system.prop for M1 reference board
    # This overrides settings in the products/generic/system.prop file
    ....
     
    You know the f02red board?
    Thanks for you time.
  10. stane1983

    stane1983 Well-Known Member Developer

    Afaik, f02ref is tablet reference board. I do have 2.3.4 sources for that.
  11. schaum

    schaum Member

    I installed build from 2012.06.12, first problem: no google market?

    Second problem: /NetShares is missing.

    Did I mess something up?
  12. hansmaiser

    hansmaiser Active Member

    Stane,

    I tried to install the latest firmware (12.06.) on my atv-101, but I get an error that something is wrong with the signature. The exact error message is:
    E:signature verification failed
    Installation aborted

    Can you help?

    hans
  13. nitromethanol

    nitromethanol Member

    Hi Stane! I find a thread on DialExtreme from other device, that changes board parameter to upgrade it.Firmware upgrade? [Update: Download Link here]


    That firmware on DX thread changes the original 'm1ref' to 'c03ref'. Perhaps you can understand what is the differences in the update.zip. What the script changes on original m1ref device.
    I think that your effort and develop will be appreciate from the whole
    Measy X7 users community.

    Thanks a lot for your time.
  14. stane1983

    stane1983 Well-Known Member Developer

    Use tool DeviceChecker from faq and provide me informtion that you have... I don't have any ATV-101, so I don't really know what board is in device.
  15. stane1983

    stane1983 Well-Known Member Developer

    Not sure why my signature is not visible but here it is....

    If you like my work, buy me a beer, summer is comming and it will be a long one... :D
  16. LeftyVz

    LeftyVz Active Member

    I bought you 50 beers... thank you... keep working ;)
  17. GuruSoda

    GuruSoda Member

    Hi @Stane1983,

    Take a look to my /proc/cpuinfo

    /system # cat /proc/cpuinfo
    Processor : ARMv7 Processor rev 1 (v7l)
    BogoMIPS : 391.03
    Features : swp half thumb fastmult vfp edsp neon vfpv3
    CPU implementer : 0x41
    CPU architecture: 7
    CPU variant : 0x1
    CPU part : 0xc09
    CPU revision : 1

    Hardware : AMLOGIC MESON-M1 8726M DVBC
    Revision : 0020
    Serial : 000000000000000b

    it's the same hardware that @nitromethanol.

    I am using your firmware without problem, i believe that problem is not the hardware, else, in some place that does not say c03ref, the firmware should work properly on that hardware.

    My media player is Android Full HD 1080P Media Player w/ USB/SD/HDMI/RJ45 Ports - Black (2 x AAA) - Worldwide Free Shipping - DX

    Surely your firmware works in more places than you think.

    Thanks for you time.
  18. stane1983

    stane1983 Well-Known Member Developer

    I am aware of that my firmware can work with other devices with or without few modifications. I just claim that I'm doing this for Visson ATV-108 c03ref and f16ref because I do have these devices and before I release it I want to be sure that anything can go wrong by installing my fw. Other devices I don't have and all you do with my firmware with other devices than ATV-108 is your responsibility, you can brick your device, you can have problems with wifi, IR remote... Hope you understand what I mean :)

    About m1ref and c03ref, these Amlogic reference boards are very similar which makes it possible to 'rename' device to c03ref and that will work.

    Also, when installing to other device than Visson's, for caution use bootloader file from your original firmware (u-boot-aml-ucl.bin).
  19. delysid

    delysid Member

    Thanks for your firmware.
    1. PlayStore does not display all applications (for example TuneIn Radio)
    You need to add all permissions, except NFS (It Crash PlayStore)
    2. Why do you use older versions of the codecs? New versions (2012_04_19) work fine.
    3. For owners of devices with SATA disk (Measy X7), need add SATA support.
    4. Android Keyboard is installed twice (from firmware and patch)
    5. Formatting /userdata, it is not good idea. No way for soft upgrade.
    6. Can You do so CPU clock was exhibited from build.prop?
    Sorry for my English.
  20. stane1983

    stane1983 Well-Known Member Developer

    1. Will add permissions
    2. You're sure about codecs? What about AC3 and DTS?
    3. Will include kernel support, but I'm not going to change vold.fstab 'cause this fw is targeting ATV-108 devices without sata.
    4. Will remove it from patch
    5. Formatting userdata and cache is 'must have' when moving from older fw or from original fw because of different partition sizes. I will see what my options are.
    6. I'm not sure what do you mean by that, allow overclocking?
    delysid likes this.
  21. test12

    test12 New Member

    More beer!
    stane1983 likes this.
  22. stane1983

    stane1983 Well-Known Member Developer

    Status update:

    - Video scaling almost done (still testing, but it's working actually.... system wide, not just MoviePlayer app - will be included in next release)
    - Camera app works now, need to be tested with actual hardware :)
    - Still looking for stable Flash
    - I still don't have any feedback if there is any improvements with Netflix with last firmware....

    Bug report by me: DTS sound doesn't work on f16ref board...
  23. jandy123

    jandy123 Member

    Nice progress.

    Pls. don't forget to compile the additional modules. Maybe you could try compiling most/all of them so that anyone can pick whatever he needs :)

    Yep, the flash is problematic indeed. Let me try describing my observations about this issue (maybe it gives you some ideas about where to look :).

    It behaves much like there is some sort of memory leak, because after attempting to play some flash video, the system becomes very unstable. I could see the free memory going down (as low as 20 MB), then the android system starts killing lots of applications in an attempt to free more memory. After this, even without doing anything, memory goes down again, system starts killing applications and so on -- this repeats up to the point that the system freezes.

    So, I believe netflix cannot work either. It seems to me that it's something fundamentally wrong. I mean not the flash plugin, but something deeper maybe in the kernel/codecs, etc. One thing I noticed looking at dmesg output. On 2.3.4 I used to see messages from the mali modules - like new context initialized whenever p[laying a flash video. Now, I do not see any log from the mali module. Though, I suppose that's fine.

    Cheers and keep up the good work !
  24. stevan58

    stevan58 Member

    Hi stane1983,
    how about A/V out and standby fixing for f16ref board on next update?
  25. jandy123

    jandy123 Member

    @stane: About the flash issue, one more idea.

    I'm gonna try installing a non-Hw accelerated flash plugin (flash 11 from market) and see what happens. If the system behaves normally and is stable, albeit hw-acceleration, this would suggest something deeper as I suggested in my previous post. Would this help ?
Loading...

Share This Page