Android 2.3 & 4.0 WiFi Internet HD 1080P HDMI Google TV Box ARM Cortex A9 Firmware

Last Updated:

  1. stane1983

    stane1983 Well-Known Member Developer

    When you're doing recovery, bootloader takes care of reading sector 0-n where recovery bootloader is stored. That is not same as reading files from partition on your sdcard, that's why I'm suggesting you to use another card.

    matinaki likes this.
  2. stane1983

    stane1983 Well-Known Member Developer

    Hi guys,

    have to inform you.... Spent 3 or 4 days solving freescale issue, but failed. I had some success with 720p but when switched to 1080 resolution it's all messed up - literally :)

    I'm decreasing priority of this issue on my todo list, have to fix other stuff... Meanwhile, I added sata support, webcam support etc to firmware. When I fix Flash player issue I'll upload new firmware with unfortunately freescale unfixed (for new readers: If you use Settings -> Display -> Set display position when watching movie or anything else that involves video reproduction, screen is sized to it's default values).

    Tech description of problem here:
    migues likes this.
  3. dam1679

    dam1679 Member

    hello. i bought this: Google Android 4.0 ARM Cortex A9 1GHz WiFi HD 1080P HDMI Internet TV Box Black. i cant install tunein radio from the playstore. it says its not compatible with my device. what can i do? thanks!
  4. matinaki

    matinaki Well-Known Member

    Well, Stane 1983, I am so jealous about you, I would like so much to know computers, but my profession has nothing to do with that..
    From the other side, I am so stupid, I forgot that recovery card which I tried was SDHC, I saw today..of course next I created was fully successful, my box now is like new..
    So, time to drink Greek beer together :cheers:
    Thanks man
  5. stane1983

    stane1983 Well-Known Member Developer

    No problem, I was glad I could help :)
  6. stane1983

    stane1983 Well-Known Member Developer

    Will add more permissions in next release... stay tuned :)
  7. dam1679

    dam1679 Member

    thanks for your quick answer!
    i do have another question: when i use skype in video-call mode, i can not see the other person
  8. stane1983

    stane1983 Well-Known Member Developer

  9. dam1679

    dam1679 Member

    how do you turn the tv box off? Do you just unplug it?
    it didnt come with a remote control so, do i have another choice?
  10. LeftyVz

    LeftyVz Active Member

    ir remote should work... if you don't have ir remote - just unplug it..
    I think stane is working on on/off function via rf remote ;)
  11. stane1983

    stane1983 Well-Known Member Developer

    I am, but it's kernel related issue. Problem is to power it back on (I mean, you can power it off with power button on RF or usb keyboard) when turned off via usb... need more time to fix that one...

    Just to be noted, LeftyVz is my colleague, we're together in this whole project... I'm developer, but he also can help with advices (which he got from me :D)
  12. LeftyVz

    LeftyVz Active Member

    It's working on M3 platform (f16ref) :smokingsomb:
  13. dam1679

    dam1679 Member

    i have not rooted my unit. should i do it? why yes, why not?
  14. stane1983

    stane1983 Well-Known Member Developer

    If you have my firmware installed, you're rooted, I mean you have root access. su binary and Superuser are preinstalled on all my firmwares.
  15. schaum

    schaum Member

    Hi Stane. When will next build be available for download?

    I have some problems with 2012.06.12 and went back to 2012.06.11 (I'm using c03ref)

  16. dam1679

    dam1679 Member

  17. dam1679

    dam1679 Member

  18. stane1983

    stane1983 Well-Known Member Developer

    FAQ and upgrade instructions here:

    My firmwares: V-Play download section

    Installation process is the same for both stock and my firmware.
  19. stane1983

    stane1983 Well-Known Member Developer

    What problems did you have with 2012.06.12? I'm thinking on publishing new firmware today.... except for Flash. I still didn't fix flash issue.
  20. tex83rb

    tex83rb Member

    hello, i'm getting this strange situation, at reboot the resolution goes wrong and re-setting to 720p bring the box to an uncentered screen (see third photo) . in every case i got the mouse cursor wrong, it appears as the edge of the black screen reporting the logo (see first and second image) .

    can this be corrected in next build? i saw something related to a/v correction in previous posts...
  21. stane1983

    stane1983 Well-Known Member Developer

    I assume you have f16ref board (rev 2). I'm aware of problem for not remembering screen scaling/resolution settings and this is fixed, will release new firmware today or tomorrow morning for both devices (c03ref and f16ref). I'll post here when uploaded.

    About mouse pointer, I promise I'll dive in that problem, same things happens on both devices, seems it's not kernel related but Android...
  22. grindinonyourm

    grindinonyourm Well-Known Member

    happened to me again as well stane. also , flash seems to work for me. at least veetle is working.. although the video doesnt full screen anymore. its a small window in the middle of the screen. i tried yer included flash and the previos version number as well, yers ending in .51, mine ending in .5. give me a flash link you use so i can check if its working properly.

    also, netflix is dead. no video or audio with the new kernel.
  23. stane1983

    stane1983 Well-Known Member Developer

    First, thanx for beers :)

    Second, can you please share your version of flash with me? I don't really know which flash I haven't tried... Problem is flash video.... I don't have problems with flash animations on websites, video seems to be a problem...

    Eg, this site: The World at War (1973) – Seriale online – Documentar | Filme online gratis, subtitrate in limba rom
  24. grindinonyourm

    grindinonyourm Well-Known Member

    Download Adobe Flash Player 10.2 from - send big files the easy way

    nope. my flash doesnt play this either. i know it's partially working because Veetle requires flash..and veetle works mostly on my box. it plays the video , just not scaled up to full screen. and netflix doesnt use flash, so i think its a media player issue, or ffmpeg, something connected to the mediaplayer cos it didnt work properly on vissons kernel or your custom kernel. i think these same issues are causing strange flash video issues. your world at war link is supposed to load its own flash video player with its own controls, but on atv-108c03ref it loads an android looking player with less controls. its not the proper player.

    edit: good series of videos too btw. :)
  25. jandy123

    jandy123 Member

    The flash player gets customized on the site above. I mean prooblem is not loading a different player... Btw. Working flash player on 2.3.4 did have exactly same controls, interface etc.

Share This Page