Android 2.3 & 4.0 WiFi Internet HD 1080P HDMI Google TV Box ARM Cortex A9 Firmware


Last Updated: 2014-03-31 04:01:15
  1. stevan58

    stevan58 Member

    @stane,
    when will be ready for download your new firmware for f16ref board and which fix and update will be included? A/v out issue and iPazz Port or remote switch standby/on/off are solved?
    Thanks in advance.

    Advertisement
  2. CoyoteX

    CoyoteX Active Member

    I dont think its related to the cable, since im not using the cable that i got from DX and it used to work perfectly before upgrade. I do have to turn volume really high on my monitor to get some sound on the HDMI connection. I will test yet another cable and see how it goes. Im not in a hurry for any feature, but let me know about BT and and remote because i do want to help on testing. I am with my son this weekend but will really stress out this GPU on 3d chainfire on monday, to see what this box is capable of. I have a remote.conf from a similar box which SEEMS to have the power button working while using your rom. If that is the case, i will start some work from there once you move it to /system.
  3. laziod

    laziod Active Member

    For some reason my WiFi is not starting any suggestions. I've updated to latest 0621 build, but WiFi did work in last firmware and.this one ad well. Please advice. Thank you.
  4. laziod

    laziod Active Member

    I have cine to realize that my box is a cheap generic copy. I has fried my scaled board on my tv twice now. This thing runs hot. It's going in the trash. This sucks, where can I get a levity box?
  5. matinaki

    matinaki Well-Known Member

    Hi Stane
    Yesterday I decided to install your 6/21 but I have some problems with Greek streams.
    I give you links, you to take a look.
    ANT1 WEBTV / HOMEPAGE /
    On this one, if you try to watch video, player shows "loading video" and after that, TV box all the time returns on menu page.
    This problem did not happened before with mediafire firmware.
    Also:
    ΕΡΤ - Web TV
    If you push here to watch a video, player opens but no video playing.
    This problem was always with mediafire firmware.
    Playing on pc I do not have any problem with both.
    Thanks in advance.
  6. stane1983

    stane1983 Well-Known Member Developer

    Not at home for almost a day... f16ref fw should be ready tomorrow. There is flash problem with video reproduction, thats why you have problems with certain web pages. Will try to solve this also. Cant help much with recovery right now cause i dont have my laptop with me.
  7. grindinonyourm

    grindinonyourm Well-Known Member

    also, stane1983, can you compile into your rom a switch in settings. other ICS devices have the ability to use only a physical keyboard if plugged in, thereby preventing the on screen keyboard from popping up. i think this would be useful. i use a real keyboard on my atv-108 and hate that the onscreen one comes up every time i want to enter text.

    UPDATE: nevermind, i just found it! it was already there!

    from another forum :

    "When you enter a text area (eg : on the navigator), you just have to touch the keyboard icon on the left of the clock. There beside "Use physical keyboard", you have to choose "No"."
  8. stane1983

    stane1983 Well-Known Member Developer

    Still on cellphone, but... :)

    Go to V-Play download section and try netflix app available under tools section.
    Reported as working by androidfun (correct me if i'm wrong, it was mail conversation) on 0604 release.
  9. grindinonyourm

    grindinonyourm Well-Known Member


    so far, no good with 0621 firmware. need to redownload 0604 and try that..app wont even start. just instant crashes and exits. :(

    UPDATE: i also tested those G.O.T. episodes on the atv-108 but with 2.3.4 running and they played perfectly! so its not necessarily a hardware decoder problem. its an ICS problem on 8726M1 problem, not on 8726M3 tho. curious...

    UPDATE2: Crackle app works great! decent amount of movies and shows to watch...
  10. leoandroid

    leoandroid Member

    :( Crackle app is not available in my Country (Argentina), i just can play on web page, but flash is not working on Crackle...
  11. stane1983

    stane1983 Well-Known Member Developer

    Finally home... Yeah, tested now by myself, netflix crashes on last fw...

    About codecs and GB 2.3.4 and c03ref... Visson did some more coding to be able to reproduce ac3.... They abandoned m1 platform and moved to m3 and that's why m1 really got only 2 official releases of ICS, neither of them supporting ac3/eac3/dts... it's licensing issue, and as I said, most probably hardware limitation of integrated audio decoder chip. What they did on GB releases I never asked...

    When I built my GB release, I had issues with all these codecs before I installed license file found on the net...
  12. andriodfan

    andriodfan Member

    Stane 1983

    I confirm Netflix works without problems in ROM 20120604 as commented by email.
    I am using Wondershare Player to play movies, series, and all kind of videos as well as local multimedia files. It also plays DVDs by pointing to the Video TS folder.
    keep with the good work
  13. grindinonyourm

    grindinonyourm Well-Known Member

    visson is not the only company to get Eac3 to work on gingerbread. mesada corp, who makes my flexview fv3, also plays perfectly. so if it can work in GB, can't it work in ICS as well? You yourself got rid of the license limitation for dts and ac3. please explain how it could be a hardware limitation of integrated audio decoder chip when same hardware plays the files fine on GB. im not sure i understand that. i got two amlogic 8726M1 players from two different companies that can play these files in 2.3.4GB.
  14. grindinonyourm

    grindinonyourm Well-Known Member


    does netflix only work on the older 1.2.0 version rom stane19830 posted? i was really hoping for newer netflix, because they have made significant improvements to the video qualtiy in more recent releases..how does it look on 0604 firmware?
  15. stane1983

    stane1983 Well-Known Member Developer

    Take ffmpeg library which is used (modified) in Amlogic sources. You take that library, do little coding and then you don't have eac3, but mp3 or some other format which audio decoder supports and can decode. Amlogic processors are powerful enough to do real time audio recoding. What Amlogic chipset does not support (at least m1 platform) is full HD VC-1.

    And I didn't say it can't be done. Eac3 etc is not my priority on c03ref boards. If I come up with a solution or if someone have a solution, share it with me and I will implement it.

    Visson abandoned M1 platform, which is good from my aspect. I'm maintaining c03ref ICS firmware for which I think is more than just a little bit better than Visson's ICS for m1 platform.

    My primary platform is f16ref, but since Android sources are the same (except for kernel), I keep c03ref active as much as I can. I have almost nothing from it. Since I started all this I received 7 donations (2 of them were from people I helped to recover their devices - means 5) with 830 fw downloads for c03ref and 62 downloads for f16ref.

    As I said in post earlier, if you don't like it, buy another product, buy f16ref for which I'm going to release new fw within 24 hours or go back to GB release or you can use movieplayer such as mx movie player where you can enable software decoding and you will have all you want, but with lower quality :)
  16. andriodfan

    andriodfan Member

    I just installed the latest Netflix from market. I can't see a difference with the one I had before, both play with Rom 20120604
  17. grindinonyourm

    grindinonyourm Well-Known Member

    hey stane, i hope i didnt offend you. sorry if i did. i was only asking because i was curious how the other boxes could decode. now i know so thank you. and i appreciate you supporting c03ref . you are doing much better than visson ever did. and yer rom is much better. i understand about moving on to the f16ref. i myself will soon buy one,just to stay current with the technology. but thank you for your work! we all appreciate it.
  18. MartinCC

    MartinCC Active Member

    Hi All ! I'm using today an old version of the firmware (20120604) and I'd like to decide if move to the 21 version or not... this are the things I'm looking forward and, if I'm not wrong, current status on latest firmware:

    BT - Not implemented
    MIC via BT - Not sure but BT is not implemented so...
    Wifi - Not sure (I think there is Wifi support but very limited yet, right ?)
    Xbox 360 - Implemented
    Webcam (For Skype) - Implemented
    Full Screen YTube Problem - Fixed

    If someone can confirm this status, would be great for deciding....
  19. grindinonyourm

    grindinonyourm Well-Known Member

    Netflix is not working. While it plays with video and sound for a little while on 06042012 firmware, the stream eventually stops and the only way to start it again is to back out of the video and start it again. timer doesnt run properly when video plays. it skips 3 seconds for every 1 real second. this is a problem we have had since i started using netflix on ICS. Netflix is completely non functional on stane1983's newer firmwares with custom kernels. but maybe a little comparison between what is different in the logs between the two firmwares and netflix sort of working and not working is in order..

    EDIT: new ROM from 06212012 is excellent at flash video sites now...at least the ones i have tried, especially gorillavid thru letmewatchthis.ch..just set browser to android and install adaway from market to block popups and whatnot. works great! HTML5 streaming video sites seem to work very well also!
  20. stane1983

    stane1983 Well-Known Member Developer

    Hey, I'm not offended, maybe I overreacted and I'm sorry for that :)

    I will keep maintaining c03ref platform as long as there are ppl who uses it :)

    Now I'm finishing f16ref firmware, should be uploaded within 2 hours... I included some changes to MoviePlayer and AppInstaller apps which will be also included in next c03ref release...

    Will post about it soon.
  21. grindinonyourm

    grindinonyourm Well-Known Member

    good to know yer still gonna support c03ref cos imma use the sh*t outta mine. til it dies. hey stane1983, have you had any defective units so far? what quantity are you purchasing in? or planning on? just curious?
  22. stane1983

    stane1983 Well-Known Member Developer

    New firmware for f16ref platform: V-Play download section

    Features are the same as for c03ref + some more which will be included in next c03ref build.

    AppInstall application behaves that that way: It will list /mnt/sdcard, /mnt/sda.... will not list /mnt/NetShares, but /mnt/NetShares/sharepath if any... If you don't have any network shares in AppInstall, NetShares won't be visible.

    MoviePlayer - shadow effect removed and added outline effect, I think it's better to use outline for subtitles than shadow.

    Features:
    - Android 4.0.4
    - IR remote support
    - resolution and scaling settings are now saved
    - CVBS output works
    - uinput and other input devices
    - new languages
    - camera support, needs testing
    - Network shares available trough /mnt/NetShares
    - MoviePlayer subtitles - shadow effect replaced with outline effect
    - AppInstall - /mnt/NetShares folder handling improved
  23. stane1983

    stane1983 Well-Known Member Developer

    I didn't have any big orders yet, but so far none of units were defective. One f16ref board (first they ever made) had malfunctioning wifi module, but that batch (100 pcs) was not intended to reach the market but samples for Visson's direct customers and for test purposes only AFAIK. Anyway, that device is also fixed cause they sent me new wifi module.
  24. grindinonyourm

    grindinonyourm Well-Known Member


    nice! when you drop the c03ref firmware, can you add news and weather back in for me please? also, i don't know if you added these bugs (c03ref) to yer list but :

    - SD cards don't automount when inserted, only upon reboot.
    - usb audio / microphone you already know about..i assume this will also affect usb webcams with microphones...so no skype quite just yet?
  25. stane1983

    stane1983 Well-Known Member Developer

    Hi, usb audio kernel bug fixed, it will work in next release. About sdcard, I'm aware of the problem, it's kernel bug... will fix that till next release. Same with news and weather, will be added. Did you manage to put news and weather to update package? It should be installed but it's not... GenieWidget.apk in new_patch.zip...

Share This Page