Android 2.3 & 4.0 WiFi Internet HD 1080P HDMI Google TV Box ARM Cortex A9 Firmware


Last Updated:

  1. grindinonyourm

    grindinonyourm Well-Known Member

    interesting, but geniewidget.apk was right where you said it would be /data/app. but it didn't work or show up in app drawer when there...manual copy over to /system/app and voila! it appeared in appdrawer and is ready to go. moral of story: put geniewidget.apk inside main update.zip '/system/app'`

    Advertisement
  2. stane1983

    stane1983 Well-Known Member Developer

    It can stay in new_patch.zip, just put it in /system/app. Better that way, adding apk-s to update.zip which is generated by android build system is little tricky (was not before ICS)...
    grindinonyourm likes this.
  3. stane1983

    stane1983 Well-Known Member Developer

    Hi guys,

    I created translation package which is available here. If you are interested in translating apps (FileBrowser, AppInstall, Upgrade, MoviePlayer...) to your native language, PM me to get credentials to be able to download that file. File is hosted under password protected folder, so you won't be able to access it w/o my approval.

    It's not approval, it's just I want to know who is translating to which language, so please put that in PM when sending request :)
  4. grindinonyourm

    grindinonyourm Well-Known Member

    http://androidforums.com/google-tv/408166-geniatech-enjoy-tv-31.html#post4570743

    here is confirmation from someone over in the geniatech thread that said they have functioning netflix in ICS. now to find out what is in this firmware that makes it work....
    We know that Netflix sort of works on 0604 rom, which is stane1983 compile but not stane kernel. Then 0621 rom with both stane kernel and rom doesn't have working Netflix..so it's partially kernel issues. Maybe all kernel issues for that matter, considering I have a zt280 tablet ICS and it can't do Netflix right either..its just like the 0604 rom. It works but eventually drops the stream and the timer runs weird.but geniatech kernel seems to work. Hrmmmmmmm...
    Edit: my zt280 is an 8726M3 platform. So Netflix behaves the same way with the stream dropping and timer malfunction on 8726m3 platform as well as c03ref with stock kernel.

    UPDATE: STANE1983: looking over logcat for netflix malfunction shows unsupported bit depth for h264 in amffmpeg.. also, is aac support compiled into kernel or added module? how does the video player system work exactly anyhow? it looks like there are quite a few parts to make it run properly and use hardware decoder chips properly.... an example would be, how does video data get passed around in say netlix from what my logcats say? what is amadec and why is it stuck on 'amadec : wait first pts checkin complete!' repeatedly in logcat? what is the function of the different things running, i.e. amcodec, amacodec, amlogicplayerstreamsource, mediaplayerservice, amplayeramavutils, amffmpeg? whats the flow of data between these programs?
  5. GuruSoda

    GuruSoda Member

    Hi stane, what dificult that is write this for me!, but i will try.
    This weekend i tested the new firmware, when play a movie has no problem and is much better than previous release when change the resolutions of screen.
    BUT ( always is a but ), if the resolucion is 1080P, appears in 1080P but see all the desktop tiny in the upper right corner.
    If in the settings change the display geometry to 720P, this is see in full screen, 1080P never see in full screen.
    As get it 1080P in full screen?, changing the resolution to 720P, reboot the android, go to settings and change to 1080P in this moment the full screen is correct in 1080P, but when reboot the android the desktop newly appears tiny in the upper right corner.
    In the previous release of the firmware this not happens, you know how to fix this problem?

    Very sorry for mi english!, I hope you have understood me.

    I am at your disposal to answer any questions.

    Thank you very much for all you effort.
  6. stane1983

    stane1983 Well-Known Member Developer


    Hi, I know that fw doesn't work well on 1080p, it's written here on the thread. I will solve this issue. Problem is that I'm building firmware for c03ref device from M3 source code and there are some differences in relation kernel display driver <-> resolution script <-> Android. I partially fixed 1080p bug on c03ref and I can tell that it will be fixed completely with next fw release.

    @grindinonyourm: Video reproduction is done this way:
    You have AV drivers which are loaded by linux kernel, you have LibPlayer libraries (which includes Amplayer library) which is called by Android. It means that all three components are tightly connected. It doesn't matter what application is used for video reproduction, all 3 components are used in all cases.

    @Everyone: I don't have any feedback on f16ref firmware, but do have 40+ downloads... Anyone tested? Experiences? I tested it myself, so far I did not find any errors. I do have white dots here and there when on 1080p resolution, but I believe it's connected to my old LCD TV.
  7. matinaki

    matinaki Well-Known Member

    Hi Stane1983
    You know, my demands about TV box are not high, I use that for internet surfing and for streaming video on 3 TV channels.
    I am one of people who downloaded and checked almost all your firmwares but without to be resolved that problem above.( I have never asked about..)
    Therefor all the time I moved back on Mediafire's firms which was not perfect but a bit better, sometimes playing such videos, sometimes not.
    Well, because of I would like to use your firmware, I wish to remind you, if possible, to try to fix that issue on your next release of c03ref board
    I appreciate your work and I thank you in advance independently if you execute my wish or not.

    P.S Pointer is great, old black one was absolutely not visible by me..
  8. GuruSoda

    GuruSoda Member

    Very thank you for you answer.

    Can you add the modules for nfs please?, i try mount a share via nfs but i have same error that older firmware...

    Thanks for you time and congratulations for you firmware.
  9. stane1983

    stane1983 Well-Known Member Developer

    All NFS modules are built in kernel... problem is somewhere else... will investigate.
  10. algadeed

    algadeed Member

    Hi Stane1983
    let me say thank you for your hard work and what a great firmwares ,, but bugs identified on
    Firmware - rev 2 platform (f16ref)

    20120625_Android_ICS ,, mouse courser move but no enter or select on any app , on the remote control when you press mouse it writes ( @ ) and not going back to mouse pointer ,, android market update it self to play market and some times work and some times not ,, when you start an app like antutu benchmark using regular usb keyboard no way to close the app and go out !! i press all the keybord buttons !! ,, still testing and thanks again for the hard work
  11. CoyoteX

    CoyoteX Active Member

    Send over credentials to me baby, im gonna traslate to PT-BR.... :-D also, did you get the heineken i sent u? Im Rene.
  12. iGNASI85

    iGNASI85 New Member

    Hi, it is my first post, but I have read all the thread... it's very interesting. So I want to congratulate for your work, concretely to stane1983! It's amazing!

    Moreover, the post is useful, specially for those who has briked the APTV... for instance, myself ...Tomorrow I'm going to recover it following the forum instructions (I'll cross my fingers! ;) ).

    If you "need" spanish and catalan translators I can start it.

    Best fo all! And again good work!
  13. stane1983

    stane1983 Well-Known Member Developer

    Wow, I assume it's quiet difficult to use IR remote control especially when in mouse mode :) I believe most of users uses wireless mices/keyboards or air fly mouses...

    About Back button, if you have any usb mouse, you can use it on your box, and mouse right click acts as back button.

    To be honest, I really never tried to do a real work with IR remote control. I just tested if it works and used remote.conf configuration file from Visson's M3 firmware. I will improve behavior of IR remote on f16ref and make it to work on c03ref.
    algadeed likes this.
  14. stevan58

    stevan58 Member

    Hi stane,
    I'm just flashed your new fw on my f16ref board and I'm happy to see that you solved most of the issues like scaling resolution, A/V out which now is properly working etc; still problem with the remote control which cannot switch off the unit and most of the keys are not working but as you said is not very useful use the remote control but it's much better use a normal USB or wireless mouse which is working fine. Now I have this problem: when I play a movie in any video format it's recorded, the playback is not smooth as before and the video gets a bit jerky as if the frame rate was too low. I tried to install another player from Google Play but nothing is changed. When the box is connected through the A/V out then every 2-3 minutes I hear audio noise that makes the same noise when you plug a Join with a unit turned on.
    Thanks for your time.
  15. stane1983

    stane1983 Well-Known Member Developer

    I'm experiencing something similar, will try to fix that asap... For example, I do hear clicking noises every few seconds if i move around with selector (eg in app launcher). It's related to audio decoder and that's what slows the unit down...

    Try this: Go to Settings, Sounds and untick Touch sounds.... works much better for me that way.

    UPDATE: I'm experiencing this on stock fw as well, how about you?
  16. matinaki

    matinaki Well-Known Member

    Hi Stane1983
    You know, my demands about TV box are not high, I use that for internet surfing and for streaming video on 3 TV channels.
    I am one of people who downloaded and checked almost all your firmwares but without to see that problem above resolved.( Of course I have never asked before about..)
    Therefor all the time I moved back on Mediafire's firms which was not perfect but a bit better, as about playing such videos.
    Well, because of I would like to use your firmware, I wish to remind you, if possible, to try to fix that issue on your next release of c03ref board.
    Also, I would like to ask from you to add Greek input method if possible.
    I appreciate your work and I thank you in advance independently if you execute my wish or not.

    P.S Pointer is great, old black one was absolutely not visible by me..
  17. LeftyVz

    LeftyVz Active Member

    Stane is doing great job... ;)
    well, as I can see stane's firmware was downloaded 513 (c03ref) + 49 (f16ref) times.. almost 600 people are using stane's firmware for Amlogic platform.
    You (all of you) made over 50GB traffic. And as Stane told me - only few of you (7-8) guys bought him beers to suuport him..

    There is server cost, bandwith cost... and stane is spending a lot of time on developement, and here on forum to help you.. Firmware is currently free and it would be nice if everyone who downloaded Stane's firmware buy few beers for him :)

    If you like Stane's firmware and if you want to see new releases for free it would be nice to support stane in any way you can

    Thanks to everyone who supported Stane!

    http://downloads.v-play.com.hr/
    Unforgiven likes this.
  18. jandy123

    jandy123 Member

    Have you also maybe tried World at War ? If not, could you please do itand let me know if it works ?
  19. stane1983

    stane1983 Well-Known Member Developer

    Hi. Greek ime will be included in next release, thanx for pointing me to that. I just don't know yet how I'm going to implement it but I will dig something out... :)

    I was working last night on c03ref fw, kernel exactly. I have some improvements, but still not ready to be released. Sd card mounting is fixed, I do have problems with 1080 resolution and not really sure how to solve it without compromising android source tree with that modification, because it works good on f16ref. Will see what I can do about it...

    To everyone who had problems with mouse cursor being replaced with bootlogo.... I managed to reproduce it! set_display_mode.sh script is responsible for that! Anyone had this problem with last firmware?

    Tech details about the problem will be posted on my subforum.
  20. stane1983

    stane1983 Well-Known Member Developer

    Still not working.... sorry.... It's not working on m3 either...
  21. grindinonyourm

    grindinonyourm Well-Known Member


    not quite. it does work.. change browser settings to 'Desktop' mode instead of android, then try to load world at war in browser. it will play back as long as you don't try to fullscreen. if you hit fullscreen, CRASH. try it out. and it does start out smooth but will quickly start to get too choppy to watch.
  22. jandy123

    jandy123 Member

    Aaargh... and it works so nicely both windowed and full-screen under 2.3.4... What the heck can be the problem ?
  23. grindinonyourm

    grindinonyourm Well-Known Member

    did 'world at war' ever work right on ICS? even with vissons precompiled kernel? or has it always been malfunctioning on ICS? i don't think i ever tried on any of visson's firmwares or stanes firmwares with vissons kernel...
  24. grindinonyourm

    grindinonyourm Well-Known Member

    http://www.amazon.com/gp/product/B004F173FA/ref=oh_details_o00_s00_i00

    i also bought this webcam from amazon for the low price of $2.50. i got it for half off the normal $5. it works very well with the built in camera app on stanes 0621 firmware. has a microphone as well that uses an analog audio headphone connector. works for the c03ref, but not th f16ref since it has no analog mic port anymore. no matter since microphone audio isn't working anyway til next firmware release. but great camera for cheap!
  25. stane1983

    stane1983 Well-Known Member Developer

    On f16ref, tested Logitech c170 camera with built in mic, works great with skype for example, doesn't work in native camera app (no picture). Camera's built in microphone works in all cases, no matter if camera is working or not, it works as regular mic. LeftyVz tested some Canyon camera, works in skype and have picture in native camera app, but unable to take pictures (he can take picture but it's black square), video recording is poor.... depends from driver to driver... I didn't use latest camera drivers available, just drivers that are shipped with kernel sources.

Share This Page