Android 2.3 & 4.0 WiFi Internet HD 1080P HDMI Google TV Box ARM Cortex A9 Firmware


  1. grindinonyourm

    grindinonyourm Well-Known Member

    ok...so ac3 works fine for me and i suspect it always has...its DTS tracks that are making the hissing noise every second. every dts track movie i got is doin it....i have a c71 upgrade 8726m3 tablet also and it does it as well. so how to fix dts is the real question. and how to edit my init.rc to start smbd with android? also, my wifi speeds suck! i get maybe 100k/sec download. i can't stream netflix or samba movies or anything streaming on the network and its because of my wifi speed! anyone else got shitty wifi?
  2. stane1983

    stane1983 Well-Known Member Developer

    If you don't have kernel sources, only way to edit init.rc is to unpack and repack uImage (boot.img)... Scripts for that you can find on xda forum thread I posted few posts earlier somewhere between page 60 and 70, don't know exactly :)

    I'm nearly done with first full featured ATV-108 c03ref ICS firmware. Taught it would be today, but I'll delay upload of my fw for tomorrow.

    What to expect of my fw:
    - entirely built from code, except for kernel image, since I don't have configs for ICS kernel, so Visson's image is used
    - MoviePlayer - multiple subtitle encoding support
    - Network - samba shares, upnp.... basically UI I used from GB sources, working on my own, but will not release it for now.
    - much better performance (in speed) than Visson's last firmware
  3. grindinonyourm

    grindinonyourm Well-Known Member

    i tried the unpack boot.img thing, but none of the tools would do it...they all complained about no android magic, or not being a full recovery or boot img....and i dont' have source code...im not an official amlogic partner yet...how are you getting samba to autostart? since you are building from source, are you building your own custom init.rc? also, what is up with ICS and wifi internet speeds? i think it might have to do with WPA encyption, but i gotta test further...but any 8726m device i have running ICS 4.0.3 with a realtek 8192cu wifi card is suddenly only getting 1mbps instead of the 10mbps i should be getting...two different networks, one 80211n and another 80211g, both with wpa ( wpa and wpa2) , and very slow internet...zenithink c71 8726m3 with 8192cu wifi and ICS 4.0.3 has the same issue? does yer wifi have the same issue stane1983? my settings are as follows:

    80211g w/ WPA (tkip) passkey - superslow BAD download speed, NORMAL upload speed
    80211n w WPA2 passkey - same as above
  4. sl0re10

    sl0re10 Member


    Must be. Maybe my wireless usb dongle radio sends enough random chatter to the box to keep it from going into standby.

    PS
    If your selling these I would point out how much space is available for programs to be installed and that your serious about the market working. I've bought other android devices that came with hardly any space for programs and the market hardly worked. I'm perfectly happy with these units.
  5. pwlad

    pwlad Member

    Oh, are you a developer for Visson?
    ICS.MBX.20120422 is your?
    Are the tools you use your "know how"?

    Respect (and sorry my English)
  6. stane1983

    stane1983 Well-Known Member Developer

    No, I'm not developer for Visson, they do have their own engineers for their firmware versions. Visson is producing hw for me, I'm adopting (adding features, translating, preparing for central and eastern european market) software and will sell it. Now, to be able to do that, I signed docs with Amlogic to be their partner.

    And no, ICS.MBX.20120422 is not mine. I didn't release any ICS version yet.
  7. andro516

    andro516 Member

    Hi ...

    When I Type The 2nd Part Command

    Code:
    amlogic@ubuntu:~$ sudo mount /dev/sdb1 /media/kernel/
    It's Give message: kernel Not Found ....
  8. pwlad

    pwlad Member

    Yes, before it, you need to enter this command:
    sudo mkfs.vfat /dev/sdb1
    and check that the directory /media/kernel/ exist. Create it, if not.

    p.s. Make sure that your flash drive is sdb
  9. grindinonyourm

    grindinonyourm Well-Known Member

    Hey there stane1983, hows the new firmware? im super excited to try...i gotta test wifi speeds and see if they are better than now..im also curious about this speed boost you say!
  10. stane1983

    stane1983 Well-Known Member Developer

    !!! Read first !!!

    This firmware is designed for Visson ATV-108 product version 1 (c03ref board). To make sure you have right device, go to Settings -> About device or about MediaBox if you are using ICS Android.

    This is test firmware which configurations are made for this particular device and should not be installed on any other device. If you are installing it on this device, you have no problems, but in either case, I do not take any responsibility made to your device by installing this firmware.

    Install Instructions:
    1. Extract all files from ZIP archive to root of your sdcard
    2. Pull out power cord from your device and put your sdcard in the device
    3. Use paperclip to press reset button on back side of device and keep it pressed
    4. Pull back in power cord to your box and wait for front leds to blink 3 times. After that release reset button
    5. Wait for upgrade to finish
    6. If you are upgrading from Gingerbread version of firmware (Android 2.3.4), repeat step 2 to 5 (when doing that, you will have no picture on your tv at all or it will be scrambled before upgrade starts -> that is normal behaviour)
    7. Unplug your device from power and power it back on. On first start you will see welcome screen where you can set up your box parameters). Everything what is not set trough welcome screen, it can be done by going to Settings from launcher
    8. Enjoy :)

    Features:

    - MoviePlayer: added shadow to subtitles
    - MoviePlayer: user selectable subtitle encoding
    - MoviePlayer: if player starts for the first time, default codepage used is set based on system language (English/Croatian/Chineese)

    - FileBrowser: Behaviour of Esc button is changed. When back or Esc on querty keyboard is clicked, FileBrowser goes folder up. When it is in root folder, it asks if you want to exit application

    - Network: Start of samba implementation, it does not work (can't mount network shares, but shows list of available shares in network)

    Known bugs/disadvantages:
    - V.play bootanimation does not look good, need to create new one
    - Some translations in MoviePlayer and FileBrowser are english only for now (such as encoding selection in MoviePlayer and quiting FileBrowser message dialog)

    I need feedback on this one :)

    Link to firmware: Download 20120527_Android_ICS-ATV-108-c03ref.zip from Sendspace.com - send big files the easy way
  11. grindinonyourm

    grindinonyourm Well-Known Member

    samba can be fixed by this:

    test: open terminal
    su
    at root prompt : smbd start

    then switch to network samba.apk and try again, also ensure permissions are set right for the 4 files (2 libs, 1 smbd binary, and samba.apk)it takes for samba to work. i have it working on my 4.0.3.

    if all goes well, you will need to add these lines to your init.rc in your boot.img , preferably right after service hciattach.


    service smbd /system/bin/smbd
    oneshot


    once that is added to your rootfs init.rc, repack your boot.img and yer all set.
  12. grindinonyourm

    grindinonyourm Well-Known Member

    i also have the 4 files you need...if you'd like i can post em up somewhere for ya. i found em on a geniatech enjoy forum on here....but they work on the atv-108 as well.
  13. grindinonyourm

    grindinonyourm Well-Known Member

    nevermind, i see you have the files in the rom....curious that network app works on my atv-108 but not in your build...probably a config switch somewhere...
  14. stane1983

    stane1983 Well-Known Member Developer

    Please be so kind and upload these files somewhere. Thanx :)
  15. stane1983

    stane1983 Well-Known Member Developer

    Which kernel have you used? My build of ICS is based on visson's kernel images (repacked to start smbd), but I'm not sure if their kernel supports cifs at all. I'm building same fw for m3 board which I have and I have kernel sources for m3, so if it works there that would mean that cifs is not supported by Vissons kernel.

    I do have m1 kernel sources, but lack of ICS configuration, so ICS is not working with this kernel version...
  16. grindinonyourm

    grindinonyourm Well-Known Member

    Download samba.zip from Sendspace.com - send big files the easy way

    here ya go.. unzip and place files where appropriate, dont forget to check and change permissions...easy enough to do with root explorer. enjoy. ill figure out which kernel im running...its the one from the last visson update. the 4-20 update....i used the samba from a geniatech enjoy product...
  17. grindinonyourm

    grindinonyourm Well-Known Member

    and im pretty sure cifs IS supported by their kernel because im using the samba.apk app to watch a movie right now with 4.0.3. stock firmware aside from root.
  18. grindinonyourm

    grindinonyourm Well-Known Member

    uname -a reports:

    Linux localhost 2.6.34 #1 PREEMPT blahblahthedate armv71 GNU/Linux
  19. grindinonyourm

    grindinonyourm Well-Known Member

    heres a question for ya..i want to add sleep function back into gingerbread rom...what files control the timer standby functions? how is that controlled?
  20. grindinonyourm

    grindinonyourm Well-Known Member

    so far stane1983, yer firmware rocks! way faster than vissons firmware. for example, i don't know how you fixed it, but audio video sync is now perfect in veetle, and netflix video runs so smooth, its amazing. couple of problems, no audio in netflix, tried a ton, no audio. had audio in netflix in visson's last firmware, so maybe its a system codec issue. i know most of netflix audio tracks are AAC. also, netflix only runs for about 5 minutes on most videos before the video stops playing. it just cuts out. logcat tells me that the amplayer that is actually decoding the netflix ffmpeg stream is disconnecting and shutting down. no reason why though. wifi is good and fast and stable with my 80211N router. wifi slows to a crawl and then drops connection and then reconnects on my 80211G buffalo router. hate the amlogic launcher. wish it had the regular android launcher frankly. samba network is broken as you said, but if you go to terminal and enter 'smbd start' as root, it works great! i took the liberty of repacking your new firmware but with root/superuser and my newer version files for samba stuff. i have a mesada made fv-3 player. its another amlogic 8726m box. i looked at it's init.rc and you've done everything exactly right to get smbd started properly..same on the atv-101 2.3.4 firmware. we are missing something here. also, can you do me a favor? can you add sleep function back into firmware since you have sources? i am desperate for it. i don't know why they took it out in the first place. i have a c71 zenithink tablet(8726m3 - 4.0.3) and its got sleep function. can ya help me out?
  21. laziod

    laziod Active Member

    Can anyone help me create the SD card via Linux so I can unbrick my unit. I am Linux illiterate, but I take directionss good. Pm me and we can Skype.
  22. grindinonyourm

    grindinonyourm Well-Known Member

    Download SDTool.zip from Sendspace.com - send big files the easy way

    download this tool everyone! and follow the instructions in the pdf only use your firmware files for this and not what the instructions say. this ONLY works on windows xp. but it is the easiest way i know to make a burned boot recovery SD card. no linux necessary. i love linux but dd is slow and a pain in the ass. use this tool and take the easy road!
    petar petrov likes this.
  23. laziod

    laziod Active Member

    I only have WINDOWS 7 and I installed Ubuntu on a partion of my laptop, but I just can't seem to get this terminal to work. i follow the directions but it says file or directory not found. I am a total noob to linux. Please help if possible. thanks
  24. stane1983

    stane1983 Well-Known Member Developer

    Ok, samba issue solved (on M3 board, should be the same on c03ref - same sources, but different board configurations). Since I have slightly different sources than visson (newer probably) just starting smbd in init.rc didn't work.. It has to be started after bootcomplete in order to work.

    init.rc:

    # Samba
    service smbd /system/bin/smbd
    disabled
    ....
    on property:dev.bootcomplete=1
    ....
    start smbd

    About netflix, I'm not sure how I can reproduce or fix this issue. I don't have netflix account (if needed one anyway), when going to netflix homepage it says it's not available in my country...

    About launcher, I will include Launcher2 in my next build (which will be today), and will also include su and Superuser.apk, so no need for repacking :)

    Next on samba, I will leave it for now as is. Still working on my own UI app solution.

    Now I noticed that if I exit Network, start it again and try to connect to my share it gives me error that it cant connect to ip... when I do click again to connect to share it connects. Seems that service goes to sleep or something like that... but it works... :)

    That's all from me now... will post link to new fw when it's compiled and uploaded.
  25. grindinonyourm

    grindinonyourm Well-Known Member

    so would it be better to rig up a broadcast receiver for smbd? also, if you go to a terminal and start smbd from there, 'su', 'smbd start' then switch over to network app, you can see what smbd is really doing...it only fires off and works when you connect up the share, then its job is complete so it stops. even in the terminal. you gotta go and type smbd start again to make it work again. it runs then dies. and needs a respawn every time you wanna run it. but it doesnt do it in 2.3.4. it starts in init.rc and works nonstop. wonder why? maybe newer sources like you said. kinda funny cos video with yours looks better than any other firmware i've tried. and flash is working amazing too. but mediaplayerservice stops running after 5 minutes of use. thats what logcat says. and it doesnt recognize the embedded tag for audio type in the netflix stream like it did in visson's firmware. stane1983, do you need any logs from me or anything that would help? also, youtube app just crashes upon open. that and netflix are a dealbreaker for me. if they don't work, then i gotta keep using visson's firmware. and i don't want to. i wanna use yours. its very nice.

Share This Page