Android 2.3 & 4.0 WiFi Internet HD 1080P HDMI Google TV Box ARM Cortex A9 Firmware


Last Updated: 2014-03-31 04:01:15
  1. stane1983

    stane1983 Well-Known Member Developer

    Yeah, I know for that... that was the way to fix ac3 in my GB release, to install ac3 license file. Problem is that our ICS bootloader and kernel can't load/save ac3 license. In gb you install license by putting license.efuse to root of your sdcard and adding --set_efuse_audio=1 to factory_update_param.aml for license to be installed with update. On ICS files (bootloader and kernel) it just doesn't work...

    Content of license.efuse (text) file: 00000011

    Yep, that's license file :D

    And no, I'm not abandoning m1, don't worry. Just need day or two to see how all this works on m3. M3 device will actually be selling device, so I have to test stuff on M3 too :)

    Advertisement
    payer likes this.
  2. grindinonyourm

    grindinonyourm Well-Known Member

    so i have about 12 different copies of ac3.bin. imma try em til one of them works..i know one will..it did before..will post when i discover it.
  3. stane1983

    stane1983 Well-Known Member Developer

    I'm having some progress regarding ac3... see 4pda link I posted earlier. It's still not working, but it's good starting point, I do have some progress on my device...

    Update: LibPlayer project and mediaplayerservice are changed to older version which is used by Visson firmware (I hope), so both ac3 and dts patches should work. Fw is compiling now, will see what happens when finished :)

    Update 2: We have ac3 and dts working, fw is uploading now
    Update 3:Bug discovered, when exiting MoviePlayer, UI doesn't show upwhen playing certain media files. Now trying to fix it, after that will post update
  4. grindinonyourm

    grindinonyourm Well-Known Member

    great news! i've been messing with ac3 all day and noticed that even when there was no ac3.bin present, it still had sound and the hissing noise..i thought that was kinda strange. i noticed the bug before but usually if i flick my mouse up or down, the UI came back. or it would just come back after a few seconds. so does changing mediaplayerservice and libplayer have any effect on netflix? curious to try and find out! and when this is all said and done, i think im going to start selling these in the U.S. im gonna do my setup stuff for amlogic tomorrow when i have a little more time. but US market will demand netflix from any device that hooks up to the TV.
  5. stane1983

    stane1983 Well-Known Member Developer

    Yeah, I changed mediaplayerservice and LibPlayer which also includes Amplayer, so there is change which might affect netflix behaviour...
  6. stane1983

    stane1983 Well-Known Member Developer

    Changelog:
    - AC3 & DTS working
    - Kernel frequency set to 900 MHz (governor conservative: 200-900MHz; was conservative 200-750MHz)
    - MoviePlayer - when exiting sometimes you had blank screen - that was hopefully fixed (was bug in Amlogic's code) - please report if you experience this issue again (with detail how that happened)
    - according to grindinonyourm, netflix works better now.

    To grindinonyourm: Please check with netflix once more, you were testing on 750 MHz, maybe it works better now.

    For new users, please read the thread for q&a. I promise I'll collect and post FAQ by the end of weekend :)

    Link to firmware:

    Download 201200603_Android_ICS-ATV-108-c03ref.zip from Sendspace.com - send big files the easy way
    schaum likes this.
  7. pwlad

    pwlad Member

    Hello Stane!
    You've done a great work.
    I'm going to try your firmware.
    I have one question - 1080p is fake?
  8. schaum

    schaum Member

    Hi all,

    Bought this box from China and received it last week.

    stane1983's 2012.06.01 firmware is running great (much much better than stock ICS). Specially for the network (samba) and DTS support ;-)

    I can't get 2012.06.03 running on my box. It seems to hang on the VPlay animation. Has somebody else experienced this problem? I'm flashing from SD card, as all other prior versions.

    @stane1983 thanks a lot for your time & contribution!
  9. andro516

    andro516 Member


    Mediafire Link .... Pls.
  10. grindinonyourm

    grindinonyourm Well-Known Member

    STane1983,

    Download netflix playing with no sound again and blank after about 6 minutes.txt from Sendspace.com - send big files the easy way

    logcat of netflix messing up some more. i trimmed it down to start of log, then i start netflix, then let it play for about 6 minutes then it blanks out. also, audio was working great again in netflix last fw, this one audio only works about 20% of the time. out of 10 tries, i only got audio out of netflix twice. otherwise, the speed boost is nice, glad i got the extra heatsinks! and ac3 and dts! yer awesome!

    UPDATE: so on netflix, when a stream begins, the timer runs kinda weird, counts about 3 seconds at a time...then eventually the video starts but no audio. i also notice that the timer stops counting yet the video will still be running. this happens for a little less than a minute, then the stream stops and the screen blanks. also, netflix video occasionally glitches and makes the screen go all pixelated green, then moments later, it recovers. but totally video corruption every once in a while.

    UPDATE: NEW BUG - During netflix or any other constant bandwidth intensive use of wifi, occasionally wifi signal begins to decrease. icon by system clock starts decreasing signal bars, then connection drops. wifi settings says that it is still connected to my network, yet there is zero signal and only disabling the wifi and turning back on gets it working again. this doesnt happen every time when using bandwidth but about 20% of the time. on visson firmware 2.3.4GB same thing would happen only signal would decrease very quickly then actually drop connection and disabling wifi wouldnt fix it. only a system restart would fix it. wifi rtl8192cu.

    UPDATE: also, the netflix screen blanking always happens after about 5 to 7minutes of playback. i use the same Star trek TNG episode to test. and every time, 5 to 7 minutes after starting, screen blank. i will test will other videos to see if timing is different, but i have a feeling that this is a key to this bug. the timing is always the same. not exact but also not arbitrary.
  11. shihabva

    shihabva Member

    I have MBX ICS VS-2
    Android 4.0.3
    Kernel - 3.0
    ICS.MBX.20120225

    I connected it to Samsung LED TV.

    It was working fine till it failed to connect to Android market , i did the factory reset. After that after watching Youtube for 5 miniutes , my TV display starts going blank for some time , then re connects.....

    I tried all possible resolutions and even changed HDMI cable to Component cables, still no progress...

    Can anybody Help Please ?

    (Sorry for my bad english)
  12. stane1983

    stane1983 Well-Known Member Developer

    Wow, that's pretty old fw you have.... Actually it's first Visson's public ICS release as far as i know :) First, i suggest that you install my last firmware using instructions from this post:

    http://androidforums.com/google-tv/...box-arm-cortex-a9-firmware-2.html#post4441200

    @pwlad: About 1080p, how do you mean that? It acually sets tv output to 1080...

    @schaum: You managed to boot the device? First boot takes long...

    @grindinonyourm: Will see your logcat, will update you...
    schaum likes this.
  13. grindinonyourm

    grindinonyourm Well-Known Member

    also, the timer in netflix runs erratic. it ticks by much faster than second to second. then it stops as i described before. curiouser and curiouser..

    UPDATE: upon reading logcat, i noticed dhcpd says something about timing getting skewed. also, when video stopped playing, mediaplayerservice destroys the open client then openglrenderer went into debug mode 0.
  14. stane1983

    stane1983 Well-Known Member Developer

    Colleague reported me a bug on 1080p resolution, I have to confirm it...

    Videoplayer does not behaive as it should on 1080... use 720 instead. I didn't test it on 1080.... my fault... sorry...
  15. grindinonyourm

    grindinonyourm Well-Known Member

    my player seems to work great at 1080p. so far. watching a 8 gb mkv of transformers 3 right now at 1080p..also gonna try that 13gb tron mkv i got and see if that works ok. what is the 1080p bug that got reported?

    does the 1080p bug affect netflix? will test and report back.
  16. stane1983

    stane1983 Well-Known Member Developer

    When you exit movieplayer, display is all messed up.... you might not have this behavior if you didn't use set display position in settings...

    Works good on 720p, but not on 1080... will fix it in next release.

    It should not affect netflix 'cause it's only MoviePlayer application issue, doesn't have anything with Amplayer or any other system libs.

    Update: I'll have some rest today, had family gathering which lasted whole day, pretty tired and full of food right now :D
  17. grindinonyourm

    grindinonyourm Well-Known Member

    oh yeah, i see it now...that was happening a little before but usually it just snapped right back into place...not this time! enjoy yer day stane! you've been working hard as h*ll for us. i appreciate more than you can know. now get that paypal set up so i throw money at you!
  18. stane1983

    stane1983 Well-Known Member Developer

    Not to worry, it should be done within 7-10 working days... :) I'm waiting my card from bank so I can link it with paypal... I could not receive funds with card I used before for buying stuff...
  19. shihabva

    shihabva Member

    @Stane1983 - I downloaded the Package , but i have the following result

    aml_autoscript - 1 KB
    ethmac.efuse - 4 KB
    factory_update_param.aml - 1 KB
    u-boot-aml-ucl.bin - 215 KB
    uimage_recovery - 4062 KB
    update.zip - 120,278 KB

    D:\****\4-23.4.0firmware.rar:CRC failed in market_patch.zip. The file is corrupt

    Again tried to download the Package through the link provided , it is showing "File removed by the user"

    Please help.......
  20. stane1983

    stane1983 Well-Known Member Developer

    I don't understand, which firmware are you trying to install? If visson's last firmware, then link is:

    Download 4-23 4.0firmware.rar from Sendspace.com - send big files the easy way

    If you want my last firmware link is:

    Download 201200603_Android_ICS-ATV-108-c03ref.zip from Sendspace.com - send big files the easy way

    In both cases if you're upgrading from ICS.MBX.20120225, you have to follow this procedure:

    1. Extract all files to root of your sdcard
    2. Unplug your device from power
    3. Insert your sdcard in device
    4. Use paperclip and press reset button on back side of box and keep it pressed
    5. Plug the device to power and wait for front leds to blink 3 times then release reset button
    6. Wait for firmware to install (ignore invalid parameter and mac error you see)
    7. Unplug your device from power and repeat step 4 to 6 (otherwise you will get scrambled picture on your tv output, nothing more)
    8. Unplug your device and plug it back in. Wait android to boot (first boot takes some time).

    If you want test, go with ICS.MBX.20120422 and then switch to my firmware and give me some feedback.

    On my firmware, use 720p as resolution, there is small bug (actually major bug, but easy to solve) with 1080 resolution in MoviePlayer.
  21. pwlad

    pwlad Member

    ICS.MBX.20120422
    After I selected 1080p I started AnTuTu Benchmark.
    The result was smaller then 720p.
    I think it's that because build.prop has this: 'ro.platform.has.1080scale=2'
    And your firmware has same string too.

    I installed your 201200603_Android_ICS-ATV-108-c03ref
    At first it loaded, the master started, I choosed some setup, but after I started work it stopped (no any reaction).
    And after rebooting the situation was as schaum wrote - 'It seems to hang on the VPlay animation.'
  22. schaum

    schaum Member

    Not yet.

    Just saw your reply this morning, so I reflashed 2012.06.03 and left for work. Will see if it has booted this afternoon when I get back home (9h should be enough for first boot right? ;-))
  23. jmcuts

    jmcuts New Member

    hmmm is there any way to unbrick this device without linux and only Win7?? I have the same situation as Lazoid did before but he has unbricked it succesfully...

    thanks for your help
  24. jmcuts

    jmcuts New Member

  25. alfios

    alfios New Member

    Hello Stane!
    You've done a great work.
    In firmware 4-23 i had the Italian language, but now in your rom there is no more.
    Is it possible to put all languages​​?
    thanks

Share This Page