Android 4.0.4 problemsSupport


  1. Linda1025

    Linda1025 Active Member

    Where to start...

    When I first got Android 4.0 in my Bionic, there were many issues. I eventually resorted to a Factory Reset.

    I now have 4.0.4 and have even bigger issues, primarily with the GPS/navigation. As I look at google maps, I'm sitting in the Atlantic Ocean. If I try to use navigation, I'm started about 50 miles from my home location, routed 50 to 200 miles out of my way, only to have to backtrack, and being told to make turns where I can't make them (interstates and one way streets). Oh, and let's not forget that the map is upside down.

    Before I do another reset (and lose even more data), how likely is it to fix my map/nav issues?

    Advertisement
    :
  2. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    Probably won't help at all. There was a 'fix' for accelerometer and GPS that I used back with my Motorola DROID that entailed spinning it in the air parallel to all three axes (horizontal, lateral, and vertical) in a particular manner to force the phone to basically calibrate itself.

    What I would do if I were you is any (or all) of the following:


    I'll try to dig up the 'calibration' instructions.
  3. Thom

    Thom Premium Guide Member Guide

    I wanted to make sure I understand the question ...

    You are currently un-root-ed and running ICS 4.0.4 release 6.7.246 and are having the problem. When you got the Bionic it was running GB 2.4.3 release 5.9.905 and it had the problem.

    You did a Factory Data Reset when you were on 5.9.905 and it did not correct the problem. You have not done a Factory Data Reset after upgrading to 6.7.246.

    Correct?

    ... Thom
  4. Linda1025

    Linda1025 Active Member

    Ever since 4.0, my phone has had issues. Mainly with GPS/Nav.

    I geo cache, and use turn by turn to get me to the location, and use Google maps satellite imagery to help me locate Ground Zero.I really noticed the problem yesterday when I was navigating to a cache location, and it started me in the wrong place, and took me way out of my way. I kind of knew where it was, but not exactly. I got there, but nav was giving me all kinds of strange directions.

    When I got to the location, and tried to locate GZ, the indicator for me was bouncing all over the place and I was standing still. I rebooted the phone and still had the same issue with the bounce.

    I've been using the phone for geo caching since August, and have used nav on this phone for over a year. I had an original Droid for a year before that, so it's not like I'm brand new to all this.

    I'll try the apps, and see what happens.

    Thanks,
    Linda
  5. Linda1025

    Linda1025 Active Member

    Partially correct. Unrooted Bionic, running ICS 4.0.4, release 6.7.246, and having the problem.

    When running GB 2.4.3 (unsure of the release), I did not have the GPS/Nav problems.

    When ICS was pushed, *THAT'S* when I started having the problems. I started having problems with the map not displaying correctly (gray boxes, instead of the satellite image, "searching for GPS", being re-routed in the middle of driving).

    Did not do an FDR on GB. Did one FDR since ICS (about 3 weeks into ICS, hoping to correct this and other issues). It sort of corrected the nav issues, but recently they have popped up again, and they are worse than before. The incorrect routing and it not taking me to the correct destination, are the major and most troubling issues. It's basically unusable for any kind of nav. The map being upside down is minor, compared to that.
  6. Thom

    Thom Premium Guide Member Guide

    Thanks for the clarification.

    I think all the suggestions from John are excellent.

    You have done a FDR (Factory Data Reset) since the ICS upgrade and are un-root-ed. I ASSUME you reinstalled everything after the FDR instead of restoring it from some backup local backup.

    I had a problem with Goggle Maps after installing ICS and I delayed doing the FDR for about 10 days (because of test commitments). In my case it would be off by half a mile to 5 miles. After the FDR it was once again as correct as Gingerbread was.

    Perhaps clearing data in the Maps app would help? John knows a lot more about GPS then I do.

    ... Thom
  7. Linda1025

    Linda1025 Active Member

    Yeah, I reinstalled. I made backups if my important information (phone numbers, addresses, etc), which is the one thing Google is good for, although trying to get my contact list back on the phone has been a problem.

    I wish I could say the FDR fixed my issues. Personally, I would love to be back on GB. I had no issues with it.

    I have had nothing but trouble with ICS. Like I said, nav is my biggest issue at the moment
  8. Linda1025

    Linda1025 Active Member

    I don't have a clue about what these apps are telling me. As far as I can tell, GPS Test says I'm using 7 of 11 satellites, with an accuracy of 105ft. Phone Tester's GPS status shows 5 of 10 satellites, and an accuracy of 96.0m. Which does nothing to explain why having the issues I am.
  9. Linda1025

    Linda1025 Active Member

    John, well, I've had some improvement. I used the tools on GPS Status and Toolbox, and recalibrated, and now I'm within feet of my home location, and turn by turn doesn't take me out of my way, and I'm not bouncing all over the place. It did take a couple of times, and I got the improvement after I rebooted my phone. I'll test it on some of my previous cache finds to see how well it does.
  10. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    Excellent news. Now that you mention it, a reboot was definitely one of the required steps to the calibration.

    The fact that the applications were showing you within feet of your actual location in the first place makes me wonder and scratch my head, but at least it seems to be trying to sort itself out.

    Keep an eye on it and post back if you have any more troubles.
  11. Linda1025

    Linda1025 Active Member

    I just checked my location again, and I'm back to being miles off (though this time about 8 miles). It didn't even last 12 hours. Now what?

    I'm pretty much back to square 1, with useless GPS/nav. Short of trying another FDR, I'm stumped. It's not the phone, because the GPS/nav worked with GB. It has to be ICS, because that's when things started going wonky.

    After I checked it last night, and it was close, I left the phone alone, until I just checked it again. So somehow during the night, it lost accuracy.

    GPS Test says I'm using 6 of 15 satellites with an accuracy of 315 ft. Phone Test says 8 of 15, with and accuracy of 32.0m. GPS Status says 7 of 14 with an accuracy of 209 ft. My geo cache app shows 7 of 14, accuracy of 157 ft. I'm baffled.
  12. doogald

    doogald Guides Guide

    Which location sources are you using? Just GPS, or also network and VZW sources? If you are using Google sources for location, do you have WiFi turned on or off?

    Just thinking outside the box a little, I'm wondering if there is a nearby WiFi access point/router that Google has mapped that was moved to a new location (i.e., the family moved, taking their router to their new home) which is messing up the location triangulation using WiFi?
  13. Linda1025

    Linda1025 Active Member

    I'm using Google and standalone, and WiFi is off. Same settings that I had before ICS. I turned WiFi on, and I was then about 15 to 20 miles from my house, and bouncing. Same routers as before around me. Turned it off, and went back to about 8 miles off. Also, I couldn't log onto my geo caching app with WiFi on, so I couldn't check the accuracy there. Turning WiFi off, I looked again, and I'm about about 5 miles off in the geo cache app.

    Turned on VZW location, and I'm about 5 miles off with it on. Still having a lot of the "searching for GPS" when I try turn by turn, and the routing is still a little funky. It seems to want to take the longest possible route from point A to point B, even though there are major roads that would provide a shorter route.

    I'm at a loss. My phone has been wonky since ICS. I'm tired of tech support and the lackeys at the VZW stores not being able to figure it out, and their answer is always FDR. I've done that, and it hasn't helped.

    Seems like Google is trying to compete with Apple to see who has the junkiest, most annoying OS around...
  14. doogald

    doogald Guides Guide

    I'd say try turning off Google location services (particularly if you usually have WiFi turned off) and go with just GPS and Verizon location services, recalibrate one last time with GPS Status and Toolbox, and restart. If you are carrying the Bionic in a case with anything magnetic, like some sort of clasp, try carrying without the case; I wonder if anything magnetic throws off the accelerometer in the phone?

    I do know that Maps should be warning you when you start that you should turn WiFi on for better accuracy if the WiFi radios are off; I'm sure that you have seen that message at some point.

    Beyond that, I'm at a loss...
  15. Linda1025

    Linda1025 Active Member

    *NOTHING* changed from working to wonky except for ICS. If I ever had to go into the VZW store, the lackeys would turn off WiFi. When I first got the phone, I was having issues with network connectivity (which I attributed entirely to Verizon), which they finally sort of admitted was their fault. The lackey's would take it upon themselves to turn off WiFi, GPS, and adjust my screen timeout.

    When I got ICS, WiFi would turn on and off on its own. And I could pretty much watch the battery drain when it was on. Even with an extended battery. Before ICS, I had my screen set to never timeout; I would turn it off on my own. With a full charge, I could leave the screen on, use GPS/nav, text, email, and still have about 20% battery left after 8 hours.

    Since ICS, I don't do nearly as much with the phone, and have to charge at least twice in 8 hours. And I can't set my screen timeout for longer than 10 minutes.

    ICS has been a completely and total fiasco for me. If ICS is this horrible, I dread JB.

    Anyhoo... I did just get the warning, after turning Google location services off. And I recalibrated, rebooted the phone, and I am back to being within feet of my home location. The question is, for how long?

    If it wasn't for the *serious* battery drain, I'd be half tempted to turn on WiFi...
  16. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    Strange. Are you in a 4G area, or a 3G area? With 4G enabled and WiFi disabled, I find my phone battery usage skyrockets, whereas with WiFi it goes down.
  17. Linda1025

    Linda1025 Active Member

    4G. Since ICS, WiFi just kills the battery, and I'm not always near a charger. And since iOS6 is so bad, I'll stick with the junky OS I know, rather than switch to one I don't know. *shrug*
  18. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    I wonder if one or more apps you have installed is set to connect / update / upload only on WiFi?
  19. Linda1025

    Linda1025 Active Member

    Just did a test. Turned on WiFi, with 70% battery remaining. 35 minutes later, I have 60% battery remaining. Screen was off, no texts or email sent or received, no calls made or received. At 70%, I had 4 hrs 13 mins on battery, when I checked and saw 60%, I had 4 hrs 49 mins on battery.

    Suggestions?
  20. Linda1025

    Linda1025 Active Member

    I turned WiFi off with 60% and 4 hrs 49 mins on battery, I have 6 hrs 4 mins currently, and am still at 60%, so over an hour of nothing happening with the phone.

    How would I tell if there's an app causing it?
  21. doogald

    doogald Guides Guide

    WiFi *will* drain the battery if you are not actively using it for network connectivity but have weak signal WiFi routers or access points within range. Since the signal is weak, the radios use more power. The phone is constantly monitoring WiFi near you to be helpful if you want to make a connection (and also for connectivity.)

    Screen timeout of 10 minutes! Mine is 30 seconds! Screen turned on will definitely drain battery faster. My screen is on only when I am using it...
  22. Linda1025

    Linda1025 Active Member

    Yes, I realize that WiFi will drain the battery, which is one of the reasons why I bought an extended battery. The longest life one I could get. Because at the time, I was making heavy use of WiFi, GPS, and text (SMS/MMS). Also email, mobile web, and camera. I was using my phone a lot, so I had it set to never timeout under GB. All that, and under GB, I could go 8 hours on a charge.

    With ICS, I don't do nearly as much. About half or less than before. And I still have to charge my phone more than I did with GB. It also takes way longer to charge now.

    I would hate to have the original battery now. The extended battery isn't enough for ICS.
  23. OutOfPhase

    OutOfPhase Premium Member Guide

    If you get to the point where nothing works, you can flash a totally new ICS. Follow the links in my signature. You can use either the modified or full 6.7.246 fxz. I would try the modified first and see if that will fix it, as this will keep your data and replace all the system files. If you are still having issues flash the stock 6.7.246 and start fresh.
  24. Linda1025

    Linda1025 Active Member

    I don't know what "flash a totally new ICS" is. I shouldn't have to know. I looked at the Bionic Life Saver page, and I don't understand it.

    I just want my phone to work. Like it used to, before this monstrosity called ICS was forced on me. I have had nothing but trouble with it, from day 1.

    I called tech support, I went to the lackeys at the VZW store, I posted on Motorola's forums. Everybody said do an FDR. I downloaded apps that were supposed to save my info, and they didn't. I lost a lot of information that I can't get back, when I did the FDR. And it didn't help with the problems I was having.

    My position according to GPS is now correct, however I get "searching for GPS..." for anywhere from 5 to 20 minutes, before it finally gets the signal. I didn't have that before ICS.

    At this point, I am getting ready to just throw in the towel. I've been dealing with this for over 2 months now.
  25. rdsok

    rdsok Well-Known Member

    No you don't HAVE to know... but then that would mean you'd need to take it to someone and possibly pay them to have them do the work... just like with car or other repairs, what you don't know, you have to pay someone that does do for you. What OutOfPhase suggested was not out of line, nor was it uncalled for, so don't blame them for making a good suggestion simply because you don't understand how to perform the steps needed.

    While I do understand you are having issues after the ICS update... it doesn't mean it means that ICS is at fault, just that the issue happened after you updated. Obviously either something got corrupted during the update or something you have installed is causing issues... but the issues are not directly ICS based otherwise everyone else would also be experiencing the problems as well.

    My GPS is spot on except when I'm inside a building ( which it shouldn't work well in anyway )... My extended battery, I am getting almost 48hrs of use out of.

    I think flashing is your next logical step as well... whether you choose to learn how to yourself or to find/pay someone to do it for you. Sometimes, technical issues requires technical solution and complaining about them doesn't make them easier or fix anything.
Loading...

Share This Page