Android 4.1.1 (Jelly Bean) Running On Sensation Google Now Working With Voice!

Last Updated:

  1. jason-567

    jason-567 Well-Known Member

    Requirements: Clockwork Mod Recovery + Skills + A rooted android phone, suck on that IOS users

    Please make a recovery image before you start. Just in case

    If like me you can not wait for the Jelly Bean to be running Android 4.1 on your HTC Sensation I may have the solution. I have browsed a few websites over the last few days and come across two tutorials to get 4.1.1 working on your sensation with Google Now working with voice functionality.

    I am only sharing the solution I have not developed it.

    Step 1 - Download the following 2 files.

    Step 2 - Copy both .ZIP files and paste to your SD card.

    Step 3 - Boot into recovery and wipe all data.

    Step 4 - Install AOKP rom through the install .zip from SD card method.

    Step 5 - Install Gapps through the same method. Reboot and power on.


    Step 6 - After first boot, go to Settings > Performance > Processor and set the minimum CPU frequency to 384 MHz, then tick the option: "Set on boot".

    Step 7 - Now, every time the phone boots up (including the first time), go to Settings > Developer options and tick "Disable HW overlays".

    If all is working well proceed to Step 8

    Step 8 - Download Google Now.

    Step 9 - Boot into recovery and install Google now using the install .zip method.

    You have now completed the Tutorial, Well Done.


    Please see below the 2 Links for the origional tutorials I followed.

    Please see the following screenshots.

    [​IMG] [​IMG]

    Google Now

    Please say thanks, it helps. If you have bricked your phone it is not my fault.

    zubero likes this.
  2. damon7620

    damon7620 Well-Known Member

    Oh how I wish I was rooted :\
  3. philco

    philco Member

    Hi Jason,

    Blimey, that sounds good ... in fact it sounds brilliant.

    Does everything work OK?

    Do the soft key lights function properly? (See my post in this forum)

    Do you have a standard 3G Sensation from Vodafone UK?

    I might just go for it!!!

  4. jason-567

    jason-567 Well-Known Member

    I have yet to find anything that does not work on this ROM!

    If you decide to go for it let me know how it works for you...
    philco likes this.
  5. philco

    philco Member

    Hello Jason, I spent a couple of days getting my head round all this rooting stuff and I think I'm getting there. I have a 'stock' sensation and I bought a rooted one off ebay. It has the ARHD rom and s-OFF. As I can't sort out the softkey led problem I'm going to do the JELLY BEAN flash. When I'm happy with my rooted phone I'll sell the near mint stock one.


    I have a rooted sensation

    Skills? I've learned a lot over the last couple of days plus I spent 40 years working in datacoms and IT so other than some new terminology I'm pretty happy having my 'hands on' this sort of thing ... even at 63!!

    I currently have 4EXT as my 'RECOVERY' option. Does it have to be CWM?? Do you think steps 6 and 7 would still work from 4EXT (or are they done on the phone ... I guesss they are).

    Having read about CWM I think I'd prefer to to have it as my RECOVERY method. I know how to download the CWM file and get it onto the SD card but how do I replace 4EXT with CWM????

    Sorry about all the questions.

    Tks for your help.

  6. jason-567

    jason-567 Well-Known Member

    I have never had to do this but browsing the internet I believe that if you install ROM Manager on your phone, from the market. (link below)

    On your phone it should ask you to install clockwork mod and will just replace 4ext.

    And if you install the ROM through 4ext you would still have to complete steps 6 and 7.

    (I don't know much terminology at all so your ahead of me on that front).

  7. philco

    philco Member

    Hi Jason, Tks for that. Yup, I picked up on downloading the rom manager app a couple of hours ago. I've got Gapps and and the latest version of the rom on my pc and just going to copy them over to the sd card. Then .... I'll go for it ... but might leave it to tomorrow when my wife is out and I have the place to myself to curse and swear!!

    I haven't been able to download the google voice zip file. I followed your link and installed the software but everytime I click to download the zip file it just hangs. I'll think about that later.

    Tks for getting back to me.

  8. djtj1985

    djtj1985 New Member

    hi there. i dont know if ive missed something but ive installed aokp and gapps to the phone and now my phone is just going round and round on the aokp logo (wont boot)

    any ideas?
  9. jason-567

    jason-567 Well-Known Member

    Seems like you have successfully installed the rom to me.... may take a few battery pulls, bare in mind the first time you boot a rom it will take ages (usually no longer then 10 minuets though). Have you got this working yet?

    If not.
    Try and re-install the rom.... (did you wipe all data? if not do that first). If it still doesn't work let me know.

    If so.
    Here is an alternative download link for google voice....
  10. philco

    philco Member

    Hello, Sorry to hear that ..... as my install went exactly as it should. My first boot took 4 to 5 mins where the aokp screen was present and then it wanted my gmail stuff for mail and the market ... and then it all worked. As an almost complete novice I can only suggest starting from scratch from the hold down volume and power button starting point.

  11. philco

    philco Member

    Hi Jason,

    It went like clockwork :)

    I installed ROM Manager, installed CWM from the SD card, ran CWM. CWM had the option to do the backups etc and then I shut it down and booted it with the vol/power held down and then chose RECOVERY and the CWM options were there.

    I installed GAPPS and AOKP, turned it off, powered it on again and then went through the setup. I didn't get on so well with Nova and the standard launcher that came with it so I installed APEX which I'd got with all my other APPS (and contacts) on the SD card.

    I pretty much have it how I want it now but annoyingly even when I turn the phone off the soft keys at the bottom of the phone stay on causing pretty heavy battery use. I'll look into that in slow time.

    Performance is exactly what I was hoping for. No real lag and lots of nice touches from Jelly Bean. I'll put my Task Manager on later and see what tasks are running and how much memory is being used during a typical session on my phone.

    Some time soon I'll also have a go at downloading the google voice file from the latest link you posted.

    Bye for now.

  12. djtj1985

    djtj1985 New Member

    thanks for the replies but i now have a new problem. like an absolute noob i got mad that i couldnt get my phone to work so i thought that if i pressed the stock kernel button on the one x software that it would return my phone back to its original state but it hasnt and now all i get is the green htc logo on the white background and it wont move from it.

    have i bricked the phone?
  13. pastafarian

    pastafarian P√Ętes avec votre foie Moderator

    Moved to all-things-root!

Share This Page