Android 4.1.1 Jellybean autocorrect does not work, please help!


  1. mardanlin

    mardanlin New Member

    I have Predictive Text and Spell Correct turned on, but it still will not autocorrect my words. All it does is display a list of words it thought I meant to type above the keyboard. ICS did this exceptionally well, why don't JellyBean do it at all?

    I really don't want to have to flash ICS back onto my S3, but if there is no workaround or patch for this in the near future, I will be forced to.

    I am very disappointed in the new OS upgrade, for more reasons than just this, but this is the most serious and prevalent issue. I would really appreciate any and all help you guys can provide.

    Thanks,
    Dan

    Advertisement
  2. rmoote

    rmoote New Member

    I have the same problem on my Galaxy S2 with 4.1.1, surely there is some way to turn autocorrect on? It doesn't work with the Samsung keyboard or the Swype keyboard - they both show a list of replacement suggestions but don't automatically select their best choice. I turned on all the settings that seem to apply but nothing works.

    The Jelly Bean keyboard does do autocorrect correctly, so (apparently) it's a problem with the Samsung and Swype keyboards, not with the Android OS? So far I don't like the Jelly Bean kbd as much tho, plus when I turned it on I was warned it saves all input including credit card numbers etc, so I'd prefer to go back to the Samsung kbd.

    Does anyone know how to turn on autocorrect with Samsung or Swype kbds?
  3. Digital Controller

    Digital Controller The Real Bass Creator Guide

    There should be an option within the settings in Text Correction > Auto-Correction and when you hit the space it will auto correct what you type, and you can change it to be off, modest, or aggressive...
  4. rmoote

    rmoote New Member

    That Text Correction->Auto Correction setting exists in Jelly Bean, but it doesn't exist in the Samsung or Swype keyboards. In the Samsung kbd, for example, the closest thing is Predictive Text, which gives you a bunch of options, like Word Completion, Spell Correction, Next Word Predition, Auto-Substitution, all of which I turn on, but to no avail.

    One thing I notice - under Language and Input->Keyboards and input methods, of the four choices there, Google Voice Typing and Jelly Bean Keyboard are shown full intensity, and Samsung keyboard and Swype are grayed out, even tho they are checked and I can still select them as the default keyboard. Don't know if that's a clue.

    Do I need to update to new Samsung and Swype keyboards now that I've updated the OS to Jelly Bean? I downloaded the Jelly Bean keyboard, which works, after I updated the OS. If I do need to update the other keyboards, I don't know how to do that - I went looking for Samsung Keyboard in the Play Store but didn't find anything.

    Thanks for any ideas you can offer!
  5. Digital Controller

    Digital Controller The Real Bass Creator Guide

  6. pieceofpizza

    pieceofpizza New Member

    this is simply a problem with language pack.follow the steps below (based on Galaxy tab2 with JB 4.1.2)
    1. settings
    2. language & input
    3. tap on samsung keyboard settings icon
    4. tap on input languages
    5. tap to download desired language pack(eg. English(UK)
    6. check the box in front of downloaded language
    you are done. start typing !
  7. chanchan05

    chanchan05 The Doctor Guide

    Why not just download a keyboard that does it better than the stock can? Like Kii or Swiftkey.

Share This Page