1. Introducing Channels - a new way to chat with other Android users!
    Dismiss Notice

Android and .aspx


Last Updated:

  1. Frazster

    Frazster Member This Topic's Starter

    Joined:
    Nov 18, 2008
    Messages:
    9
    Likes Received:
    0
    I created a site for mobile devices and it works on most. It is asp .net (.aspx) but I can't seem to connect to it on my G1. Does Android have a problem with .aspx pages? I even created a test .htm page, but still no go. It could be just me, I don't know.

    Could anyone with a G1 test it for me?
    http://m.usrds.org/

    Here is the test .htm page:
    http://m.usrds.org/x.htm

    Thanks.
     

    Advertisement
  2. Cryptic79

    Cryptic79 VIP Member VIP Member

    Joined:
    Sep 10, 2008
    Messages:
    576
    Likes Received:
    24
  3. Frazster

    Frazster Member This Topic's Starter

    Joined:
    Nov 18, 2008
    Messages:
    9
    Likes Received:
    0
    Thanks. Still won't work for me, I get "Page Not Available.", but I can brows any other sites. I don't get it.

    Thanks anyway.
     
  4. Cryptic79

    Cryptic79 VIP Member VIP Member

    Joined:
    Sep 10, 2008
    Messages:
    576
    Likes Received:
    24
    Something wrong in IIS? I don't know much about mobile apps and if there is any difference, but does the default content page have <whatever>.aspx in the box?
     
  5. Frazster

    Frazster Member This Topic's Starter

    Joined:
    Nov 18, 2008
    Messages:
    9
    Likes Received:
    0
    The is no different then any other .Net website. There is a webcontrol for mobile apps in .Net, but I didn't use it. The full path is:
    http://m.usrds.org/default.aspx.
    It just won't work on my G1, not even:
    http://m.usrds.org/x.htm and that's just html.

    This works on Blackberry, Windows Mobile, IE, and Firefox.

    Did I understand you right when you said it works, that you trided it on your G1 and it forks fine?
     
  6. Cryptic79

    Cryptic79 VIP Member VIP Member

    Joined:
    Sep 10, 2008
    Messages:
    576
    Likes Received:
    24
    No. Couldn't get it to work on the phone. Ok. Another, possibly dumb, question. Are you getting to it from an outside network on the Blackberry, WiMo, IE, and FF? I figure this is an even smaller chance than the home content thing, but worth a shot.

    I'm just grasping at straws now. :p
     
  7. justjimjpc

    justjimjpc Premium Member VIP Member

    Joined:
    Nov 3, 2008
    Messages:
    10,543
    Likes Received:
    210
    Might have worked but it didnt work for me and is actually a redirect and the closest thing the browser could find ... so you might want to look at it again ... I also check the above link with FireFox and it shows a problem with the address and puts up closest thing it can ...
     
  8. Cryptic79

    Cryptic79 VIP Member VIP Member

    Joined:
    Sep 10, 2008
    Messages:
    576
    Likes Received:
    24
    Probably supposed to be FAQ.aspx. Oops!
     
  9. Frazster

    Frazster Member This Topic's Starter

    Joined:
    Nov 18, 2008
    Messages:
    9
    Likes Received:
    0
    Hmmmm. I'm inside the network right now, so I guess I will have to check when I get home. Did you try those links in a browser (IE, FF)? Is so, and it works, then it must be something with Android. If it doesn't work for you in IE or FF then it has to be my network (server).
     
  10. Cryptic79

    Cryptic79 VIP Member VIP Member

    Joined:
    Sep 10, 2008
    Messages:
    576
    Likes Received:
    24
    Hangs both IE and FF.
     
  11. Frazster

    Frazster Member This Topic's Starter

    Joined:
    Nov 18, 2008
    Messages:
    9
    Likes Received:
    0
    Ok, must be something with our server.

    Thanks a lot for all your help.
     
  12. Cryptic79

    Cryptic79 VIP Member VIP Member

    Joined:
    Sep 10, 2008
    Messages:
    576
    Likes Received:
    24
    No problem. What version of .Net are you working with?

    I'm a SharePoint 07 developer.
     
  13. Frazster

    Frazster Member This Topic's Starter

    Joined:
    Nov 18, 2008
    Messages:
    9
    Likes Received:
    0
    2.0 with the 3.5 add on. I'm kind of new to the .Net framwork, but slowly learning. I spend most of my time programing in SAS.
     
  14. pestilence

    pestilence Well-Known Member

    Joined:
    Oct 15, 2008
    Messages:
    174
    Likes Received:
    4
    I was gonna guess it was DNS related, like your domain hasn't propagated out to whatever DNS servers t-mobile sends us to, or you have a hosts file you forgot about on your desktop or something.
     

Share This Page

Loading...