Android and WIFI: What's the story?


  1. Timurid

    Timurid Member

    I am on my third phone in five weeks, and am getting ready to bring this one back too. I'm a newbie when it comes to mobile phones, so I have some questions for those in the know. Let's talk WIFI.

    I'm not sure if Canadian routers are different in some way, but Android phones seem to have problems with the routers I've tried my phones on. My first two phones were INQ Cloudtouch, and both had the "obtaining IP address bug" that is fairly widespread.

    I brought both phones back to Best Buy, and the second time I decided to get a Samsung phone because I assumed that it must be a flaw with the Cloudtouch. As usual, the WIFI worked the first day. When the bug appeared on the second day of owning this phone, I nearly fell out of my chair.

    I've done a bit of research, and was surprised to find that this has been an issue for at least a couple years, and on many different phones. Is it impossible for Google to fix for some reason?

    I learnt about the workaround that involves turning off the WIFI, and connecting by starting the AllShare app. That worked for a while, but didn't last. Now when I do it, I get a different Android WIFI bug. The WIFI connects, but if I try to get online with any app I get a message that tells me I'm not connected.

    Looking into this new bug, I found advice that suggested I go into airplane mode to reset something. This worked... at first. It still sometimes works, but usually not.

    I'm at my wit's end, and don't know what the heck to do. When I traded in my second phone, I was enthused to be getting a Samsung with Gingerbread, but it looks like nothing has changed.

    I've searched multiple threads and articles, but it seems as if I have to root my phone in order to solve this problem. I don't consider this an option, because I don't want to void my warranty, and it seems to be something that you shouldn't do before you're pretty familiar with the tech.

    The fact that this problem has been ongoing for years, and continues with the new OS, suggests to me that this problem won't necessarily be fixed any time soon.

    I've tried WIFI Fixer, Wifi Static, WeFi, and assorted workarounds, but nothing takes care of this. It really seems like the only good answer is to root and delete/rename that file storing the IP's.

    On top of these problems, none of my phones have been getting strong signals. I was surprised to see other students at school with one or two more bars of WIFI than I had, and ran a test at home. In order to get full bars, I not only have to be in the same room, but I have to be within ten feet!

    I have the same problem at school and at home, so it definitely isn't all the router's fault in either case.

    Are all Android phones afflicted with these issues? Is there a possible fix that doesn't involve rooting?

    If not, I'm wondering if I might have to try and get out of my contract. The only non-Android phones available where I signed up are Blackberrys that are out of my price range. Would a non-availability of working phones not be grounds for voiding the contract?

    Thanks for any comments or advice.

    Advertisement
    :
  2. IOWA

    IOWA Mr. Logic Pants Moderator

    Umm, what are you talking about sir? What kind of phone? None of my Android devices have had any of these issues.
  3. bioforce

    bioforce Well-Known Member

    Don't know what to say other then I've never had problems with wifi here or at school.
  4. Clevo89

    Clevo89 Well-Known Member

    You haven't mentioned what sort of work you have done with your wifi/router to see if there is a problem with the way your router assigns IP addresses.

    If you have set your phone with a static IP address (using wifi static) your bound to come across situations where your static IP address has already been assigned to another device.

    I use wifi Static for my wifi connection at home only and leave the rest for the router to assign the IP through DHCP.

    at home I chose an IP address ending in 10 for my phone (or a number above the number of gadgets that will more than likely connect to the Router through wifi).

    It seems to me you have a conflicting IP address issue possibly from with the way you have used all thos IP address apps.
  5. Timurid

    Timurid Member

    Thanks for the replies, and sorry about the tone of my first post; I was frustrated and it bled into my words. On top of not being able to connect, my GPS suddenly doesn't turn on anymore and I was ready to snap.

    I have a Samsung Galaxy Ace right now, and the previous two phones were INQ Cloudtouch. All three phones had the same problem. If the threads in this forum and others are any indication, this is an especially common problem with Samsung phones.

    I am usually able to fix the issue while I'm at home by restarting the router, but it's a real pain because it's in one of my landlady's rooms. Every other device connects fine, and on the first try.

    The same problem occurs at school, so it isn't just the router here at home. I'm not sure about the free WIFI at cafes and such yet, because a feature of this bug is that you connect fine the first time on each router.

    I don't have the phone set to static IP's, so that can't be it. Setting a static IP for home might work, but I'll still be unable to use WIFI anywhere I've already been once.

    My problems began before I downloaded a single app, so that can't be it. I downloaded all of those WIFI apps because they were variously suggested as fixes.

    I finally got connected today when I decided to wait a bit after I engaged airplane mode in case whatever it does isn't instantaneous. I don't know if that's the answer, or if it just worked this time, but time will tell.

    From what I've read, the problem is the DHCP folder keeping IP's that are out of date and conflict with the new one assigned by the router. Users who root are able to fix this problem once and for all by simply deleting or renaming that folder to force the program to go through the full process of getting a new IP each time.
  6. Clevo89

    Clevo89 Well-Known Member

    No worries...I can understand your frustration so don;t worry about the tone of your posts.

    The DHCP IP assigning is normally controlled by the modem/router and they should be on a 24 hour lease (reset after a day).

    To have such similar problems across several phones just seems to me that the problem might be something other than the phone.

    I'll check my rooted phone for any DHCP/IP settings and get back to you ASAP (at work at the mo)
  7. Timurid

    Timurid Member

    Thanks a lot, I appreciate it.

    BTW, when you turn on GPS you're supposed to get a little satellite dish in notifications to indicate that it is currently running, aren't you? I was having problems with GPS, so I haven't been using it but I could have sworn that you got that little icon whether or not it could get a lock at that time.

    I'm going to head out and see if it can find my location without using my router, or if I need to try the fix suggested here: http://androidforums.com/epic-4g-su...-cache-problem-workaround-tested-working.html

    I really hope that the GPS hardware is not broken.
  8. Timurid

    Timurid Member

    OK, it looks like giving airplane mode ten seconds to do its thing is the answer! The AllShare app gets the connection but doesn't allow you to go online, but airplane mode resets something and apparently fixes that particular bug as a side effect. I guess that I need to see if it lasts, but it seems to do the trick.

    GPS was working fine, so maybe I was remembering something wrong. I used the new Google Maps Navigation and it worked like a charm. I also downloaded the GPS Status app, which is wonderful BTW, so one or the other seems to have fixed the problem I was having with incorrect locations being given as my current location. Those are a great pair of apps that everyone should try.

    As for WIFI bars, do they mean the same thing on every device? I suddenly realised that I'm not necessarily getting slower WIFI than other devices if it's just that mine needs a much better fix before it gives the full bars.
  9. Tcarlin

    Tcarlin New Member

    How can I fix the wifi bug in my tablet without always having to reset? Will an update come out to fix this super annoying problem? The table is unusable without wifi. Can anyone help? Can I buy a 3G connect somehow?:(
  10. John Redcorn

    John Redcorn Well-Known Member

    HTC stock roms seem to exaggerate the number of bars compared to stock android. (or maybe stock under-reports). I can get full wifi bars all the way out to my street or back fence on an htc rom, but have to be in the same room as the router to get full bars on an aosp rom.
  11. KyleB

    KyleB Well-Known Member

    I'm in Canada and haven't had this problem, never heard about it before. I have HTC Magic and Linksys router. No problem with wifi at home or at work.

    Hope someone chimes in with a response that helps for you
Loading...

Share This Page