Android calendar app not syncing with google calendar - help!


  1. rs142

    rs142 New Member

    Hi,

    I have been having a problem with my phone not syncing with my google calendar. I add a new event on google calendar on my computer, and it does not update on the app, although it always used to. It has had plenty of time (24 hours +). I have tried Settings > Accounts&Sync > Google > Sync now, and in fact 'sync all', and nothing. No circular arrows on the bar at the top or any indication it's doing anything at all. I have tried 'sync now' in both the android calendar app and the business calendar app i use. When I go into my Mail app (non gmail) that will sync quite happily.

    So to try and solve this I read some advice online which advised me to clear the data in 'Calendar storage'. So I did this and now I have no appointments whatsoever in my android calendar, and no way to sync with my google calendar to get them back! I've also lost my bank holidays that the app came with, but I can live with that.

    Any suggestions gratefully received. I was so pleased to be able to sync my phone to my calendar and now it no longer works!

    Phone: HTC Wildfire
    Network: 3 mobile (UK)
    Android version: 2.2.1

    Anything else I can tell you please let me know.

    Advertisement
    :
  2. rs142

    rs142 New Member

    Any ideas anyone? My phone's had several hours and still not synced.
  3. jefboyardee

    jefboyardee Well-Known Member

    Have to ask an obvious question: any chance you’re turned sync off for all your calendars? It would still show Sync Now and like you described, but the arrows won’t turn when you tell it to, as I recall.
  4. Tim K

    Tim K Well-Known Member Contributor

    In the calendar app itself, there should be a setting for "calendars to sync". Make sure the correct ones are checked off or they won't sync no matter what your general sync settings are. Sorry I am not familiar with your phone and don't remember the calendar configuration from Froyo.
  5. rs142

    rs142 New Member

    jefboyardee - obvious questions are good! You mean in the calendar apps themselves, like Tim K suggests? When I go into the calendar app's menu, then 'calendars', my gmail calendar is checked.

    Sorry for the delay in responding - am now at home and can answer more quickly. Thanks for your suggestions so far.
  6. jefboyardee

    jefboyardee Well-Known Member

    Yep. Open Calendar > menu button > More > Calendars > tap the ones you want until they say
  7. expalpo

    expalpo Active Member

    If you think you have all the settings correct in the calendar app… double check all the auto-sync settings within Android, to ensure you have covered all the basics.

    Android Settings -> Accounts & Sync
    1. Ensure that Background Data is “checked”
    2. Ensure that Auto-sync is “checked”
    3. Click the account associated with the calendar you are attempting to sync. (e.g. Google Account)
    4. Ensure that Sync Calendar is “checked”
    5. Click “Sync Now”

    If the sync is still not working try “Synker”, free, from the market. Once installed.
    1. Click on the Synker app from the app drawer
    2. Ensure Sync Notification Service is “checked”
    3. Ensure Sync error notifications is “checked”

    That should allow Synker to display the account that is syncing in the notifications windows and if it detects sync errors it will notify you. Unfortunately you need to purchase the Synker unlock key to get to the additional information for the error but might not be needed for a quick test.

    Setup a Synker widget to just sync the calendar… if you see the “sync notification” that should at least tell you that the calendar is attempting to sync.

    https://play.google.com/store/apps/details?id=com.afterhoursdevelopers.android.synker
  8. rs142

    rs142 New Member

    I think I have solved it - although I don't really like the solution!

    I have been sitting at very low internal memory, as the apps I have have gradually increased in size. In order to install or update anything from the market I have to uninstall facebook, my largest app. So I did this to get the Synker app expalpo suggested, then I noticed my phone was syncing so let it finish and there was my calendar back! Now when I go into settings and press 'sync now', it actually does something, and I can see the wheels go round, whereas before it did nothing at all.

    So now I have my calendar back - at the cost of facebook! I will have to do a proper purge of apps I don't need, and hope I can make enough space to have both.

    Thanks everyone for all your help.
  9. thomashacker

    thomashacker New Member

    I was having the same problem. I would create events on my phone, then after logging into gmail on my computer nothing would show up. I would sync and re sync and nothing was there.

    There were two calendars on my phone. My phone calendar and my gmail calendar. I realized this because some events had different colors. On my phone red was gmail synced.... and blue was not, it was phone only. The first thing I did was clicked on all blue events, hit edit, and about half way down there is the option for selecting which calendar you post it to.

    To change your default calendar:

    Go to calendar - settings - Default Calendar

    The very first option says calendar. Select that and you have options for
    all calendar
    my calendar
    gmail

    I selected only the gmail. Now when I create events it only has the option of creating the event on google calendar.

    Just to clarify I had to go back and edit previous entries that I had made to change them to google calendar. To do this you have to edit the event, and about half way down you have the option of selecting which calendar it is posted to. I have the feeling if you don't change your previously created events to gmail calendar and you deselect the "my calendar" the will disappear.

    Hope this helps!!

    I tried not to make it super confusing, but honestly google didn't make this one very intuitive.
  10. thinker25

    thinker25 Member

    I have items from a few weeks ago on my phone. I am syncing Android phone (Motorola MB520, Android v. 2.2.2) to my google calendar. My google calendar is syncing from Outlook on my laptop, no problems with that. The online google calendar has stopped syncing to the phone.

    I hit the account and made it sync - and now it hasn't stopped syncing for about 4 hours with no end in sight. The new appointments are not showing up on the phone. If I try to stop that sync, it warns me not to.

    I went to Settings>Accounts> and chose my gmail account which seems to be the one that syncs. On this phone, under accounts, there are "Motoblur" accounts, one of which is my gmail address, and "Other Accounts" which shows only my gmail address. The latter is the only one that has a sync option and it won't stop - nor does it seem to be updating. The Outlook 2003 app on my laptop that it is syncing to goes back forever on the calendar (10 years or so) but obviously the new events are... new.

    I can't find a solution and I've been looking all day.

    One thing - there is no "Settings>Accounts and sync" option, just settings>accounts. I noticed references to "Accounts and sync" in several posts.

    Help, please!!! And many thanks. I don't have wireless access and this is eating cell minutes syncing right now. Oh joy. I can manage that, but it doesn't seem to by doing anything really :)
  11. ColdDeadHand

    ColdDeadHand Member

    I have read, re-read your directions, all to no avail. The calendar absolutely will not sync and I absolutely make sure the sync is turned on and select the proper calendar (thanks for the calendar setting-did not know that one). But still no sync.
  12. thinker25

    thinker25 Member

    Good suggestions, all of them. What I've found - finally - is that I have to manually hit the sync button on my phone, on the gmail /google account. Magic. The phone syncs, the calendar is there, all is well with the world.

    However, it used to be automatic and I can't figure out why it stopped that. Grateful that I can do it - I don't have that many appointments so I just sync when I add one. Usually I add in Outlook, then sync outlook to google calendar, then sync the phone. It sounds like a lot of steps but it's pretty effortless.

    This is my first smartphone and I haven't really learned how to use many of its features... must do that. But the syncing problem was one that had worked and then stopped.

    Okay the phone is currently smarter than I am....

    Thanks for all the help - sounds like I'm not the only one! :D
  13. thinker25

    thinker25 Member

    Yes. It has been a while but...

    Getting started with Google Calendar Sync - Google Calendar Help

    This tells you how to sync google calendar with outlook calendar. If you google "sync outlook with android phone" you'll get a lot of hits. I sync the google/outlook calendars. There is an app that will get set up on your pc/laptop that syncs those automatically. You can adjust the time and which way you want to sync.

    Then you have some setup to do to sync the phone to google and that's really what this thread is about so look at the other posts. I started the thread and I still can't get the phone (lately) to automatically sync. But you can definitely manually sync the phone with your google calendar. I gave up and that's what I'm doing, just clicking on it periodically or when I add an event.

    There's a little icon in the systray on your PC that shows when it's syncing - and that's where you adjust the settings as to whether it's a 2-way sync or whatever, and the frequency. Again, this is getting your Outlook calendar to sync with your google calendar.

    And it's actually really easy. :)

    The manual sync is done on your phone, go to settings>accounts>other accounts [which is where my google email address is]. Click on the right account and there is a choice of what to sync.
  14. hintanog

    hintanog New Member

    My problem is all the settings are correct, Infact I have two phones, one syncs and the other doesn't.
    The one that doesn't shows the wrong date under the sync button!
    All of the other funtions, like sync email, contacts and stuff, show the right date, but the syn calendar shows 3/9/2012.
    What can I do?
  15. Kiep

    Kiep New Member

    Just like the rest in here, I found that my phone would not sync events I entered into the Android calendar.

    I noticed the different colors in the android calendar. After changing myusername@gmail.com to the default calendar this happened: Whenever I create a new event I can (at the top of the screen) choose if I want to make an entry in the google calendar OR the phone-memory. Choosing the google-entry solves all problems. (on my Motorola RAZR i appears blue or green, the latter being phone-calendar).

    Unlike others in this forum I have not found a way to change old entries that were done in the phone-memory. I simply deleted those.

    It seems that the phone calendar is intended to show the content of different calendars with different color labels. The phone-calendar is useless, but the viewer has a nice GUI, so I prefer this solution.

    An alternativ is to install the Google calendar viewer (an app), but it's http-based and spends time to open. Moreover I don't like the GUI, so I prefer viewing and entering inside the built-in calendar function.

    Thanks a lot for a very useful forum!

    Kiep
    klairkitty likes this.
  16. dan3

    dan3 New Member

    I am having a problem with a new Android tablet that my calendar will not load as an option to sync from my Google account. When I go into settings>accounts>sync the calendar does not even show in the sync options. Everything else connected with my Google account like browser/contacts/drive/gmail/photos is available but no calendar. When I go into the calendar app it asks me to set up by signing in with a new or existing Google account, but when I try to sign in with my gmail it says this account already exists on this device and will not allow it...
    I have tried deleting and adding the account, and have gone through the Google dashboard but have not found a solution.
    Any thoughts appreciated!
  17. thinker25

    thinker25 Member

    On mine when I go into settings>accounts I see several accounts (yahoo, facebook, google, etc.). When I click on google I have the option to sync google play books, sync contacts, sync gmail and sync calendar. It is working - right now it seems to have synced the contacts & calendar today - I was having to do some of this manually :(

    Do you see something else? I'm on an android phone, not a tablet.

    The sync calendar function seems to be done through the phone in accounts, not in google.

    Are we having fun yet??? LOL!
  18. thinker25

    thinker25 Member

    Have you tried syncing it manually from the phone? Settings>accounts>gmail account. Click on it and make sure it is set up to sync what you want. If you click it it will usually sync manually...
  19. ro234

    ro234 New Member

    I struggled to try to fix this with the help of this thread and others, so I thought I'd post the really simple solution I eventually found.

    I simply installed another calendar app (in my case "Business Calendar Free") and set it up with my Google account. Somehow that resolved the syncing problem with the native Android Calendar app as well, so I now use that again as I don't like Business Calendar Free as much. But I've left it on there to facilitate the syncing for the native app.

    Hope that helps!
  20. LazyPenguin

    LazyPenguin New Member

    worked for me
  21. xanrgirl

    xanrgirl New Member

    Hi all

    I"m new here and got here by googling for help with my Android Tablet. I could not get the calendar to sync with my MAIN gmail account. Everything else related to that account would sync except for the calendar. My phone syncs fine. For some reason the main gmail account wasn't "visible" or something. My tablet didn't give me the option of setting the default account. In the settings it would show all of the accounts....just when I went to sync all....calendar would not sync for the main account.

    I had added another gmail account for the entire family and somehow that calendar was visible and syncing. What I ended up doing was deleting that second "family" account from the tablet, restarted it and now my main gmail calendar is syncing fine. I have not yet attempted to re-add the second family account and probably won't do so. I have found a really nice app for the family: "Cozi" and they can all use their own email accounts.
  22. Raines

    Raines New Member

    Hi, I've been battling this for the past few days before I found out that this is a common problem amongst andriod users. It showed on my device that there's an error in syncing.. today, it stop syncing altogether and it says that my sync has been disabled though I did not disable it and every other sync with email and contacts are working.

    anyone experiencing this?
  23. iphonerepairs

    iphonerepairs Member

    Go to android setting and reset your setting and then upload the calender.
  24. meissen

    meissen Active Member

    I've been banging my head for a long time about this - I can't get older calendar entries that were entered into the Android calendar onto my Google calendar.
  25. jefboyardee

    jefboyardee Well-Known Member

    For some reason we’ll never understand, the Google PC calendar shows appointments going back over ten years – maybe forever. But when viewing the same calendar on the droid, it only shows as far back as five months , on mine at least.

    To me, not critical, but perturbing.
Loading...

Share This Page