Android Core App and battary discharge in 2hSupport

Last Updated:

  1. Mika3107

    Mika3107 New Member

    Hello, in the moring then my phone catched wi-fi at my work, somthing strange happened, it discharget in about 4 hours and by look in battary consuption android core apps took 80% of it as seen on screenshot i took shortly befor phone finaly died. but for some reason time showed here is incorrect, i took it off charge around 3-4 hours before i thook this picture.

    also it was overheating much and TWlauncher were always crushing, i reastarted phone few times, took battary out and put it back, but every then phone starts i cannot do anything on launcher screen, it compleatly frozen and after a minute or so phone asks me if i want to close twlauncher because it not responding, only if i hold big home button for a wile, recent applications window popup and from there i can use phone properly and it cools off doing so, but then it falls a sleep you can feel hot it heats up again... i tried also clearing chached and running application, but i used only original service build in SGS2, i dont have any special programms for monitoring my phone activities and services it runs, trust in samsung and goodle much :) thought that they optimize their products to the poing there you dont need any more additional programms to twink their products more.
    so any one had same problemm or know any solution for this? bring in it to workshop isn`t option for me now, since i`m stuck in the midle of nowhere for another week, and don`t even have cellphone coverage here, so i mainly use it as a photo/video camera and for music, and its gooing to be realy loong week without them :(

    and btw, i`m running ICS 4.0.1 i think, dont remember, but it latest avaliable for my phone, i checked for updates, and it told me that i`m running lates version

  2. ironass

    ironass Well-Known Member

    Hello and welcome to Android Forums Mika3107! :)

    I'm guessing you mean ICS, Android 4.0.3, firmware.

    It sounds as though you have a rogue app or setting that is causing problem and may well be as a result of your upgrade to ICS.

    The easiest and quickest way to solve your problems is with a Factory reset, as outlined, here.
  3. Mika3107

    Mika3107 New Member

    Thank you Iron, guess i have to give it a try later today. I dont think that upgrade causing this problemm, because i did it long time ago. Only change were made to the phone is that i installed 1 app yestarday, but this is started only this morning, although i added a new friend to my google+ account last night, that i didn`t do in a very long time, and this morning i tried to watch his profile with google+ app from my phone, and shortly after that i noteced that somthings wrong... anyways ) in a few hours it make factory reset and report here how it went :) And thank you for welcome ;)
  4. rocking23nf

    rocking23nf Member

    try uninstalling facebook, thats whats been draining my battery.
  5. Mika3107

    Mika3107 New Member

    My apologies for taking so much time to replay, but any ways, later that day i made factory reset and problem seems to go away, sucks thou that i couldn`t find the reason why it happened, factory reset seems like a bold action to take, but at least it`s effective :D and yes, facebook was one of the first apps to go, with Chrome Beta, Dolfin browser, that was working kinda weird and heating phone pretty bad, and some over minor but suspicious games and apps i installed , but none of that worked... And about a year ago, i had similar problem with battery, it was draining dry in about 2-3 hours, but by screen always active, even then it seems black and turned off... factory reset didn`t helped that time, i had to take it to the shop there i bought it and use warranty, after a week they returned it to me in working condition and told me that they had to replace usb dock (or how does it called? the hole in the bottom of the phone where you plug charger) but there i did dropped phone on a wooden floor connected to a charger.. so any ways.. thanks a lot for you help, and for those how is looking for a solution to a similar problem, factory reset - is a quick and easy solution... not saying that it best.. but it did worked for me
  6. ironass

    ironass Well-Known Member

    Hi Mika3107!

    Glad to learn that the Factory Rest solution worked. :)

    At least by doing the Factory Reset you know that you did not have a corrupted installation of ICS firmware to begin with. This can happen, usually with an OTA, (Over The Air), updates but also via the Samsung PC Suite, Kies.

    Now that you know that ICS is OK, it narrows it down to being an app or setting that is causing the problem. Unfortunately this means re-installing and setting up your app's individually, much the same as when you first received the phone, and monitoring which app/s or setting/s causes your problems again. To be honest, you may never find out... as the simple process of re-downloading and re-installing them could fix your problem.

    For anyone experiencing similar problems, see this thread...

    ICS problems... what you can do!

Share This Page