1. In regards to recently combined carrier specific root forums, if your device forum was affected, please see this poll/thread!

Android Development question--rookie to this


  1. Hello everyone. I just joined this forum tonight and have an issue. I'm trying to work on a project in Scringo and I'm having issues as to where to place the SDK file. A video tutorial was so out of date that I got confused and I can't run Eclipse because I get some error warning telling me that it failed to create the Java Virtual Machine, whatever that is. I've also asked questions on the Eclipse site too so any help either of these communities could give is most appreciated.

    Advertisement
  2. cDubU

    cDubU Member

  3. This is my new issue now--trying to import the lib into Eclipse. I found Android Studio but it wouldn't dl the exe so I'm not going to sweat it, I got Eclipse already. I'm trying to follow the steps here but to no avail:

    http://www.scringo.com/docs/android-guides/quickstart/

    any answers/solutions?
  4. cDubU

    cDubU Member

    It would be best if you told us any errors or unexpected behaviors that it is having. I guess the best thing to do is to start over. If you haven't actually had to much progress on your project, start up a new project and run it on the emulator. Check to see if everything runs without a problem. Once you KNOW that your app is running fine, then try to import the library. If something wrong happens than, be sure to copy paste any errors in the log. :)
  5. What I'm saying is how do I open the folder that this SDK is featured in? Everytime I tried to it wouldn't allow me, the lib folder wouldn't have a + next to it. I just moved the folder out of the C Drive and into a different folder on my desktop. All I want to know is how I can access the folder so I can upload the project. It doesn't show me that in the link I provided and the youtube links haven't been that helpful. When I go to SDK Manager to add a link it doesn't work. I guess I'm using the wrong links or something, one was from a youtube link and another was from somewhere else that didn't work. You know what I'm talking about right?

    When I go to Help/Install New Software and I have to add a site the ones I mentioned above have never worked. There are others in the list but I don't know what they are and I don't know what to do as far as adding the Scringo SDK--what do I do, use the link in the tool bar? The link I posted about how to dl and install the SDK doesn't give a link to use. I want to know how I can do that to open the Scringo SDK or even the Android one (the Scringo one is Android-compatible by the way). I can't access the SDK because of this step.
  6. Ok I think I know what the issue is and I want to know how to correct it:

    http://androidforums.com/application-development/2314-installing-eclipse-android-sdk-windows-xp.html

    When I get to the step where I make an Android folder and unzip it in the C drive, I get lost. After I do this (I assume INSIDE the C Drive not outside in a folder) I go to Environmental Variables and follow the steps of adding the path and after that nothing happens--the path gets lost. I also tried to follow this tut which is more updated but basically kinda the same:

    http://www.scringo.com/blog/how-to-install-the-android-sdk/

    but this one has the link, unlike the one for this site it has no images to go with it which leaves me very confused so I follow both. I want to know what I'm doing wrong, why is Eclipse not finding the path to the SDK let alone read the libs folder that the SDK is featured in?
  7. I'm getting very desperate, I'm willing to go as far as to ask if anybody has Skype on here or Team Viewer, I have NO IDEA what I'm going wrong let alone what's wrong. I'm afraid if I can't figure this out I'm going to abandon the project altogether, and I don't want to do that.
  8. Manaya

    Manaya Well-Known Member

    I don't really understand the problem, and I don't know what Scringo is, but the Android SDK Manager is just for Google Android related SDK's not custom ones... you install the others by following their instructions, usually it's a .jar or a project you have to import as a library.
  9. Scringo is this:

    http://www.scringo.com/

    They have plugins/SDKs for both Android and iOS.

    I saw a tutorial last night where someone opened Eclipse in the Android project folder, I haven't done that. Everytime I open Eclipse it's in the Eclipse folder, the version in the Android folder won't open, it keep saying "Failed to create the Java Virtual Machine". I'm assuming this is another big issue as to why it's not working. I want to know if I have to uninstall/install something again. It was a thought I had while working through these issues but I wasn't sure. Do you think this could be the problem I've been facing, that Eclipse won't open in the Android folder?

Share This Page