Android File Transfer for MacSupport


  1. red66charger

    red66charger Well-Known Member

    Apologies if this has been addressed previously, I did search for a solution first and had no luck.

    My main computer at home is a Mac Pro running OS X.6.8 (Snow Leopard). It seems I had no issues using Android File Transfer with my Razr Maxx, but with my Droid Maxx connected to my Mac all of the files on the entire device have the same creation date - 12/31/69. Makes it very difficult copy specific files to the Mac.

    Does anyone know if there is a fix for this issue? (other than dumping the Mac, that is ;))

    Advertisement
  2. Thom

    Thom Premium Guide Member Guide

    I'm using a Windows workstation.

    With the Droid Bionic in Mass Storage mode the creation date is displayed.

    Mass Storage mode is not available in the Droid Maxx.

    With the Droid Maxx in Media device (MTP) mode the only way to see the creation date is to right-click on it in the Windows display.

    ... Thom
    red66charger likes this.
  3. doogald

    doogald Guides Guide

    The same time stamp problem is happening on my Mac running Lion (10.7.5). Maybe this is a KitKat issue with the phone?

    I rarely connect my Mac to my phone (this is the first time since probably last October, and I really never paid attention to the timestamp of files before; that's why I wonder if it is a problem that started with KitKat.) There are many ways to connect the phone to the Mac other than by direct connection - Dropbox definitely support proper time stamps on files. (I use an app called Dropsync on the phone to set up two way and one way syncs from specific folders to my Dropbox account.)

    Dropsync also has a service that works with Google Drive called Autosync for Google Drive.

    Another method is to use the app AirDroid to connect to your computer using WiFi rather than USB.

    Dropsync: https://play.google.com/store/apps/details?id=com.ttxapps.dropsync
    Autosync for Google Drive: https://play.google.com/store/apps/details?id=com.ttxapps.drivesync
    AirDroid: https://play.google.com/store/apps/details?id=com.sand.airdroid

    AirDroid may be your best bet, actually. That's what I would use, anyway. That Android File Transfer app is a kludge anyway. The old pre-ICS direct access method, where storage just mounted to the Mac as a removable device, was much much better.
    red66charger likes this.
  4. red66charger

    red66charger Well-Known Member

    Thanks to both of you. Yes, Android File Transfer was simple "old school" drag and drop with my RAZR Maxx.

    Bummer. This may be my first complaint about Droid Maxx. It took a while...I love this phone.
  5. doogald

    doogald Guides Guide

    I just tried BT connection from the Macbook to the phone. While that's another way to transfer files, you still get no visibility of file or folder timestamps. At least they're not set to zero time (that's the 12/31/69 date... Unix zero time is midnight Jan 1, 1970, at UMT, so they show 12/31/69 8:00:00 pm local time for me.)
  6. red66charger

    red66charger Well-Known Member

    My storage was almost full so I wanted to copy vids and pics to the video and photo library on my primary home computer. Very frustrating without proper meta data. I'll probably back up to Google Drive and then transfer.

Share This Page