Android File Transfer on Mac Showing "Empty Folders" on Phone??Support

Last Updated:

  1. scudder

    scudder Well-Known Member

    Hello has everyone been?? :D

    Having a problem with my wife's EVO LTE...trying to transfer her pictures to MacBook for backup via USB.

    I am familiar with the Android File Transfer app for my MacBook permitting the mounting and file transfer due to the MTP protocol:

    Android File Transfer Info

    After installing Android File Transfer, I WAS preivously able to download the picture files but, for some reason recently, I am NOT able to do so any more...?? :(

    As before, I hook up the phone via USB, choose "Media Sync" and Android File Transfer launches on my computer and then shows the internal storage in a window. However, as you can see in the picture below, I expanded the arrow next to the DCIM folder where the 100MEDIA folder and images should reside and nothing expands


    ..and if I open the folder itself, it is TOTALLY empty:


    NO image files...not even the 100MEDIA folder shows up in my computer's Finder!!

    And when i go back to the folder and use a file explorer app, I see ALL the image files just fine at DCIM>100MEDIA.

    So, why did this work for a bit and then stop?? How come I cannot see my 100MEDIA folder or my images in my Finder even though the phone mounts with Android File Transfer app?? :confused::confused:

    Thanks!!! :)

    EarlyMon likes this.
  2. EarlyMon

    EarlyMon The PearlyMon Moderator

    Hiya scudder, how have you been? :)

    I'm running the same rig, let's compare.

    Which version of OS X? Take any recent updates?

    And, is there a chance you set your camera to store on the external sd card instead of the default internal?

    PS - while the setup you have has generally worked for me, I've mostly preferred Airdroid and DavDrive via wifi to insulate the two from version changes.
    scudder likes this.
  3. scudder

    scudder Well-Known Member

    Originally Posted by Scudder:

    Hiya EarlyMon...nice to hear from you! Long time, no see (my fault)!

    Well, got home and checked the phone and computer. I'm running OS 10.7.5 if that is important...

    And I checked the location of the picture storage. Well, it cannot be the SD card because we have NO SD CARD in the phone!! I then checked the camera settings and storage is greyed out as "Storage - Phone Storage"

    Sooooooo, thoughts....?? :confused:
  4. EarlyMon

    EarlyMon The PearlyMon Moderator

    Don't know how I missed this!

    A portion of internal storage (9.93 GB) is mounted as /sdcard and that satisfies expectations of apps looking for that as an Android standard. When I refer to the sdcard, I'm referring to that.

    If you install an optional, physical sd card that gets mounted as /sdcard2, aka, /sdcard/ext_sd.

    If you install EStrongs File Explorer, and set the initial path to just / in its settings what does it show?
    scudder likes this.
  5. scudder

    scudder Well-Known Member


    Now I AM sorry for the, work...and the fact that I needed to get a hold of my wife's phone to try the above.

    So, I set the path to / and there are various folders. Not able to do a screenshot but the folders from top of the screen to bottom are as follows:


    Below that are a bunch of files/non-folders. Does this show you anything??

    BTW, I can access the 500+ picture files that I am trying to access via US through EITHER of the following paths:




    I would be transfer via bluetooth or other wireless means, however, I have a couple/few HUNDRED files I want to get from the phone. That and the fact that the USB connection SHOULD WORK is frustrating...

    Any of this make any sense?? :(


    Adding the following information:

    So I noticed and tried a couple things after I posted the above...

    When the Android File Transfer opens in my computer Finder window, I can see the DCIM folder. When I open that folder in my Finder window the 100MEDIA folder DOES NOT APPEAR. I checked permissions of both the DCIM folder and the 100MEDIA folder (located at DCIM/100MEDIA on the phone) and the permissions are the same set as "drw"

    I then decided to try the Android File Transfer Finder window, I created a new folder entitled "DCIMCOPIES/" I then disconnected the phone, went to ES File Explorer on the phone and COPIED ALL of the files in DCIM/100MEDIA to the new DCIMCOPIES/ folder. Well, that new folder, AND THE COPIED FILES, appeared in the Finder when Android File Transfer opened!! I was then able to copy (quickly...and MUCH quicker than I would have via bluetooth/wifi) ALL the files I needed to my computer.

    So, I have a work-around, however, what's wrong and is there a way to fix this?

  6. EarlyMon

    EarlyMon The PearlyMon Moderator

    Ok. :)

    /sdcard is a shortcut to /mnt/sdcard - exact same thing.

    How about trying AirDroid?

    It'll take a bit longer, but you can select all those pictures and xfer them via wifi in one handy zip file?

    Apple probably broke something on a recent update to hose AFT.
    scudder likes this.
  7. scudder

    scudder Well-Known Member

    Ha! I was juuuuust going to PM you that I finally replied! :D

    Actually DID YOU SEE MY UPDATE TO MY POST ABOVE?? You might have replied as I was editing/updating. Please check my edit/update and my copy/new folder thing that worked if you haven't...

    Yeah, I am familiar with AirDroid or Bluetooth or other wifi transfer...does work...and going forward I won't have the couple HUNDRED of files I just had to transfer with the copies-now-appearing option. But still hoping to figure out and fix...any thoughts???
  8. EarlyMon

    EarlyMon The PearlyMon Moderator

    Not really. :(

    Prior to the latest OS X release, AFT was working 100%. :(
  9. ScandaLeX

    ScandaLeX Wasn't Me

    While on Gingerbread never had to use it since my Mac could see my card. The minute I jumped on ICS I could never get AFT to work. It was such a frustrating affair that it was easier to pop the card out, insert it in a reader and go on from there.

    It was then I discovered Airdroid and couldn't be happier.
  10. EarlyMon

    EarlyMon The PearlyMon Moderator

    I have no issues with ics on my LTEvo and Snow Leopard.

    The benefit of AFT when it works is that you can get to the internal and external sd cards.

    If all you care about is your external sd card then just choose disk drive when you plug in your phone to get traditional usb mass storage, with any version of OS X.

Share This Page