Android Market error after CM7 Mod


  1. CM7 Mod appeared to go well until I try to download something from the market. During the download I get " the application market (process com.android.vending) has stopped unexpectedly. Please try again. And wants me to forceclose. Any fix?

    Thanks,
    Pete

    Advertisement
    :
  2. colchiro

    colchiro Well-Known Member

    What upgrade was that (from? to?)?

    Did you also install the latest Google apps? (I'm guessing not)

    If it's been awhile since you updated, you should also flash gApps.
  3. I think I had Froyo. I did the two zip files it told me to down load. Can you tell me what/how to get these gapps etc??? Ill even let you dial in if necessary to help me out.
  4. colchiro

    colchiro Well-Known Member

    Froyo? Is market the only issue you have?

    Since it sounds like only Market is a problem (instead of everything FC'ing), maybe all you need is to flash this from recovery: http://goo-inside.me/gapps/gapps-gb-20110828-signed.zip

    So I'd try flashing Google apps and if that doesn't work, then reflash CM7 followed by gapps.
  5. DSP Manager is force closing all the time, anything I can do to get that to stop. I notice it wont run angry birds, but will do other apps.

    Thanks,
    Pete



  6. colchiro

    colchiro Well-Known Member

    Did you flash gApps? Did it help?


    Any time you have FC's, you want to fix permissions (and clear caches). I prefer to do this from recovery because I've had it hang from Rom Manager, but you can also try it from Rom Manager first (then reboot).


    How many apps FC on you? Which ones?

    If it's one or two, you could try to find it in Settings... applications... manage apps and choose "clear data". For Market, you could instead "uninstall updates".


    Might also be a good idea to boot into recovery from Rom Manger:


    • Use Volume buttons to select and "n" button to do the highlighted item. Power button is used to go back.
    • Choose mounts menu and "format cache". Go back
    • Under advanced menu, choose "wipe Dalvik cache". This is also where you'll find "fix permissions" should you decide to do it here instead.
    • Return to the main menu (go back) and choose "reboot system now".


    Since we wiped caches, your next reboot will take a couple minutes.

    Does that fix or improve your problem?
    kilva and pjs911dispatch like this.
  7. Im getting a Toshiba Thrive maybe you can help me modify to use AD HOC

    Thanks for your help.
  8. kilva

    kilva New Member

    Thanks, this solved the issue on my LG Optimus Black (P970) running Cyanogenmod 7 (CM7). I ran it from Rom Manager and rebooted. It was so easy. Thanks again.
  9. colchiro

    colchiro Well-Known Member

    Glad it worked for you.
Loading...

Share This Page