1. Download the #1 Android News App:   EarlyBird - News for Android
    Dismiss Notice

Android Market no longer updating apps

Last Updated:

  1. DAE51D

    DAE51D Well-Known Member

    For the past week I've noticed that I can't "update" any of my installed apps. When I try, it will download and then just hangs on "installing". Then from there I'm screwed. Trying to update or download again won't do jack shit. It throws up a toast that says, "your updates will start shortly". But nothing happens. Normally then the screen changes to a download bar and shows progress and my CPU maxes out indicating it's working. Now it doesn't do anything. :mad:

    I have a rooted Evo but it's running stock Sence UI and all that stuff. I have Market 2.3.6 according to the Application Manager screen. I've tried to "Force Stop" with no luck. This screen always just says "Computing..." for the storage and cache. I've also pressed "Clear data" and "Clear Cache" and I don't know if they're ever even working since the "Computing" is always there. Still no luck. :confused:

    The ONLY time I can sorta get things to work is if I reboot the phone, then go to market, then manually update a single app. Sometimes it completes, sometimes it doesn't. And usually that one install will hose things up for subsequent updates and I have to keep repeating this process. "Update All" is the kiss of death for sure each time. More often than not, the update fails in either case.

    I've tried with WiFi on, off (just 3G) and even in the very few places 4G on Sprint is available in all of Seattle, I attempt it then too. Nothing.

    I've tried AppBrain, but all that app does anymore is take you to the android market. Lame. It used to install directly.

    It's even more infuriating as there is no error messages or log or anything to even look at (is there?). I should have about 40MB left internal storage and like 3GB on the SD, so I doubt space is an issue.

    I haven't done anything to my phone that I'm aware of. I just use it. I don't mod it or hack it or anything, and it's been rooted for quite a while, so that shouldn't be it.

    Android 2.2
    Build Number 3.70.651.1 CL294884-release-keys
    PRI Version 1.90_003
    PRL Version 01115

    I saw this other thread, but I don't think they're the same issue:

  2. frenchy714

    frenchy714 Well-Known Member

    Moved thread to "All things root" section.
  3. frenchy714

    frenchy714 Well-Known Member

    Have you tried doing a factory reset?
  4. Drew5150

    Drew5150 Well-Known Member

    lets try this...

    go menu - settings - applications - manage applications - running tab

    find "google services framework" select it - clear data and force stop .. THIS WILL NOT ERASE ANY OF YOUR PERSONAL DATA OR SETTINGS.. sorry for caps but people always ask about that.

    then go to the all tab and find market and select it. then clear cache, data and force stop.

    at this point I recommend rebooting your phone, but you can try without. now open the market and accept the terms agian.

    does it work now?
  5. DAE51D

    DAE51D Well-Known Member

    "Computing..." never stopped after 15 minutes, so I just pressed "clear data", "clear cache" and "force stop" . I did this for "google services framework", "market updater" and "market" (all three)
    I rebooted and MANY of my apps are GONE! :eek: They don't show in the "up arrow" on the far left side. And the folders I have painstakingly created are full of green/white android icons!!

    When I go to the market, the only thing that shows available to update now is "adobe flash player", there used to be like 5-10 updates (that I could never get to work). clicking on it and trying to update does what it always did.

    I did a search for "WhatsApp" (something I recently installed last week, and noticed it is missing, and the market shows it as "Free" and wants me to "Install" it! I click it and it won't install (same issue as the update).

    It appears it's all the apps that were on the SDCard (which is most of them) are "gone". Yet if I go to "gallery" app (internal to Evo) then I see my photos. If I 'adb shell', then I can see all the directories:

    Code (Text):
    2. # cd /mnt/sdcard
    3. # ls WhatsApp
    4. Media
    5. Databases
    This blows. Did I just hose up my phone?! More importantly, what about all my data/settings for the apps I had there that now don't show up? I was able to download Titanium Backup but it doesn't seem to want to install?!

    Code (Text):
    2. c:\Temp\Android>adb install -r TitaniumBackup_latest.apk
    3. 343 KB/s (2060046 bytes in 5.858s)
    4.         pkg: /data/local/tmp/TitaniumBackup_latest.apk
    It never says "success". :(
  6. Drew5150

    Drew5150 Well-Known Member

    well clearing "google services framework" does not clear out any of your apps. what it did was clear out the cached memory for the apps that are on your sd card, so the icon links need to be recreated.

    what type of apps 2 sd method are you using?

    1: android native - through manage applications

    2: market apps2sd

    3: dark tremor aps2sd that is in cluded on many roms, with a sd ext partition

    I'm taking a guess that you are using the market version? if so I have read of people having similar issues, I don't think they were resolved they just stopped using this app.

    did you have titanium backup installed before, were these apps already backed up in titanium?

    also are you on a gingerbread or froyo rom?
  7. DAE51D

    DAE51D Well-Known Member

    I use a hybrid of Apps2SD and the native Application Manager. I didn't realize there was a difference actually. I thought that Apps2SD just did the same thing, in fact, usually all it did was show the blue icon and say, "blah blah app can be moved to SD" and then it sends you to the App Manager screen where you click "move to sd" button.

    I had Titanium installed but my backup is probably from at least a month ago.

    I'm on Froyo (stock Evo 4G)

    (ps. thanks for your help so far Drew5150)
  8. Drew5150

    Drew5150 Well-Known Member

    hmm, ok so I have never used the market apps2sd before so I can't give too much guidence.

    is there a way you can get titanium to install on the phone itself, or is it already?

    I've read of issues with the market app, but really I have no idea what to do about it... sorry.

    I have also read that combining app2sd methods can cause issues. I'm not sure if that means the android native and market versions, or the dark tremor version and one of the other 2.

    I hate to say it but you might be hosed. can you move these apps back to the phone? or are these not seen at all anymore in manage applications?
  9. DAE51D

    DAE51D Well-Known Member

    I think I'm hosed too.

    I've tried removing the SDCard, power cycling, clearing the /data/dalvik-cache and /cache/*.apk and various other things I could think of and nothing is putting the links back

    When I go to "Market > My Apps", I see them all listed, but they all say "FREE" next to them like they aren't installed. Clicking on one requests for me to install it, but of course the install doesn't complete :confused:

    What a crappy architecture that this could happen! UGH! :mad:

    Well time for a factory flash I guess. I can't think of anything else to do. Is it worth using Cyanogen or another new ROM instead of the HTC EVO one?
  10. DAE51D

    DAE51D Well-Known Member

    I don't think this issue has anything to do with 'root'. It's got to do with the Market just stopped working... :confused:
  11. DAE51D

    DAE51D Well-Known Member

    Looks like I have a long night ahead of me... A word of advice to others, if you go the Android Market, you can see a list of all your apps (even if they're saying they're not installed on your phone -- how that works I don't understand, but I'm at least glad for this "bug"). I have printed them all out (several pages) so that I can at least go back and painstakingly re-install them all, again. *sigh* :(
  12. DAE51D

    DAE51D Well-Known Member

    I started at 8pm, taking notes of what I needed to backup and salvage if I could, I planned to .tgz the whole internal / and /mnt/sdcard. I was going to format the card and do a factory reinstall. I was really sad that I had not done a backup before attempting this repair above.

    My Lord must have shown me some mercy, because out of nowhere, after taking the SD Card out and battery out and back in and out and in and ....

    I was able to 'adb install -r TitaniumBackup.apk' into the phone with the SDCard removed. :) That made me very happy as at least I could backup my contacts and calendar and internal stuff (in theory). But when I tried, it said I needed the SDcard in to backup the stuff to. So I put it in, and when the system came up, I ran T.B. again. Much to my elation ALL (I think "all", looks like "all", no broken icons that I see) my applications are back!!! :happy dance: :D

    AND what's stranger is that I noticed the downloading arrow in the notification bar. It was actually downloading and updating some things from the market! WTF!? :confused:

    Knowing not to take a gift like this for granted, I aborted the downloads, and immediately have started a FULL system & data backup with T.B. of 305 apps. ;)

    I also (learned something new) did an Export of my contacts to the .vcf file because I noticed something really sucky -- "HTC Sync" only seems to acknowledge the 'home' and 'mobile' phones (or something like that). I have contacts -- my g.f. in particular -- that has three phone numbers listed in my Evo, but yet after the sync [phone over-writes Outlook] she only had two showing. Checking in the phone and sure enough there's a third, but no corresponding field in Outlook. Don't get me started on a rant on how idiotic it is that I can't hotsync my Android STILL to Outlook like my 12 year old Palm Pilot could do without a hiccup. :mad:

    Anyways, something is CLEARLY still borked, but at least I am back where I started (and my phone is USEABLE) even if I can't update apps yet. I will get these backups done and then this weekend looks like I'll be doing some flash-to-factory and re-format the SD card in case there's a bad sector or something?

    A shout out to Jesus (and the apostles of tech) and whomever else took pity upon me and gave me back my data that I've worked so long and hard to acquire.

    Certainly will be setting up T.B.'s automatic backup scheduling and assuming the restore goes smoothly after the flash, I can see a purchase in the market for it in the near future. :p
  13. RUNIT331

    RUNIT331 New Member

    I deleted data and cache in google gmail and market and soft reset, and it then asked me to login with a choice of TWO accounts! One was my Gmail and the other was the foolie that I could not access. The new market opened immediately, and I was able (finally) to update Kaspersky with the offered prompts. USERS still shows me the spurious (ugh!) login, but I have wisely demurred from testing fate. I wish I knew how to delete POPPA3@login.tst/
  14. Granite1

    Granite1 Zercron Encrusted Tweezer Moderator

    Welcome to the forums!!! :)
    Are you rooted?

    If you're rooted, I would wipe the phone and reflash your rom. Sounds like you got a bug. :(

    If not I would make sure all of your contacts are saved to your sd or the cloud, back up your sms messages, if you can, and do a factory reset.

    That sounds like bad juju right there.:(
    ocnbrze likes this.
  15. Team420

    Team420 Well-Known Member

    I would wipe, and try out a new rom... maybe even some gingerbread... froyo is a lil outdated...

Share This Page