Android Market Package File Is InvalidSupport


  1. bjones371

    bjones371 Member

    Hi All,

    I've come across a very strange problem with my Galaxy S II. When I try to download any app from the Market over WiFi it downloads and installs no problem. When I try to download it over the 3G network (Virgin Mobile) I always get the error "Package File Is Invalid" regardless of whether it's an update to an existing application, or a new application being downloaded, and it does this with every application I try and get hold of.

    I've tried clearing the Market application's cache and data but no joy.

    Any ideas would be great.

    Cheers,

    B

    Advertisement
    :
  2. Hawker

    Hawker Well-Known Member

    I had a similar problem a while back, but with market in general (not just if installed via 3g)
    I cleared cache+data, and also selected uninstall updates, which reverted it back to version 2.x temporarily.
    This fixed it for me.
  3. bjones371

    bjones371 Member

    Thanks for the quick reply - I forgot to mention I tried this as well, but before an app could download the Market closes and when I open it up again it's updated itself back to the new version. How do I stop it from doing that so I can try this out? Or better still, is there a way to fix v3 :)

    Thanks,

    B
  4. ianio

    ianio New Member

    im not on a galaxy s2 but a nexus s. i am also having this issue.

    looked into it and most people are suggesting to flush the cache and dalvic cache files. unfortunately i do not want to root my phone to achieve this.

    a factory reset did ease the issue but after a week and a replenished app install, the issue is back to as it was.

    All 3g installs (via t-mobile uk) cause invalid file error. all wi fi installs run fine.

    Is this a corruption in 3g signal. surely the phone is checking for down load errors etc.
  5. bjones371

    bjones371 Member

    Interestingly I had a Vodafone SIM in there today and downloaded an app over 3G no issue. Soon as the Virgin SIM went back in (which uses T-Mobile network by the way) back to the same problem.

    So is the issue common across users of the T-Mobile network?
  6. Gearu

    Gearu Well-Known Member

    Well I have trouble downloading any app over 10MB on Three (download failed), but using my Voda sim it's fine, probably due to the big difference in download speeds.
    The higher over 10MB it is, the more likely it is to fail when it finishes (and the longer I wait to find out).
  7. bjones371

    bjones371 Member

    I've sent Virgin a question regarding this - although I believe their CS leaves a lot to be desired!
  8. bjones371

    bjones371 Member

    So Virgin called me today saying they'd received my email, and the woman that called said she would be speaking with somebody in their tech support team and would call me back very soon. I remained sceptical...... Until 10 minutes later when she rang again and said that the tech support chaps had put it down to a device fault rather than a network issue, which I didn't really believe.

    She then offered to dial through to Samsung for me and connect me to them through the same call (meaning I didn't pay the charge for ringing an 0845 number from a mobile) which I accepted. Samsung told me to do the following:

    Go to Settings > Applications > Samsung Apps
    Select "Packet Data"

    And I've just downloaded a 20MB app and installed it over 3G with no issues! It's unusual that it worked on Vodafone though, but nonetheless some pretty impressive support from both Virgin Mobile and Samsung there!
  9. bjones371

    bjones371 Member

    So that didn't fix it after all - or if it did only temporarily. I submitted a support request to Android Market Support/Google and they said looking at the device history the errors are occurring due to connectivity issues. Back on the phone to Virgin tomorrow.

    The Support from Google mentioned that my carrier was T-Mobile by the way, so I presume this will be affecting all T-Mobile users...?
  10. scottg07

    scottg07 New Member

    I am having the exact same problems...i have 3 different phones Galaxy S2, HTC Desire HD and HTC legend...all on T-mobile. none will download and install apps when using T-mobile (package file invalid).

    Ive tried all the fixes - even factory reset - still the issue remains.

    I contacted T-mobile support - utterly useless - they just read from scripts and then tell me they don't support android market...hmmmm:mad:

    I contact android market support, played email tennis..then they just stopped replying....hmmmm.:mad:

    Anyone have any ideas??? thanks in advance if you do.

    I have just switched to GSM only 2.33mb download took an eternity but has successfully installed...so is it corruption im getting using HSPDA???
  11. bjones371

    bjones371 Member

    Spoke to Virgin again today they basically said if I can get on the web on my device then it isn't their problem, and I should speak to Samsung instead as it's a device issue, and tell them that it wasn't fixed by the last thing they suggested...

    Not sure what's causing this but I don't think for a second it's a device problem, I reckon it's related to T-Mobile in some way, esp as it's affecting HTC devices on T-M as well....
  12. KungFu Ramone

    KungFu Ramone Member

    Same problem here with my Nexus S on Virgin Mobile! It started off intermittently about a month or so back, but now it's affecting every download from the market over 3G. I've also had issues downloading .APK files outside of the market with them failing to install, but then it's been OK downloading other files. Definitely sounds like a problem with the T-Mobile network. Glad I've found some other people affected by this and that it's not just down to my handset, maybe with a bit of research we can get this nailed!
  13. gbolton2008

    gbolton2008 New Member

    I have exactly the same problem. The issue extends to ZIP files as well (apks are zip files, I believe)

    I'm on a Moto Atrix running CM7 - The issue has been present over various ROMs and Radios, and is exactly the same on my Moto Defy too. - On T-Mobile.

    Will be very interested to see how this pans out.

    Edit to add: Probably worth noting that now that I can use the Orange 3G signal here in Manchester, I can download at a reasonable speed (i.e. not GPRS) without data corruption. DEFINITELY a network issue.
  14. bjones371

    bjones371 Member

    Proven even further this afternoon when I went to look at a problem on a friend's laptop that needed a plug-in downloading to fix. They only have a T-Mobile dongle, no fixed broadband web. I couldn't even download a 13MB plug-in from the web through it, when it tried to unpack the files it failed saying the download was either incomplete or corrupted.

    Unfortunately I can't speak to T-Mobile as I'm not a direct customer and they'll just tell me to contact Virgin, but it's definitely an issue on their end.
  15. dozydave

    dozydave New Member

    I have had this problem with all app updates for my T mobile HTC wildfire, if i connect via my home wi fi network all apps update no problem,and no "package file invalid".This has to be a T mobile network problem.
  16. bjones371

    bjones371 Member

    Well I've put the same in the T-Mobile UK forums to try and get an answer. Another post in there (see here) suggests there is a network wide problem - but how true this is I don't know.

    Just out of interest and to rule out a mast fault rather than network - are most of the complainants from the same area? I'll go first:

    Manchester.
  17. twistzilla

    twistzilla New Member

    I'm having the same problem only on 3g on a T-Mobile G2. Also in Manchester
  18. steslatt

    steslatt Well-Known Member

    A work Colleague has the same problem on his HTC wildfire T-Mobile.

    Manchester.
  19. KungFu Ramone

    KungFu Ramone Member

    Yup, Manchester! I'm starting to see a trend here :)
  20. bjones371

    bjones371 Member

    So probably a problem with the masts then it looks like :)

    I might get back on to Virgin - problem being that it'll be a bit of a to-and-fro because Virgin will have to speak to T-Mobile who will speak back to Virgin who will pass information back on to me etcetc...!
  21. KungFu Ramone

    KungFu Ramone Member

    I've just tried updating a couple of apps and it worked! Has anyone else tested it recently?
  22. bjones371

    bjones371 Member

    Working for me just now as well - tried it last night though and was having the same issue so it's a very recent fix...

    Somebody must have turned something off and back on again somewhere :)
  23. KungFu Ramone

    KungFu Ramone Member

    Still working. Looks like it might be sorted.
  24. ecko1873

    ecko1873 New Member

    hi all

    I am a complete novice with a problem

    I have a MID tablet and when I download games from the app market I get the following message:

    install failed: invalid APK file

    help please, thank you
  25. Andima

    Andima Well-Known Member

Loading...

Share This Page