Android market problem, application hold on starting downloadSupport


  1. martani

    martani New Member

    Hi,
    I got my HTC Magic yesterday and I can surf internet using wifi normally, gmail , browser, google maps all work perfectly.

    but when I go to the android market, I can see and select application and when hit install, it freez on the starting dowload message and never start!

    I saw in other forums that starting google talk will help, but my problem is that Google Talk also can't sign in at all :mad:

    please help!

    Advertisement
  2. cdmackay

    cdmackay Well-Known Member

    Did you check your router's firewall log?

    I think then when on a cell network, Market downloads are done via TCP to a server port 5228, so that needs to be open for it to start. But I thought that when on wifi it used a "regular" port?
  3. martani

    martani New Member

    thank you for reaply,
    actually it never connect to my secured network or any other secured network, I'm using public wifi so I can't do a check for the TCP port!

    I hope I'll find a way to connect to secured networks otherwise I'll make my router's wifi unsecured :(, no choice
  4. cdmackay

    cdmackay Well-Known Member

    I had problems with my home router (WRT54G) until I reflashed it to run the Tomato firmware, and now my Hero connects fine; it would barely connect at all, before.
  5. timbo

    timbo New Member

    Martani,

    I have exact the same problem. Please let me know if you find a sollution.

    With kind regards,

    Tim Ruijters
    tim.ruijters@gmail.com
  6. martani

    martani New Member

    yes now it's working for me,
    I found that it never downloads when I'm connected to public wifis, so when I connect to protected networks with password there are two cases :

    1. it starts downloading immediately
    2. it doesn't : in that case you choose the application you want to download, hit start download, then disable and enable wifi again and it will start immediately.

    some other start Google Talk and that worked for them
    I hope this will work for you!
  7. skyhawk10x

    skyhawk10x New Member

    I've experienced similar problems on my HTC Desire.

    The problem:
    - Downloads in Market hang on "Starting download"
    - Google talk crashes immediately after opening it

    The problems gets fixed if you clear data and cache from Talk, Market and Mail (also clear Agenda to be sure). You'll need to re-add your mail accounts etc. A sync icon will appear above and Market and Talk will also resume working.

    Though... this proved to be a temporary fix. One day later the same problem occured. I also noticed that the synchronization of my accounts stopped working. Triggering it manually didn't resolve te problem.

    I noticed Android gave me a warning that my internal phone memory space was running low. I removed a few applications until the warning went away and voila ... sync, talk and market suddenly resumed working again !
  8. panamathor

    panamathor Member

    well, this didn't work for me on my new Galaxy S. I've opened the ports on my Wifi router as indicated on other forums and still nothing.

    Amazing Google doesn't step in with a clear and consise explication and fix.
  9. edie209

    edie209 Member

    I want to add my experience to this.

    I can connect no problem via the mobile network, however when I connect via wifi I am having problems. I can browse the web with no issues. Youtube gives me a server connect error as does trying to connect to Android Market.

    My wifi is a Linksys WRT54G running DD-WRT firmware, my firewall is clearOS.

    I think that certain ports need opening however I am unable to find a difinative answer to this, can anyone enlighten me.
  10. Green1

    Green1 Active Member

    well... I'm stuck in the same place... after searching a lot I have discovered 2 things
    1) it's a common problem affecting thousands of people, and has been for 2 years
    2) google doesn't care

    The fixes I have found listed are:
    - sign in to google talk (I can't it just force-closes the app)
    - clear the cache on various applications (doesn't help)
    - roll-back the update to the market app (doesn't help)
    - switch to "2g only" mode (there is no 2g coverage for TELUS phones in Canada)
    - switch to wifi (doesn't help)
    - toggle airplane mode (doesn't help)
    - reboot phone (doesn't help)
    - change google account password (doesn't help)
    - switch to googlemail instead of gmail (google doesn't give me the option)
    - factory reset phone (every single person who has reported trying this has been left with a wiped phone and the problem still there, so I won't risk my apps for this)

    Anyone have a solution NOT on the list?
  11. Baz8755

    Baz8755 Well-Known Member

    I'm having the same problem with my wife's Magic.

    Market used to work fine on both the Magic and Desire and about a month ago the Desire started having intermittant problems downloading.

    A couple of weeks ago I tried to use the market on the Magic and nothing downloads, have been trying nearly every day. Have tried all the usual tricks of clearing data/cache/force stop.

    My Desire seems to be working OK most of the time now.

    Both phones are connected to exactly the same Wi-Fi network.

    I suspect the Marketplace is having issues but they are affecting Magic more than Desire (probably because it's and older product).

    Baz
  12. Green1

    Green1 Active Member

    well... as a last ditch effort I did a factory reset on the phone... that left the phone completely unbootable.

    I then restored a nandroid backup from 2 days after I got the phone (apparently I should do backups more often!)

    After restoring the backup the phone is completely working again.

    So I don't know what originally caused the issue for me, but whatever it was must have been on my phone.

    It seems that there are many different causes for this same problem, possibly as many as there are people reporting the issue. Unfortunately what works for 1 person rarely seems to work for the next, but I hope that someone finds the info useful.
  13. leddra2k

    leddra2k Member

    Right peeps, I dont know if this helps any of you but I plugged my phone into the PC and selected disk drive and installed the HTC sync app from the SD card. I let that update then suddenly all 4 downloads I had in the market app started downloading!!! Dont know if this helps :) Ant
  14. ianarus

    ianarus New Member

    Had the same problem with my wifi WRT54GL --Firmware: DD-WRT v23 SP2 (09/15/06) vpn-- router @home.
    Application download from market could take up to 5 mins to start download.

    But with the wifi @work it downloaded instantly (Cisco Router)

    I corrected the problem @home with forwarding 5228 (udp&tcp port) to my htc desire ip
    i guess it could work also with upnp but i prefer knowing whats going on with my ports ;-)
    i supose that my works wifi router is using upnp thus i didn have any problem there...

    Now market works like a charm it downloads instantly like i used to at work or over 3G coverage

    Hope it helps
  15. Stigsmann

    Stigsmann New Member

    I have reset my phone to factory standtard, and when Im trying to open the Android market, at first it loads on the page it is suppose to be, but then suddently it jumpes to an internet reader and the identicall page appears on some google page. The problem there, is that I can't accept the conditions! And when Im trying to press "back" button i come to my HOME screen..

    Ive tried to uinstall the updates and so on nothing works.. now, im stuck!:confused:
    Can anyone help me please!
  16. epuser99

    epuser99 New Member

    Hi All,

    I just received my phone a day ago and was having the same problem; it just sat at "Starting Download" when I tried to pull down apps. I noticed I had no issue when connected to 3G or 4G network, so I figured the issue was related to my wireless network. Once I made the change in my firewall to allow traffic on certain ports it totally fixed the issue.

    Here is what worked for me:

    Set your firewall to allow UDP and TCP traffic for port 5228 (this is the port the android market uses). Make sure you allow in and outbound traffic. If you also notice you are having problems with Google Talk after allowing port 5228, you might want to play around with allowing port 443 and 5222, which are the google talk ports, but I really don't think you should have to do that.

    Hope this helps, good luck!
  17. Nodnerb

    Nodnerb Member

    I have this exact same problem on my brand new captivate. I still have yet to find the solution but I do know what the problem is. Sadly, my phone is brand new, so I have NO apps at all and can't get any.

    As soon as android market updates itself, I get the "download unseccesful" error for everything I try. If I uninstall the android market update, it goes to "starting download" but sits indefinitely.

    I've done many many factory resets and it is definitely a problem with the new market update. I can get in a d/l or two on the old interface, as soon as the market updates, it's toast.

    I've tried all the same things(and then some) as an above poster so I will just copy his list...

    The fixes I have tried:
    - sign in to google talk (I can't it just force-closes the app)
    - clear the cache on various applications (doesn't help)
    - roll-back the update to the market app (doesn't help)
    - switch to "2g only" mode (there is no 2g coverage for TELUS phones in Canada)
    - switch to wifi (doesn't help)
    - toggle airplane mode (doesn't help)
    - reboot phone (doesn't help)
    - change google account password (doesn't help)
    - switch to googlemail instead of gmail (google doesn't give me the option)
    - factory reset phone (every single person who has reported trying this has been left with a wiped phone and the problem still there, so I won't risk my apps for this)
    -created a new google account


    Does anyone know if google is working on a fix or if there is some way to stop the market from updating?

    My brand new phone is useless!!!!!
  18. Green1

    Green1 Active Member

    if it's brand new, and a factory reset doesn't fix it, I'd check 2 things, the first is your google account, try changing the password, or even creating a different google account.

    If that still doesn't work, I'd take it back to where you got it and say something's defective...

    Unfortunately Google is not well known for their customer service, up until android most of their stuff didn't really require much. It is yet to be seen what they do with android, but the few bugs that people really seem to be upset about don't seem to be getting much traction...
  19. citydodge

    citydodge New Member

    I had exactly the same problem with my galaxy which worked fine initially. Tried all in your list except factory reset. I connected the phone to Kies and upgraded to latest s/w (2.2) and all sorted. Though I did lose my 3g connection there are lots of threads to show you how to reset your APN details very quickly.
  20. sanrocz

    sanrocz New Member

    This is one solution which worked for me. I did not come across this solution anywhere online. I think I figured this out as I was having this issue and it was annoying.

    For me this issue happens after I download an app from market which corrupts my market app or screws up my sd card.

    Solution -

    Switch-off the phone, and remove the SD card.
    (P.S Side note: Market downloads and installs from market work fine without sd card. )

    After the SD card is removed I was able to uninstall the rogue app(Most probably the last installed app before the issue started). Then switch off the phone and reinstall the sd card and when the phone is powered again everything is back to normal. But this issue seems to recur frequently. I have Sprint EVO 4g.
  21. blago

    blago New Member

    I was having this issue as well: 4 downloads that were stuck at "download starting" and not going anywhere. The solutions for me was in restarting the phone (turn off the phone, select restart). After that, the downloads started and installed properly. Seems easier than reinstalling SD card or resetting everything :)
  22. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    Deleting the android_secure and LOST.DIR folders on your SD Card, then rebooting should resolve the issue.
  23. Addie90

    Addie90 New Member



    I tried disabling, re-enabling my wifi but nothing happened. I have xperia x10. Same problems regarding downloading. :(
  24. Ensiferumize

    Ensiferumize New Member

    I have this problem:
    I bought HTC Wildfire S last week. The problem is that when i go to android market to download some apps (library's WiFi), they just keep saying: "starting download" so i don't get them. This is a new phone, so i don't have any apps... so what's the solution?
  25. mzrv

    mzrv New Member

    ahhh! im having the same problem :mad:

Share This Page