Android market won't downloadSupport


  1. icemanjs4

    icemanjs4 Well-Known Member

    More than half the time, android market stalls On downloads. It gets as far as "starting download" but then nothing happens. It doesn't even time out,it just acts as if the download wasn't even happening. The problem is it's inconsistent, and then seeming goes away ion its own after 10 minutes

    Has anyone had this problem? Houw do you rectify?

    Thanks

    Advertisement
    la sal likes this.
  2. dbpaddler

    dbpaddler Well-Known Member

    I get that every now and then. Don't know why. The 3g symbol just turns gray. I usually hop on engadget or the web and that kickstarts 3g again which lets the dowloading kick back in.
  3. tbenson81

    tbenson81 Active Member

    I never had a problem until the latest firmware update. Now I have to try 10-20 times to get anything to download. Always gets stuck on "starting download'

    I tried clearing all the cache and histroy from google and market apps as suggested in another post but that didnt seem to help
  4. Richie18

    Richie18 Member

    Are you guys running Juice Defender? Sometimes Juice Defender won't re-enable 3G for me when i try to download from the market.
  5. dbpaddler

    dbpaddler Well-Known Member

    I am. I'll leave it disabled for a few days and see what happens with the market. But again, jumpstarting 3g by clicking on engadget or using the browser. Do that after you've started downloading and the market kicks back in.

    Also, haven't tried it as I think it's a paid version feature, but if you can select apps that utilize data you could just add the market to the list, I think.
  6. gme109

    gme109 Well-Known Member

    Samsung Galaxy S Market Download and System Restore Fix


    Step 1. Go to your settings

    Step 2. Select
    popeye10 and holan like this.
  7. jerbeck24

    jerbeck24 Well-Known Member

  8. dbpaddler

    dbpaddler Well-Known Member

    Temp fix: just start engadget or browse the web after you start downloading an app. That will kick the 3g in and the app will start downloading. It hasn't failed me yet.

    And with juice defender....I didn't disable it, but downloaded 3 apps today with zero issues while it was enabled. Can't figure a rhyme or reason to the issue.
  9. jerbeck24

    jerbeck24 Well-Known Member

    I tried this too today and it still didn't force my download to start! Kind of frustrating! I saw there was supposed to be a Market update from Version 1714 to 2007 [Link]. Maybe this will help? Hopefully something will fix this and soon.
  10. tbenson81

    tbenson81 Active Member

    I keep having the same trouble and I wish my market would update to the new version also but as of now I still have the old market verison
  11. megabiteg

    megabiteg Well-Known Member

    I've also seen that his problem has to do with an application occupying a lot of processor time space, it happens to me with Live wallpapers on. try to see if you have an application stalling in the background.
  12. jerbeck24

    jerbeck24 Well-Known Member

    Ok, I'll try it, but I'm pretty anal about ending running applications. I'd be surprised if that was the problem, but am hopeful!
  13. drexappeal

    drexappeal Well-Known Member

    I had this issue and also an issue of not being able to connect to the internet, so I couldn't download the OTA updates available either.

    I ended up having to hard reset the phone in order to download.
  14. megabiteg

    megabiteg Well-Known Member

    Try downloading Watchdog, this application evaluates the applications that are stealing processing time but also shows you the ones that are dormit in the background.

    This can help you determine which are really sucking the power of your phone, not the ones that are just consuming RAM. The ones that are consumers of your processor time spaces (while not being used) are the ones that consume both your battery and lags your phone. I saw this with a third party live wallpaper I downloaded: every so often the app would start consuming an big amount of processor time, and when that happened my market app would start showing these symptoms. Once I FC that program, the market app would work great and fast.

    I saw an article on this problem over at XDA and there was that I started using Watchdog instead of ATK or other software like them, since then my phone has worked great and even battery life has improved .
  15. icemanjs4

    icemanjs4 Well-Known Member

    I'm connected to wifi at my house right now. I clicked on watchdog from the market and said Install. It's now hanging at "starting Download". So there's no issue of needing 3g or anything. It's still refusing to start the download. What's wrong with this thing?
  16. holan

    holan Member

    I got a fresh epic. hit update. had the stuck on start downloading.
    didn't think your advice would work but it was worth a shot....

    and it worked perfectly. Thanks!

  17. holan

    holan Member

    hate having to do this often. i shouldnt have updated.

    (spoke too soon) having the problem again.
  18. Maci

    Maci New Member

  19. l400ex

    l400ex New Member

  20. foo_C_m

    foo_C_m New Member

    I carried out the following steps and it worked like a charm on Android (v.2.2) running on Viewsonic Viewpad 7:-

    (i) before even turning on my Android fone, go online using a PC to create a new GMail account
    (ii) turn on Android fone, use a USB wire to back up all SD Card and SIM Card data onto your PC first (for safety)
    (ii) then Clear Market cache (Settings > Applications > Market > Clear cache) as well as Uninstall all Market updates
    (iii)do a complete system reset back to factory settings (Settings / Privacy / Factory data reset)
    (iv) go thru the manufacturer's initial fone set-up procedure, register and sync using the GMail account you've just created

    Everything's cool after that.
    However, since you acivated a factory reset, all your local Telco's internet settings would be gone. This means you'd lose your internet-access on your Android fone after carrying out the above procedure. To rectify this, fone your local Telco after you
    carry out the above steps and ask them to take you thru the configuration needed under Settings > Wireless & Network > VPN settings and Access Point Names settings.

    And heres my
  21. l400ex

    l400ex New Member

    i found a zip file for the talk app in the site somewhere sorry not sure where but i donloaded the zip file to my phone used es file exploer to unzip and install and no more problems
  22. jimweda

    jimweda Well-Known Member

    Are you serious? You have to do a "Hard Reset"? Maybe I have my terminology wrong. I thought a hard reset was going into the settings menu>Privacy>Factory data reset. Every time I've had to call Sprint, (at least 100 times in less than 3 months) because I was having problems with my phone if their miracle "Pull the battery and wait 30 seconds." method didn't work they would tell me to do a hard reset which wipes out all data on the phone and you basically turn it into a fresh new out of the box mode.

    Do you mean pulling the battery, hitting power button and then powering off or the 3 button shutdown? I have been having problems with the Market hanging on downloads since I first got this phone in Aug of this year so I know its not this update or the last update that's causing it. If it is the software its been in there before the last update.

    What is irritating is that when it hangs and you go to "My Apps" while in the Market there is a stop button at the top right with an "X". It never works so I don't know why they even have it there. The only way I can get it to start working again is to reboot. I either pull the battery or just use the 3 button method to shut doing and reboot. Usually I can go to the Market and download at least one app without any problems. I've had rare occasions where I have been able to download up to 10 apps without an issue. More often than not thought within 5 downloads it goes into that stupid "downloading" or "installing" loop and I have to reboot. I thought I was the only one that was going through this problem because I never saw any other posts about this problem.

    I never have this problem at Amazon or GetJar, I'm not sure what's up with the Market but I wish they would fix it. I hate having to reboot my phone all the time. I wish there was another option for the Market that had a large selection of apps. They seem to have the largest selection and sometimes the only place you can find an app. GetJar is great but small selection and Amazon doesn't have as much except when they have some great apps in the Free App of the Day. Both Amazon and GetJar have daily free apps and I've downloaded some really good apps, well at least for me. Things like OfficeSuitePro which is a $14 app. SwiftKey X which is also a paid app, some good games etc. Its definitely worth checking them every day. I'm just waiting and hoping for SPB 3D Shell to show up but I highly doubt it because of the developers. I just can't justify spending $15 for a Home Launcher app. Its nice but not $15 nice plus it still has some bugs and force closes. No more than $5 is what I'd pay for it. I did get a chance to play around with it for a couple days and I really do like it.

    Well, I hope someone figures out how to fix the Market issue. It is really annoying.

    Jim
  23. brucemon

    brucemon New Member

    My android (EVO4G) had the same issue with Sprint TV, Sprint Football and eventually all app downloads and updates. Clearing the cache and data from several applications freed up enough space to let the video run correctly and also allow all downloads which were blocked before. Here's the link for resolving a number of android download problems. I used solution D. Hope this helps.

    my android won't download apps

    brucemon :)

Share This Page